OpenSUSE 11.1 64bit and Vista x64 Bootloader Screwup


well, here is the issue I have been facing with the Suse installation. I have two HDDs in my system, a 15krpm SCSI that I use as primary HDD and installed SUSE on there, and a SATA HDD that I have Windows Vista installed in there.

The problem is that OpenSUSE set up keeps putting the darn GRUB onto the SATA drive, wiping the boot sector for Vista. I have been trying everything to get this stupid thing to write to the SCSI drive instead, but it seems like either I’m missing something or there are no options for that when I boot from the SUSE DVD and run the software repair.

I have tried disconnecting the SATA drive and loading the GRUB, but as soon as I connect the SATA drive back all the screw-ups start again.

I don’t usually install dualboot, this is the first time I’m trying to get these two OS working on the same system. I hate Windows as much as GRUB does, but I have to get this thing working.

What is the proper way of adding a windows entry in bootloader?

ok, so it seems like I have lost the MBR on my Windows Vista drive. I know I could get it back if it were XP by booting from the CD and getting into the command prompt (using fixboot, fixmbr), but that doesn’t seem to work right in Vista (like everything else) because it does not even detect the Vista installation when booting from Vista DVD and selecting the repair option.

How can I fix the Vista mbr now? anyone has some experience with that at all?

I really want to fix Vista rather than reinstalling it since it took me an entire weekend to install and update it. it is not as easy as OpenSuse to install and updating and installing drivers is a real pain. It takes a long long long time! Please help.

You can fix vista boot (we hope!) this way:

Insert the Vista installation disk and proceed to the final screen where you have the option to Repair Your Computer. Select Repair but do not opt for the automatic repair plus restart. Instead select Next and then select the Command Prompt. Enter bootrec.exe /FixMbr in the console and follow that with the command exit. Then select to reboot.

Awesome, Thank you so much. i’ll try this as soon as I get home tonight.

Can anyone please tell (or point me to where I can find) what is the proper way of adding a windows boot partition to GRUB please?


Nevermind, I found a little thing on your site That I’m going to try:

Let my try this fist and see how it works out.

I got it fixed thanks to this article here:

Boot Multiboot openSUSE Windows (2000, XP, Vista - any mix) with Windows bootloader.

even tho I did not follow all of it, but found some nice little things in there that I had not think of trying.

now I have ended up with two boot loaders, one on each disk!!! One is the nice OpenSUSE one that also points to Windows disk, the other one is the Vista multi-boot menu, that also points to Linux… Thought about getting rid of the Vista one, but too scared to touch it! it’s ok… if one of them breaks I can always change the boot device priority in the BIOS and still get in!!! rotfl!

Thanks you swerdna, I really appreciate your help.

Well done, you’ve got your bootloader situation tuned to perfection. Baden Powell would be proud.