openSUSE 11.0 and intel 4965agn card

hey i just tried a fresh install of openSUSE 11.0 on my dell d830 notebook which has an intel 4965agn wireless card. This card worked out of the box on opensuse 10.3 but im having issues in 11.0. it detects fine but i cannot get it to connect to my network. i set everything to the same way it was in openSUSE 10.3 and double checked it all but when i try to connect it just fails. i feel its also worth noting that when i go into yast network devices to change the card’s configuration during the suseConfig at the end it crashes the network manager. i also feel its worth noting that in 10.3 i was running the 2.6.22-default kernel and in 11.0 i have tried both the 2.6.25-[pae/default] kernels and both of these react the same. also i checked in the hardware section of the yast network devices and it says that the driver it is using is the iwl4965 driver which is the one i used in 10.3.

i read on Intel® Wireless WiFi Link 4965AGN that this driver is built into the kernel 2.6.24 and up and that the developers driver does not work in these kernels. does this effect the functionality of my network card?

so what my question really boils down to is does anyone know if there is a problem with the (k)networkmanager or is this a kernel/driver related problem? i have seen bug reports relating to the knetworkmanager needing fixing but all of the ones iv seen were wpa related not wep.

i seem to have found a reasonable substitute. i tried out the ifup traditional method rather than the networkmanager method and this works fine. i guess that the latest version of network manager has some bugs that need working out. i would guess that we see updates to it in the near future (im not sure but the version number of the current network manager is leading me to assume that it is a release candidate or beta)

I don’t have first-hand experience, since I don’t have this device. But, my
reading of that Intel posting is that, yes, it affects your card, and yes, it
is kernel/driver related.

Since I’m an ndiswrapper lover (i.e. never found a card that it wouldn’t work with),
I’d suggest you try that:
Ndiswrapper - openSUSE

Hope this helps…

already figured out its not driver related since i can get a connection if i switch to the ifup method. (k)networkmanager was the problem. it would crash when i tried to configure the card from yast2 with an error code 11 and it glitches out when i tried to connect to wireless networks. the kinternet with ifup will be a suitable substitute for now until networkmanager is updated, iv already seen several bug reports about it relating to similar problems (but not the same).

have you tried using the compat-wireless drivers?

try this, here

I have the exact same problem with the AGN4965. It didn’t work on 10.2 even with ndiswrapper, worked perfectly on 10.3, and now is not working again on 11.0. I got it working with ifup. KNetwork crashes during the network config. It’s hard to know if it’s a driver problem or KNetwork.


It’s Knetwork manager. It appears it has it’s old quirks about which cards it will work with. even the broadcom card i have had working since 9.3 works intermittently with Knetwork manager now.