openoffice missing fonts after 11.1 install

I just installed 11.1 on laptop and i was checking out my openoffice install and I noticed that fonts set is very limited. I am missing fonts like Arial, Times new roman and others. I have another pc running 11.1 and openoffice there has all the fonts. I went through Yast and I have the same products installed as the good pc.

Any ideas on what might of happened and how would i get the complete list of fonts.

Thanks

Start the software installer and install fetchmsttfonts. During install it will ‘fetch’ the fonts for you. Normally those get installed during online update.

You can normally pick up the MS TrueType fonts through Yast>Online Update. On the left select Filter: Patches, and Show Patch Category: All Patches. Scroll in “Summary” for the title “optional” towards the bottom; below that find and select “Download and …”. Install the update called “pullin-msttf-fonts”.

Hi
If that and pull-in rpm doesn’t work have a read here;
<http://forums.opensuse.org/applications/420940-msttf-font-install-error.html>


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
up 3 days 15:19, 3 users, load average: 0.13, 0.23, 0.21
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

Malcolm, that pull-in rpm should work since it references the bug that originally prevented it on the first 11.1 online update. IIRC that’s how I installed it.

When I go to install/update the fonts recommend above I receive a the message fetching done, then extract failed delete. The same message scrolls over and over, so fast i am unable to capture the url it is referencing. I get kent.dl.sourceforge/…/~.exe.

it appears it is tryig different source for the package and keeps failing until it quites.

any ideas.

Malcomlewis,

I failed to look at your post closer before i posted my last reply. I looked at the link msttf font install error - openSUSE Forums and copied and pasted the updated script provided by the link fetchmsttfonts-11.0-5.1-1 - nopaste.com (beta).

I ran the updated script and the fonts installed and everything looks good.

I want to thank you and the others for all the help.

kellykare

Malcolm,

Maybe you can explain this one; now after I ran the script suggested. I no longer have any sound, which i had on cnn.com and yoursmoothjazz.com and i was able to play cd’s and dvd’s. I get picture with dvd’s but no sound.

I am stumped and have no idea why i would lose the sound from this type of update.

please advise.

Hi
Sounds like that may have been related to other updates pulled through
and not related to installation of fonts…

Sound volume hasn’t snuck down on the Desktop environment, else have a
look in YaST->hardware->sound and select the other button in the
right-hand bottom corner -> volume and check that as well.

Else have a look at the stickies in the multimedia subforum and after a
read, post a new thread there as I’m no sound guru that’s oldcpu’s
field :wink:


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
up 3 days 23:05, 2 users, load average: 1.88, 0.68, 0.49
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

The official update for the msttf-fonts to update the sourceforge url’s just arrived in my opensuse updater applet. A short wait would have sufficed, but glad you managed to get them anyway. :slight_smile: