Open With File Manager does not open using the Default Application

In System Settings -> Default Applications, I’ve set Dolphin as my File Manager (I’m on KDE).

However, in some places, when I rightclick on a folder and choose Open With File Manager, a different app that’s not Dolphin gets opened (used to be Gwenview, now after installing QDirStat that has become the one that opens). If the dialog looks like this:
(which I believe is KDialog), then things are fine, I can right click and open in Dolphin. However if the dialog instead looks like this
then the above problem occurs. In this latter dialog, it takes double clicks (instead of single click) to open folders, and the arrangement on the left side is different - there are no categories like Places, Devices, etc. I’m guessing non-KDE-native programs open up this type of dialog, so I’d like to know how to configure these also to Open folders using Dolphin always.

I mostly use the command line as my file manager, so I might not have the best advice.

Go to System Settings → Applications

Click on “Default Applications” (the left column), and check what is set for File Manager. Here, it says “Dolphin”

Then click on “File Associations”. That allows you to tweak for some file types. Here “Gwenview” shows up for image types such as “.jpg”.

Thank you! The File Associations part helped, in a weird way. The Default Application was already set to Dolphin as I had mentioned in my post, but I had missed the File Associations tab entirely.

It turned out that even in File Associations, under inode/directory (which is the relevant association), Dolphin was set as the first priority association - **but **it still helped because I tried a Move Down and then a Move Up back to the same original position and then did an Apply, and that somehow fixed it!

This seems likely to be some bug in some layer of this, because this also happened with another file association. Today I found out that png files were for some reason opening in the Wine Internet Explorer (!). I checked that too in the File Associations list. Wine IE was third on the list, but for some reason was getting chosen to Open with, despite Gwenview being the top association for png files. So I did the same thing there - did a Move Down on Gwenview and then a Move Up back to the top, pressed Apply, and bam, now png files open in Gwenview correctly.