Only Root login OK -- nothing else is after upgrade.


System WAS 11.1 (32bit) 4GB RAM dual core AMD with MSI MOBO w/ NVidea built in adapter.

MOBO apparently died.

So now running ASUS, 8GB RAM, dual core AMD (same as before), but I have upgraded from 11.1 to 11.2 (32bit) to 11.2 (64bit) trying to get around what I found to be an ATI driver problem (forums).

The new MOBO has ATI Radeon. I have spent a week trying to get past problems with it. Started reading the problems in the forums, and so pulled a GeForce 8600 GS off a shelf and put it in this system (it was originally bought for this workstation – but it and the now dead MSI MOBO didn’t like each other).

Ok, here is where I have gotten. I can login with root (don’t start the root gui rant, you are preaching to the wrong person), but I can’t log in with my power user account or with the normal workstation user’s account (my wife). It makes no difference if I do this with the failsafe or default boot (Grub is only showing the two).

I have run yast to remove anything to do with the ATI drivers. And once that completed, ran it to pull in Nvidea drivers and config routines. That all seemed to run OK.

When I try to login with other than root, the login fails with (and this is off the top of my head):

Failed runlevel 5:

And then, you just hang. So I swapped to virt screen 1 and logged on as root and issued shutdown now -r.

I have tried to swap users, and that is also a disaster where a reboot is needed to get going again.

I also can’t seem to get the nvidea config software to startup and run. Yast has run the software management module to verify the system, and nothing shows a missing requirement.

Any ideas?

Honestly this sounds a mess. Personally I would backup important data and do a new, clean, de-crudified install of 11.2

It probably would be a mess if someone did this that doesn’t work on other systems doing upgrades and plans each step in the process. :wink:

At each iteration, I booted the machine and checked that things looked good. I even migrated from SDx# to DEV ID and have that quite correct (fstab and GRUB).

The migration to 11.2 (32bit) was done as a step to 11.2 64bit – which was being done to take advantage of the extra 4GB RAM. And that was when the ATI issues started. :open_mouth:

Since my file server has been running 11.2 64bit with an ATI Radeon adapter for almost a year, I figured when I got to 11.2 (64 bit) for the workstation that should solve the problem – except the drivers have been mugged since I did that upgrade. >:(

But if it is that this is really the best way to get to 11.2 64bit, all I have to do is backup a few OEM RPMs to the /home partition and rebuild the user accounts… :\

Since my file server has been running 11.2 64bit with an ATI Radeon adapter for almost a year
Perhaps you mean a different version as 11.2 was released in November 2009.

There are choices and you seem to know what they are. I was just suggesting, IMO, the route I would take, as a option for you.

Upgrading from 32 bit to 64 bit is truly a bad idea. Upgrading in general does not rewrite config files thus they are still set on the assumption that you are running 32 bit. Also exiting 32 bit libraries may cause problems. In many cases you need the 32 bit version of 64 bit lib not a 32 bit lib. Yes confusing isn’t it. But if you are running the 32 bit version it can cause problems.

IMO it is best to do a clean install and save the home partition from formating any time.

Yes, 11.2 seemed like a year w/ all the grief over ACPI and RAID1 in going from 10.3. I forgot that I build a new root (/) partition just for 64bit – because I was out of space in the 32bit root (/) :open_mouth: !!

And now that I think about it, only the /home partition lived through all that. So I am, even as I type this, backing up to a 1TB USB drive (don’t get one, they are slower than [fill in blank here]). And once it is done, I will commence wiping out the scrambled root (/) partition and build another SWAP (2GB swap against 8GB RAM doesn’t seem right to me – but hey, I’m a z/OS sysprog/developer at my day job).

This is unbelievable. I’ve pointed the installer to a new drive (unused but waiting), and the partitioning, install all went OK.

However, GRUB now goes to 1.5 then 2.1 (or 21) with a loader failure. This is without ever putting up a menu.

This is like an old country song here in the USofA, “… if it weren’t for bad luck, I’d have no luck at all. Gloom, despair and agony on me.”

I had thought all this had been fixed with the public release of 11.2! I knew of some of the problems (because my server uses Raid 1) that RC1 & RC2 had. But this is just incredible :open_mouth: !

Have no idea why you are having such problems. :’( It installed simple and sweet for me. :stuck_out_tongue:

Maybe a little more about the hardware might point to something.

Ok, problem was BIOS had re-ordered the drives. :beat-up:

So, I disconnected the drives I don’t care about for “right now” and rebuilt grub. Now it boots.

Ok, so I got a Knoppix CD out and went and editted my /etc/fstab so that the drives I don’t care about are not in fstab.

This allowed me to boot the system and get it mostly running. :slight_smile:

At this point I shutdown and re-attached the drives, fixed the BIOS to present them in the correct order, and rebooted. Then I went into the partitioner and labeled the partitions of the old system for my benefit.

Then I put the entries back into the fstab (of course I’d saved a copy – I may be a noob, but I wasn’t born last night). Then the requisite reboot.

Ok, now I copied the /home directory of the OLD system to the new /home partition (which is also mounted as /home). And then I built the users, and told it to not wipe out the directories but take them over (I had copied using root, so they were probably owned by root).

And here I am again, able to logon as root, but I can’t logon as any of the users that I’ve defined! :’(

I finally rebuilt VMware Player (addresses the vmware service) so that it and vmtoolsd would stop being flagged as failed in run level 5.

Now attempting to login as one of the users, what I get from KDE is the “disk” shows up about 2 seconds after the screen changes from the logon screen. Then about 19 seconds later the tools and planet (www?) show up. :slight_smile: And then nothing, nada, zip. I honestly don’t know where to look for a log to see what is going on because <Esc> doesn’t work at this point to show me what is happening.

Where do I go from here?

  1. Linux use the UID number to identify the users. If they do not match you have a problem . Make sure the new UserIDs (UID) match the old ones. Can be done in Yast from a command line.

  2. You have setup the users in the new install right. It is more then just having the /home directories.

I fixed it. :beat-up:

I went back and did an install of the 11.2 64 bit (just to be clear) on the new drive (root and /home). – Not an update, but a take over for those two partitions.

Then I defined the primary user’s ID. After that, I copied the user’s info from the old drive to the new drive, with autoskip.

The only headache after that was the total loss of the bookmarks for Firefox. :frowning: And that was after I went back and copied the firefox directory. And that probably means all the user-ids and passwords.

A few more rounds with Yast and VMware Player was able to rebuild and run. The Windows/XP system has no idea that all this was going on. :slight_smile:

One or two more mods should finish things, but I will get to that later (needing the dual monitors to work from Nvidia).

So I think I’m done here.

What I learned:

  1. You can’t do an upgrade from 32bit to 64bit. You have to take over the root partition (at a minimum) to jump to 64bit.

  2. You CAN logon with root, but apparently AFTER you login to a userid.

  3. You can get the “old home data” for a user, but you have to login on the user account and do the copy from there (i.e., do the copy of the old “home/uid” to the current /home while logged into that user account and skip/autoskip things with the same names). After that, selectively pull back things of the same names.

“What a long strange trip its been.” Grateful Dead.

Live and learn eh!