one of my guest is paused and dont resume anymore


My guests was working fine and now one of them is not running anymore, could someone help me to run it again?
I have tryed virsh resume many times and reboot the server again and it does not work

What VM what host what guest any error message? Need lots more information then it is broke :open_mouth:

Generally speaking,
The way “Pause” or “Suspend” is implemented by all virtualization technologies is to store the machine state in a separate file in the same location where the virtual disk, configuration and likely memory backing files are stored.

I don’t know what file extension libvirt uses to store this file, on vmware it’s “.lck” (short for lock).

Typically, when the machine can’t resume it means this file is corrupted.
Simply removing (or if you want to be safe in case you make a mistake, rename to a different file extension or move it to a location that libvirt doesn’t read) this file enables you to do a cold boot which is the best available option.

Of course never suspend a machine if you’re in the middle of important work.
Always save your work in a reliable manner so if you have to recover, your work isn’t lost.


The vms is automatically mounted everytime the localhost is rebooted. One of them just paused and i couldnt make it run manually, is there anyway to resume this? Is there any other reason to it comes paused?

I found the reason!
The disk is full.

df -u shows the used
1st VM is working fine 80% used
2nd VM is paused 100%

How can i access to release some data if it is paused? ‘-’

The correct procedure is to expand the disk (to a larger size).
The exact procedure and utility used to do this depends on your disk format (QCOW? Raw? Something else?

It’s not too much different than working with a physical disk except for this option to first expand the disk.
Once your disk has been expanded, then you will want to use a utility like gparted live to move and enlarge the partitions on the disk, and when done… voila! - A running system, where you can then go in and remove dead files if you wish to free up even more room, and then maybe even defrag and maybe if this is a dynamic disk compress the disk to improve performance further.

As always, always work on a copy of the virtual disk in case what you’re working on becomes corrupted.



I dont have disk available to expand my server. I talked to my boss and he allowed me format the disk, I have made backup of my vm which is working, if i kill this vm will I be able to expand my 2nd one to enter and make my backup?

I’m pretty sure you misunderstood me.

I said to expand the <virtual disk>, not do anything to “expand your server” physically.
When you expand your virtual disk, you’re “magically” making your virtual disk larger which is the equivalent of cloning a smaller physical disk to a larger physical disk, but using the <same> disk. In other words, this is something that can’t be done in the physical world, but is commonly done with virtual disks.

I hope you haven’t done anything to your original physical disk storage holding your virtual disks…


nooo haha… Not yet, but the problem is that my disk is full, totally full. My entire server has 500GB, my primary is small just have conf of both virtual machines, each machine has pratically 250GB each. One of them is 80% full and the other is 100%. The other problem is that the guy who made this put each vm into a different partition in the server. I cant increase more cuz it is rlyyy full. And thats why im asking if i can simply erase the partition smaller so i could make the backup of the other and then i can format my server and start all over again and make this in a easy way for me to go on.

well, I did it, i formated the first partition and i remade this but smaller then before and tryed to increase the second one, right?
Anyway when i tryed to resize my second vm for i can enter and make my backup I run resize2fs /dev/sda3
But i dont know why this command is not working to increase the partition, when i run fdisk -l or df -h the partition has the same lenght then before.
Do u know why is this comand “resize2fs” is not working?

From the first partition i release 50GB to resize the second.

I need to open this partition no matter how.

Is your virtual machine “virtual disk” a file or a raw file system?
Set up properly, your virtual disk should be a file and not a partition or physical disk.

If you are currently pointing to a physical partition or disk, I’d recommend you take the time to either run a P2V utility or “dd” the physical file system into a backing file which can be used as a virtual disk. There are many advantages and new features if you use a backing file instead of pointing to a raw file system.

If you need guidance, you need to post a clear description of your situation, possibly including your virtual machine configuration file and the results of “fdisk -l”

And, as should be expected… If your virtual machine is running on a physical partition or disk, you can’t re-sze physical objects (like /dev/sd*).


Hi Tsu,

I remade the procedure, but i didnt remade the partition sda4 and then i could resize the partition and i kept work. I appreciate your help. Thank u very much. Im doing the backup :slight_smile: