OMG what has happened to Suse

I was a fan of Suse in the 9.X days. I love YAST. It is the best system config tool around. Zypper sucks. I tried to install 11.2 rc2 and went to nvidia site to get driver since unlike ubuntu I have to install manually. I get a prompt that says install missing plugin (like ubuntu):slight_smile: Great I select the flash plugin and next thing I know the system is doing a complete 700 freaking meg update. You great Novell developers don’t see this as a problem? Try to install Ubunku/Kubuntu and see how easy things are. You should be able pull your collective brain power to make Suse what it used to be. I think you got something stuck in the Zypper…lol

O.K. That was the lamest I have seen yet.

  1. nVidia has not released the propriatary driver yet. You can’t blame SUSE.

  2. Flash plugins for nVidia’s site are not handled by Novell.

  3. This guy sound just like the last one. Starts his story very similar.

I am also still trying to figure out what YaST and Zypper have to do with going to nVidia’s site.rotfl!

I wondered the same thing…I went to install something using the “Install Software” link in the menu, did a search, marked it for installation, next thing I know, its downloading 700MB of stuff including Java? WTH is this all about?? It’s totally confusing.

I’ve used Ubuntu and Arch, I wasn’t as confused with either of them…

Why is it downloading and installing 700MB of seemingly random things?

What did you mark for install?

Just tried to install ‘make’ so I could install the Virtual Box Additions, never did get it done, because when I saw 700MB of stuff (JAVA?!) being downloaded I stopped it.

You have to have more than just MAKE marked for install. Was it also ready for updates? Had you already changed the repositories to the new 11.2 repos?

I have NO clue, I’m a new OpenSUSE user, this was done with RC2 a few days ago, all I did was mark ‘make’ for installation, that was it.

In order to help, we need to know what was installed. YaST does have a way to show history of what was installed.

I’ll bet it’s updates. The updates repo is set to a priority of 20. The others are 99 to 100. The lower the number, the higher the priority. So updates has the highest priority.

But I am only hypothesizing right now.

At this point, I’d already installed updates, according to the update notifier in the panel. This was a fresh install of RC2 inside Virtual Box 3.0.10. I was trying to install the additions and it required make, and GCC and kernel headers, all of which weren’t installed, so I just wanted to install make, I found the “Install Software” link in the menu, clicked it, searched for make, it came up, right clicked it, marked it, proceeded, BOOM 700MB’s of stuff, including java. I stopped it when I sawa 700MB, as I KNEW make isn’t 700MB

If you are a new user, why are you trying to install test software? If I were going to try Ubuntu for the first time, I would not start with their unstable software. I would be trying something that I would not expect to have any problems with.

You’re right. Make would not be 700 MB. Something else already had install priority. You would have to open it up and select it again to see what all is showing up.

Typical responce when somone doesn’t have the answer lol…

I’ve been using Linux for a while, most Debian based distro’s and Arch Linux.

I tried 11.1 last year, and it was not to my liking, I figured a final release candidate would be stable enough to use. In fact, it’ll be ‘stable’ in about 24 hours.

I’m knew to SUSE, to RPM packages, etc, not to Linux. My experience included running Ubuntu alpha’s and never having a major issue, and if you’ve ever heard of Arch Linux, then I don’t even need to speak of it.

As it stands now, however, I will wait until 11.2 is out “for real” and attempt all of this again. I look forward to learning about SUSE, RPM package management, and the community, and hope I’ll be able to offer something back to the community after I get my bearings aligned.

I’m telling you. I install Kubuntu and I can…from in the kde environment install proprietary drivers for nvidia and install flash plugins without downloading 700+meg of other updates. I have done this on many pre-release versions. It is possible and basically just quior boy saying it can’t be done

If you point the repos to the new 11.2 repos, and run ‘su zypper dup’, it will update to 11.2. It will probably be a few hundred MB.

I’ve heard of Arch.

openSUSE does not contain the proprietary nVidia drivers. You have to get them from nVidia. I checked a few hours ago and they were not in the nVidia repository. They most likely will not be there till Thursday. Sometimes, they a bit later than that.

If you had updates waiting to install, then that might account for the 700MB. That seems a bit large even for the first updates, but we don’t know what all you selected to install.

So what’s so hard about providing the history. If you’d already done the updates, we’ll be able to see that. Their are time stamps on this.

So I see it as you are either wanting an explanation of why this happened. Kind of a support request. Or you are just venting, not wanting support. In which if you’re venting, then you have accomplished that.

On Wed, 11 Nov 2009 04:36:01 +0000, robertlafler wrote:

> . I install Kubuntu and I can…from in the kde environment install
> proprietary drivers for nvidia and install flash plugins without
> downloading 700+meg of other updates.

I would point out that Kubuntu is in released state - 11.2 is still a
release candidate until it arrives tomorrow.

I expect the nvidia and other packages will be available shortly after
release.

Can you install the nvidia drivers on 11.2 RC2? Very likely using the
“hard way” listed on the wiki. But you are dealing with pre-release
versions at the point at which you posted, so packaging for proprietary
components may not have been completed yet.

Jim


Jim Henderson
openSUSE Forums Moderator

Guys,

Since this thread really belongs in the soapbox forum, I’m locking the thread to move it - will unlock after the move is completed.

Jim

Them move has now been completed and the thread has been re-opened.

Thanks,

Jim