Older hardware on 12.1? what are you running it on?

I’ve got 11.4 running on a Dell D420, 2GB ram. it runs great.

I’m considering upgrading it to 12.1 but thought i would see what others are experiencing on older hardware. I know the min req are P4 1GB of ram…

If i’m going to have fight the wireless card issue again i’ll just stick with 11.4 and wait to use 12.1 on the desktop i’m building (AMD Phenom II X6, 8GB, etc etc)

I have 12.1 currently running on my IBM Thinkpad T60 with a 1.66 ghz core duo and 1.5GB ram, intel graphics, with KDE 4.8 and it runs magnificently with desktop effects and everything. I would consider it older and I am happy with it.

Now this is just my personal opinion on the subject but may I suggest that if you have openSUSE 11.4 working just fine on your older computer and the fact that work has already begun on openSUSE 12.2, I think I would stick with what you have and wait to see how 12.2 turns out. My main PC still uses 11.4 and it works great. I have installed openSUSE 12.1 on a second PC and it also works just fine, but I have had a few oddities due to using systemd on 12.1. For instance, I have been playing with dkms, an auto kernel module compiler that can be used with VirtualBox for instance to recompile its kernel module after a kernel version update. dkms works great under openSUSE 11.4, but I have had problems getting it to work with openSUSE 12.1. These issues exist because not all applications have been properly converted over to support systemd. I expect on the next release for systemd support to be even better and to continue to get better. However, in your case, for several reasons, I suggest you stick where you are at and enjoy your hard work getting everything just right. When you get your new PC up and running, go for the latest version of openSUSE and let us know if you need any help.

Thank You,

I share the view that if openSUSE works well with version 11.4 there is no need to rush to 12.1.

My main PC (an Intel Core i7 920 w/6 GB RAM) is still running openSUSE-11.4 (although its in at the repair shop currently with a broken power supply). My wife’s desktop PC (Core i7 860 w/6GB RAM) is also running 11.4.

I do have openSUSE-12.1 on both my wife’s laptop (Lenovo X220 with Core i5 w/4GB RAM) and my older Dell Studio 1537 (Intel Core 2 duo P8400 w/4GB RAM).

My oldest PC running 12.1 is my ‘sandbox’ PC, which is a 12 year old athlon-1100 w/2GB RAM and an AGP FX5200 nVidia card (it has an MSI KT3 Ultra motherboard). I use LXDE on that ancient desktop to try help wrt the speed impact from running a slightly ‘heavy’ GNU/Linux distribution such as openSUSE. I do most my testing on that ancient desktop which I call my ‘Sandbox’ PC. In fact that ancient Sandbox PC is setup with 2 hard drives and partitioning sufficient to support FreeDOS and 4 x different GNU/Linux distributions. I currently have FreeDOS, openSUSE-12.1 GM (its main partition), Tumbleweed (in a test partition), and another openSUSE-12.1 GM (in another test partition on same PC) and an additional two ‘blank’ partitions where I could install a 4th GNU/Linux. I plan to replace the test partition that has 12.1 GM with one of the 12.2 milestones (as part of my ongoing testing).

oldcpu wrote:

> I use LXDE on that ancient desktop to try help wrt
> the speed impact from running a slightly ‘heavy’ GNU/Linux distribution
> such as openSUSE.

There are of course also very light distros out there, specially
tailored keeping small requirements in mind, like DSL.

But I think openSUSE as such is not any “heavier” than any other modern

It’s the bloated desktop environments that are “heavy”, in any distro.

I gave up KDE long ago, too, because of bloat.
It started to “take more than give” and I had to let it go and I haven’t
looked back.

I still run several KDE programs although my desktop is also LXDE here.


openSUSE 11.4 (x86_64) main host
openSUSE 12.1 (x86_64) 3.2.4-6-desktop Tumbleweed in VirtualBox
openSUSE 12.1 (i586) 3.1.9-1.4-desktop in EeePC 900

I have been running OS 12.1 (currently 12.2 Milestone 1) on an old Fujitsu Siemens Celsius H230 laptop just for fun and testing:
CPU: Pentium M at 2 GHz
RAM: 2 GiB
GPU: ATI Mobility FireGL V5000 564B (M26)

I use there KDE 4.7/4.8. It is not very fast, but OK for me, as I have a shiny new desktop system for the “hard work”.


It works fine here on a P4 3.0 w/ Hyperthreading, 2 GB DDR RAM, and a Nvidia 8400 GS. Both with stock as well as with KDE 4.8 as of yesterday.
All in all performance is very near what I saw even under Gentoo when I used only XMonad for a WM and went without a DE.

Bah, this is all blazingly fast hardware. :stuck_out_tongue: I’ve been able to successfully install OpenSUSE 12.1 onto a 1.8GHz single core AMD Sempron 32-bit laptop with 512MB DDR RAM and an IDE 75GB HDD spinning at an ungodly 4200 RPM.

“It’s the bloated desktop environments that are “heavy”, in any distro. I gave up KDE long ago, too, because of bloat.”

This word is an issue with me. It’s not “bloat”; the correct term is “features”. There was a user on DistroWatch who began telling a story about a user concerned about all of the “bloat” in a distro so he begins stripping out this and that, deciding he really doesn’t need almost anything and ends up at a command line. I appended my own ending in which the user begins complaining about ASCII and all of the ASCII codes dedicated to characters he never uses! rotfl!

I tried LXDE on this laptop but found it unacceptable to give up a zillion features (not even recently-used programs in the program launcher!) all for about 50MB more free memory. The same with XFCE. One of them didn’t want to remember touchpad settings either.

KDE is quite usable on this old 512MB laptop. Yeah, you’re not going to run VirtualBox or disk encryption on it, but you can run Google Earth, KMail, clementine, Banshee, Firefox with several tabs open. It can even play 720p videowith VLC and Kaffeine… at almost 100% CPU usage, but hey… I can almost have XBMC play 720p videos at an acceptable rate with it… maybe with a bit of tweaking. Since only the open source drivers are available for the graphics, 3D performance is poor (the chip is slightly less powerful than the desktop graphics card I had in 1999) but I’ve actually used WINE and been able to start up/play through a few minutes of the original Half Life and Dungeon Keeper II on it (neither of which worked for me any more under genuine Windows!).

Warning: rant/whine follows:
The only issue is after a few minutes under battery power (never happens on AC) X periodically shoots to 100% CPU usage and leaves the system unusable for minutes at a time. This has nothing to do with 12.1 as this happened on 11.4 and 11.3 and 11.2 and Gnome and LXDE and XFCE and PCLinuxOS and Sabayon and every other distro (even Scientific Linux and Debian) I tried it on except, I believe, for Puppy, but then they do strange things and use an antiquated something for the X server. This is the Kennedy assassination and Roswell of Linux bugs. :wink: I’ve found it listed in the bug trackers of many distros but no resolution. It mostly seems to affect AMD systems with the 200M Radeon Mobility graphics, but then you see isolated cases where Intel users are complaining (perhaps a second cause?) One OpenSUSE user claimed he’d found a way to reduce it to only happening once and posted a link to patches in a bug report, which some people said worked, but then he and his OBS repository disappeared, taking the patch with them! >:( I think “they” got to him. Unbelievably, the OpenSUSE bug tracker seemed to have developers saying to fix the issue they’d need to recompile a lot of other files and they just didn’t want to bother (?!?). The bug was closed even though there was no solution, and when someone posted a comment explaining it still existed he got kind of a rude answer. I have a feeling it’s something in the kernel itself innundating X, since it seems to happen under different distros and desktops. Sorry that’s so off-topic but if I could find a solution to this I’d be very happy. I bragged to everyone I knew about receiving this laptop for free because it had grown to be unusable under Windows XP (which is very swappy so the 4200RPM HDD/512MB combo was a performance killer) and made it usable again without any upgrades or cost, but technically I can’t use it under battery power so I ended up being embarrassed for Linux. The saving grace is the laptop is so big and heavy (6.5-7 pounds) with an approximately 2 hour battery life that one really wouldn’t want to use it with the battery much anyway.

On 2012-02-13 04:26, duncreg wrote:
> This word is an issue with me. It’s not “bloat”; the correct term is
> “features”.

No, it is bloat. Things like curved window corners or gradients of color,
animated window movements, etc, are bloat and take a lot of cpu. Things
that are done for show. A window is the same window without that and moves

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

The first system I put 12.1 on was a Dell D400 (1.8 Ghz(?) Pentium M w/1GB ram and Intel 855 video). It is the first distribution since early 2010 which handles my Intel video out-of-the-box and even provides desktop effects. Others I have tried with mixed results were Ubuntu and Fedora.

My current system is a Thinkpad T42 (1.8 Ghz Pentium M, 2 GB RAM and ATI video) running openSUSE 12.1 KDE. Except for a few things like tap-to-click on the trackpad, everything has been working as well or better than other distributions or operating systems.