Old program requiring libstdc++-libc6.1-2.so.3

Hi,

with the upgrade from 11.4 to 12.1, one old program stopped working:


fido@Telcontar:~> golded
gedlnx: error while loading shared libraries: libstdc++-libc6.1-2.so.3: cannot open shared
object file: No such file or directory

I try to search that in the oS search box, but it changes


libstdc++-libc6

into

libstdc  -libc6

Anybody knows if that library is still available somewhere, or I’m out of luck?

I do have the sources of Golded++, but it will not compile any more: GCC long ago complained
about hundreds of errors that previously were warnings, and I’m afraid Golded is no longer
maintained. Perhaps in some hidden Russian web or BBS, but I don’t read the language.

If I can not make it run, I will have to use a virtualized machine for the purpose.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Am 21.08.2012 00:58, schrieb Carlos E. R.:
> gedlnx: error while loading shared libraries: libstdc+±libc6.1-2.so.3: cannot open


zypper in compat #compat-32bit if you need that


PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

Just that you know I do not tell you nonsense


martinh@ganymed:~> rpm -ql compat
/usr/lib/gcc
/usr/lib/gcc/i586-suse-linux
/usr/lib/gcc/i586-suse-linux/2.95.3
/usr/lib/gcc/i586-suse-linux/2.95.3/crtbegin.o
/usr/lib/gcc/i586-suse-linux/2.95.3/crtbeginS.o
/usr/lib/gcc/i586-suse-linux/2.95.3/crtend.o
/usr/lib/gcc/i586-suse-linux/2.95.3/crtendS.o
/usr/lib/gcc/i586-suse-linux/2.95.3/libgcc.a
/usr/lib/libg++-3-libc6.2-2-2.8.1.3.so
/usr/lib/libg++-libc6.2-2.so.3
/usr/lib/libstdc++-3-libc6.1-2-2.10.0.so
/usr/lib/libstdc++-3-libc6.2-2-2.10.0.so
/usr/lib/libstdc++-libc6.1-1.so.2
/usr/lib/libstdc++-libc6.1-2.so.3
/usr/lib/libstdc++-libc6.2-2.so.3
/usr/lib/libstdc++.so.2.9
/usr/lib/libstdc++.so.2.9.0

it is in oss.


PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

On 2012-08-21 01:17, Martin Helm wrote:
> Am 21.08.2012 00:58, schrieb Carlos E. R.:
>> gedlnx: error while loading shared libraries: libstdc+±libc6.1-2.so.3: cannot open
>
>


> zypper in compat #compat-32bit if you need that
> 

Right! Indeed, that was. I did look at “compat” but did not see it. Thanks.

Golded works again, for another term of lease… :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 2012-08-21 01:25, Martin Helm wrote:
> Just that you know I do not tell you nonsense

No, no, your advice worked. :slight_smile:

The thing is that I looked in yast for a library named compat something, but it did not leap to
the eye, I did not find it. Maybe I typed the search with a typo, dunno.

When I copypasted the name you gave me, compat-32bit, I found it immediately, and it is working.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)