Old Flash/Nvidia problem: flash video peers through some windows

Ok, guys, i guess it’s about time this bug should’ve been fixed, but it still isn’t. In a few words: flash video just oozes through dark parts of the screen sometimes, depending on an app. Always seen in terminal. Funny thing is that if you make a screenshot it doesn’t get captured along with the terminal, screenshot shows normal blank space, which is why it’s impossible to provide a visual proof of the occurence.

A few extra details:

  1. It’s not a compiz bug nor has it anything to do with compositing of any kind
  2. It does not depend on a DE, i had this on Gnome (2.32, opensuse 11.4) and now i have it on XFCE (opensuse 12.2)
  3. It happens only using NVIDIA (while using proprietary driver. Not sure if only so, didn’t experiment with nouveau and nv, but eitherways doesn’t matter cause most people use the proprietary one)

So. 11.4, 12.1, 12.2… still there. I’ve tried looking up the issue on forums, but so far i’ve seen only complaints but no solutions. I’d like to know at least whether it’s NVIDIA driver problem or flash plugin on openSUSE. Never had anything like it on other distros. Any ideas?

I guess I do not understand the setup when having a problem. What do you have loaded at the time and from what are you trying to view a video in? And its not impossible to get a picture, that is what a real camera can do and post the image somewhere.

Thank You,

On 10/06/2012 12:46 PM, Zelator wrote:
> Ok, guys, i guess it’s about time this bug should’ve been fixed, but it
> still isn’t. Words aside, just have a look at this:
>
> ‘[image:
> http://s12.postimage.org/cz7os0xjd/Screenshot_10062012_04_04_26_PM.jpg]’
> (http://postimage.org/image/cz7os0xjd/)

why do you show us a picture of your desktop with an open terminal?

so, instead of “words aside” use a few to explain what you see that you
don’t like…

what specifically are you wanting us to see–that is, tell me where to
look to see an example of “flash video peers through”


dd

I guess i could use my phone as a cam, but i won’t bother since you don’t seem to be familiar with the issue. And no, it has nothing to do with preloaded stuff, it’s a known bug actually: http://forums.opensuse.org/english/get-technical-help-here/applications/457905-flash-image-bleed-through.html

But, thanks for the question about an app i play youtube videos in. It appears that it happens in Firefox and Opera, BUT… it doesn’t occur in Chrome/Chromium! Which is rather peculiar.

I don’t know how you saw that, cause i edited the post in a couple of minutes since i didn’t notice immediately that making screenshot of the problem DOES NOT capture the actual thing, it just comes out normal, which is why i edited the post and removed the link. And you came here much later, i dunno how you managed to see that. Anyways, forget about the screenshot, all neccessary details have been described.

On 2012-10-06 18:06, Zelator wrote:

> I don’t know how you saw that, cause i edited the post in a couple of
> minutes since i didn’t notice immediately that making screenshot of the
> problem DOES NOT capture the actual thing, it just comes out normal,
> which is why i edited the post and removed the link. And you came here
> much later, i dunno how you managed to see that. Anyways, forget about
> the screenshot, all neccessary details have been described.

I also see the link in plain view, it is not edited out. >:-P

(Why? you ask. Well, it is a feature of these forums.)

(hint: nttp)

About your problem: disable hardware accel in flash.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 10/06/2012 06:06 PM, Zelator wrote:
> i edited the post in a couple

ok…that explains it…reading in nntp i saw your note in the form it
was the first time you pressed Send (or Post, or whatever it says in
the web forum)…

so, now i have gone to the www and found your words and understand your
problem…so now say:

this is neither an openSUSE nor a Linux problem, but instead some
unintended interaction of Firefox, Opera, Flash and nVidia drivers…

as such, the fix must be made by them and posts here do little, if
anything, toward a solution…until those outside of openSUSE fix it
(don’t hold your breath) the solution for you is one, all or some mix of
these:

  • don’t use the nVidia driver
  • don’t use Flash
  • don’t use Firefox
  • don’t use Opera
  • don’t use desktop effects


dd

Yeah, very funny. Just a little correction here, i don’t use any desktop effects, and as i’ve stated above it doesn’t matter in my case.
Anyways, i’ve got even better solution for those in need: don’t use opensuse. Actually… don’t use any GNU/Linux OS. You’ll save yourself a lot of trouble.

P. S. Don’t live, it’s a waste of time and sometimes quite painful as well. Just die immediately :slight_smile:

> You’ll save yourself a lot of trouble.

proof once again that Linux is not for everyone…

sure, it take a little extra effort to be successful…

if one does not have the maturity, persistence, capability or
inclination to prevail then i agree: just quit, and use something a LOT
easier, no matter the price…

i hear Apple/Mac is good, but expensive and i’ve tried Android and can
attest it is as easy as falling off a log (but also free and Linux)…

so, there are options for all…no need to get snotty.

bye.


dd

It’s funny how you didn’t mention Windows. And i’m not being snotty actually, just sarcastic, cause you see… i couldn’t regard loads of “don’t use” as a serious advice. Sounded like you were trying to pull my leg there. Anyways, what matters now is that you probably don’t use Nvidia, you’re most likely on a laptop with Intel graphic card, which doesn’t give you any troubles. But hey… i want you to use Nvidia :slight_smile: And see who’s gonna be snotty then. Anyways, thanks for all. Especially for Apple/Mac thing, that was the “best” advice ever given to me here, haha

On 2012-10-06 23:36, Zelator wrote:

> doesn’t give you any troubles. But hey… i want you to use Nvidia :slight_smile: And
> see who’s gonna be snotty then. Anyways, thanks for all. Especially for
> Apple/Mac thing, that was the “best” advice ever given to me here, haha

I don’t know from your description if it is the same thing I had using nvidia, but if it is, I
repeat: disable hardware accel in flash, it is broken.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 10/06/2012 11:36 PM, Zelator wrote:
>
> It’s funny how you didn’t mention Windows.

friends don’t let friends drive drunk–nor recommend inherently unsafe
operating systems to them.

> i couldn’t regard loads of “don’t use” as a serious advice.

it was very serious (and sound) advice! the reverse of what i posted is:
Use what works!

that is: if nVidia + Flash + Firefox does not work, then use what
works!(while waiting on nVidia and Adobe to fix their stuff)

> Sounded like you were trying to pull my leg there.

then what you heard/read was not what i wrote/meant.

> Anyways, what matters now is that you probably don’t use Nvidia,

my just previous daily driver used nVidia and i loved it–[sigh] that
box died and sits lonely in the corner waiting for some love.

i highly recommended nVidia for years, it was the best and
easiest…now, not so much–unfortunately.

> you’re most likely on a laptop with Intel graphic card, which
> doesn’t give you any troubles.

true (but it is a tiny, Atom based netbook–which sips electricity in
Europa’s highest electricity rates)

but that is no help to you!! what helps you is: Use what works. (or,
don’t use what does not work–and if you do continue to use what is
broken then you don’t need to tell us it is broken, we KNOW that
already…and we can’t force either Flash or nVidia to work together to
make you smile…)

> But hey… i want you to use Nvidia :slight_smile: And
> see who’s gonna be snotty then. Anyways, thanks for all. Especially for
> Apple/Mac thing, that was the “best” advice ever given to me here, haha

really, most folks here are happy to recommend to use what works:
don’t like KDE? try Gnome.
don’t like openSUSE? try (in alpha order)
Arch/Debian/Fedora/Kbuntu/Mint/Ubuntu/ etc etc etc etc
don’t like nVidia+Flash+Firefox? try to disable hardware acceleration
don’t like nVidia+Flash+Firefox+disable hardware acceleration? try Opera.
don’t like Linux? try Apple or Android.

simple, this is not rocket science: Use what works–don’t use what does
not work.

ymmv (no snot included)


dd
http://tinyurl.com/DD-Caveat

On 2012-10-07 08:27, dd@home.dk wrote:
>> i couldn’t regard loads of “don’t use” as a serious advice.
>
> it was very serious (and sound) advice! the reverse of what i posted is: Use what works!
>
> that is: if nVidia + Flash + Firefox does not work, then use what works!(while waiting on
> nVidia and Adobe to fix their stuff)

From his description, I’m not sure if it is the same problem I had. I had a flash animation in
the page from my bank, and when I switched workspaces, the flash animation sat there alone in
top of an openoffice document, in top of gnome terminal… so what? It is a known issue, just
disable hardware accel in flash, like it or not. It is not an option.

So I don’t understand what is the problem.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Thanks. Now that sounds more like a decent advice. However, i repeat: it happens only using Nvidia. And only on Opensuse. At least i never encountered the same thing on Debian and a few other distros.

While not wishing to get into some sort of fray here, can I ask what happens if you do not load the nVIDIA driver? I have been doing some testing this weekend on two PC’s, one with a nVIDIA 275 and the other a 450 and I have got the nouveau driver working on both just fine and with 3D. I can visit the iTunes web site and view any movie trailer I wish to see (using Totem 3.4). On the 275, the openSUSE 12.2 Plymouth startup works great but on the 450, it does not work, creating an out of horizontal sync looking view. Otherwise, everything else works great without installing the nVIDIA proprietary video driver and you can disable Plymouth if you wish.

What testing has been made using nouveau driver? Do consider that you must remove the nouveau blacklist if it exist, enable KMS and remove the nomodeset kernel load command from your grub 2 load parameters in order for the latest nouveau driver to work. Just something more to think about.

Thank You,

Ok, i disabled hardware acceleration, it helped. Thanks to all who cared.

As for other distros… possibly the feature was disabled in those by default, which is why i never ran into this issue before. So i never bothered even checking it up. Solved.