Okular wont print

openSUSE 12.3
KDE 4.10.5r1
Okular 0.16.5

I down loaded a PDF, opened it with Okular and it opened just fine. It is a 4 page document.

However if I do a print preview, there are no pages shown and it indicates that there is only 1 page.
I tried a print and the printer warms up but does not print anything.

I am able to print a test page just fine.


Could be a bug in poppler which okular uses.
Can you upload the PDF to SUSE Paste and post a link so I could check it?

You can also try to use Adobe’s acroread to print it, this should be installed by default. If not, install the package “acroread”.

Wolfie, I am trying to figure out how to use Openpaste. Let me see if I can attach it to an email or PM.

Acroread works just fine so I will continue to use it, though I hate it. rotfl!

Have you tried okular with a different PDF file?
It’s likely that it just has a problem with this particular file.

At least “Print preview” works fine here. I just tried it with the Virtualbox manual…

As suspected, this seems to be a bug in poppler.
pdftops generates an invalid PostScript file out of that PDF.

Yes, other files work fine.