okular do not always show filename of opened files

if I open a pdf file usually okular show me in the title bar the filename followed by “- okular”, but this do not happen for every pdf file, for some file on the title bar appear:
“XSane scanned image - okular”, why this???, how can I have the filename also for that files??? it is an okular bug or feature??? it is a plasma bug or feature??

many thanx, ciao :slight_smile: pier :slight_smile:

It’s a feature.:wink:

If the current document defines a document title (you can check with File->Properties), this is shown by default instead of the file name.
But this can be configured in Settings->Configure Okular… (“Display document title in title bar if available”).
You can also configure there if you would like to be shown the full path of the document or just the file name.

…I was supecting it…:slight_smile:

I checked in File->Properties but cannot find titles…

…oookk, this works… maaanythanks :), :slight_smile:
ciao :slight_smile:

If you open a document with a title, this title is shown in the dialog opened by File->Properties, see here:
And this is what gets shown in the title bar instead of the filename by default, if the document has one.

If you want to do the same as the example above, use the hyperref package in your LaTeX file with the appropriate entries or select Document>Settings>PDF Properties in LyX.

…found it…:), I was looking at file properties right-clicking on the file icon in dolphin…:slight_smile: