Oki C5100 and OpenSuse 11.2

Hello, I’m not very experienced in linux so bear with me with guys

I’m running OpenSuse 11.2 and I have a Oki C5100. I ran the connection wizard and I put in its IP and that part when fine but Linux doesn’t have a built in driver for this printer and it isn’t a postscript printer so I cant just use any postscript driver like I’ve gotten away with before. I found the foo2zjs driver (which says it will work with the Oki C5100) and download it and followed all their instructions on foo2hiperc: a linux printer driver for HIPERC protocol and I get as far a extracting it. then it says to go to the directory it extracted to and run the command “make” but when I do it doesn’t work just comes up with a command not found error.

I really like OpenSuse and I would make it my desktop OS if i could this printer working.


You need to install “make” utilities.

zypper install make
zypper install automake

Also, you may need other stuff like the gcc etc. Anyway, do the above stuff and they try…

I’ve had an OKI c 3100 colour laser printer which worked fine under XP.
But when I changed to openSUSE, there was no way to get it working under 10.3. 11.0 or 11.1 did not work with it, too.
My first way was, to call OKI for support.
First, this hotline was very expensive, second, they kept me in a line for about 10 minutes, only to tell me third: There is no and there will never be a way to install an OKI printer on a Linux-Distro.
They were really unfriendly. They wasked me, why I want to use such a distro? Win would be sooooo nice and suitable for users…and the whole things, eyerone of you know.
Second try was, to find a solution in the Internet (this is when I came across this forumlol!). But nothing worked:P.
My solution was, to sell the OKI printer, keeping openSUSE and to buy a HP printer. Worked out of the box without doing any cryptical installations.
OK that might be no solution for you in the moment, but for me, OKI is out of the race with such statements.
I am affraid, there must be solved lots of difficulties before you can get your OKI running and there will be no support from the producer.

Thanks that helped very much got it working. but I print out of the multi purpose tray because the paper gets jammed in the bottom one. is there any way to make it print from the multi purpose tray? I there is no way thats okay I’m getting the printer fixed soon.

No idea. See if there is any setting to disable it from the printer itself. Honestly, I have never seen an OKI printer in my life!