Oh no! Something has gone wrong

First of all, here is my computer
Gateway Support - 450SX4 Specifications

Gateway 450SX4
512 MB Ram
ATI MP-6 or M6-P, I cant remember which way it goes
OpenSUSE 12.1

The message I am getting is:

A problem has occurred and the system can’t recover. Some of the extensions below may have caused this. Please try disabling some of these, and then logout and try again.

Problem: Alternative Status Menu

I disabled it and logout, but then I cant login, it doesnt load or anything when I click on my name. Do I need to reinstall or find a new distro of linux?

At login
switch to IceWM session

Try logging in

FYI: IN IceWM use right click on the workspace to get a menu

Alright what causes this though?

openSUSE supports most PC hardware components.

The following requirements should be met to ensure smooth operation of software.opensuse.org: Download openSUSE 12.1:

  • Pentium* III 500 MHz or higher processor (Pentium 4 2.4 GHz or higher or any AMD64 or Intel* EM64T processor recommended)
  • Main memory: 512 MB physical RAM (1 GB recommended)
  • Hard disk: 3 GB available disk space (more recommended)
  • Sound and graphics cards: supports most modern sound and graphics cards, 800 x 600 display resolution (1024 x 768 or higher recommended)
  • Booting from CD/DVD drive or USB-Stick for installation, or support for booting over network (you need to setup PXE by yourself, look also at Network install) or an existing installation of openSUSE, more information at Installation without CD

The GRUB bootloader co-operates with other operating systems on the same machine. openSUSE can be installed on one free harddisk partition, while preserving existing installations on other partitions.

You meet the minimum requirements, but I feel your problem can be two fold, low memory and the ATI video card, both of which may conspire to give you a problem. You really need to 1 GB of memory, in my opinion and you most likely need to use the kernel load option called nomodeset. Now consider a corrupted installation can also create such a problem and I might suggest a new install OR, perhaps you do want to find a distro that needs less system memory. Here is such a list:

Mini Linux Distros

Thank You,

Yea I think its corrupted cause whenever I click on anything in the login menu, it crashes after a few clicks. So I guess rollback to other distros

Im not sure if guys handle with other distros of linux, even though they are quite similar. With all the distros I have used, none of them have found my video card ATI M6-P in my model of laptop.

Gateway Support - 450SX4 Specifications

I cant find any driver on linux or anything is there a solution to this?

I found an interesting link below suggesting a modification to the xorg config file (/etc/X11/xorg.conf)

ATI Mobility Radeon 7000 - ThinkWiki

And it suggests you add the following section …

Section "Device"
       Identifier      "ATI"
       Driver          "radeon"
       Option          "AccelMethod" "XAA"
       Option          "AGPMode" "4"
       Option          "AGPFastWrite" "yes"
       Option          "EnablePageFlip" "on"
       Option          "RenderAccel" "on"
       Option          "DynamicClocks" "on"
       Option          "BIOSHotkeys" "on"

You would need to restart your PC to see if this helps. To edit this file in KDE use the following command:

Alt-F2 and type: kdesu kwrite /etc/X11/xorg.conf

In general you have three strikes against you trying to overcome this issue …

  1. This is an older Video chipset.
  2. This is an ATI (AMD) video chipset often less supported than Intel or nVIDIA.
  3. openSUSE 12.1 often requires you add in the kernel load option: nomodeset which users such as yourself seem unable or unwilling to use or try.

I am not sure what else to say or do but to wish you all of the best with this video problem.

Thank You,

Dang this stinks. Trying to install xubuntu yet it is going nowhere. The screen loads but then goes black and nothing occurs. I remade the disk and still nothing

So you did not indicate if you have tried any of my previous suggestions. Further, having the same problem with other distributions simply points to a problem with the built-in video driver of the kernel of your video chipset. While there are lots of differences with how Linux distributions are put together, the kernel support is about the same everywhere.

Thank You,

Alrighty, well I decided to go back to Ubuntu since that is the only working distro for me at the moment. Now I am trying to find a video card driver for the ATI M6-P but cannot find any on amd.com.

So is that all I need to put in the xorg.conf file from above? Cause right now I have no xorg.conf file.

openSUSE, since version 11.4, needs no xorg.conf file to work, but your default video setup is not working so I would give my suggestion a try. Can’t say about Ubuntu of course as I don’t use it. Good Luck.

Thank You,

I have tried to upgrade to stable 12.1 x86_64 and now cannot start the system. I have the same error message the you @xSilverhandx note. My system is a Dell Precision M4500 with 8-core i7, 8GB DDR3 and nVidia Quadro FX880M. openSUSE had been running fine, but in preparation for installing VirtualBox to run Windows, I thought I would update to the latest stable 12.1. Is there any workaround to this Oh no!? I can only logout and come back to the same Oh no!

Your best solution to to do a clean install of openSUSE 12.1 and elect to do custom partitioning. You should find your swap partition mounted as swap and require no change. Mount the existing root / partition as /, and set it to be formatted. Mount your existing /home as /home, but DO NOT Format it. Mount Windows as /windows/C or what ever you want, select the big partition and don’t mount any small ones and** DO NOT Format** them. Allow the install to complete. You will often need to add/use the kernel load option called nomodeset and on any install that does not start your selected Desktop, the nomodeset kernel load option may be required. I always load the nVIDIA proprietary video driver, for best video response. Once complete, just reload any applications you were using before and your old settings will still be there, since you did not format the /home partition. You asked and this is what I would do. Ask for more detail on any of these individual items in my procedure.

Thank You,