OBS package will not build binary rpm's

Hey guys,

I’ve been messing around with OBS the last few days trying to get it build a custom kernel for me. I can get it to output the source, sym etc rpms but it will not output the compiled kernel rpm. I’ve tried a bunch of different methods but it appears that even with using a _multibuild file it is ignoring the directive to run through kernel-binary.spec.

I’m using the official opensuse kernel sources from http://download.opensuse.org/repositories/Kernel:/openSUSE-42.3/standard/ as a base and I got OBS to import them into the package when I created it.

My repo is here: https://build.opensuse.org/project/show/home:m3ph:kernel

If anyone can point me in the right direction I would really appreciate it.



Build.opensuse.org shows timeout.
And packages does not build. It shows “Service in progress”.
This is since ca. 12:00
status.opensuse.org shows all okay. :pensive:

Yeah, I made a change before I went to bed and it seems to have completely screwed it up. I’ll have a look and post back when I get the issue replicated.

It looked like the change I made to the metadata was the cause so I deleted all my projects but even after recreating them from scratch they are still stuck servicing. Seems a little weird. I’m gonna leave it till tomorrow and see if it clears up. The whole site seems a little slow for me atm so it could just be really busy.

It’s running a build right now. the logs seem to indicate it is still not building the binary. Any ideas?

So i’ve been screwing around with this and finally decided to rebuild the package from scratch. I ended up just linking to kernel: opensuse-42.3/kernel-default. I copied everything right down to the meta file. The only difference is I didn’t copy the repo setup. Instead, i set my build target as kernel: opensuse-42.3/standard. The build now fails but it is trying to build from the correct spec file (kernel-default.spec) the problem it is now failing with the following error:

   75s] scripts/kconfig/conf  --silentoldconfig Kconfig   75s] *
   75s] * Restart config...
   75s] *
   75s] *
   75s] * Multiple devices driver support (RAID and LVM)
   75s] *
   75s] Multiple devices driver support (RAID and LVM) (MD) [Y/n/?] y
   75s]   RAID support (BLK_DEV_MD) [M/y/?] m
   75s]     Linear (append) mode (MD_LINEAR) [M/n/?] m
   75s]     RAID-0 (striping) mode (MD_RAID0) [M/?] m
   75s]     RAID-1 (mirroring) mode (MD_RAID1) [M/?] m
   75s]     RAID-10 (mirrored striping) mode (MD_RAID10) [M/?] m
   75s]     RAID-4/RAID-5/RAID-6 mode (MD_RAID456) [M/?] m
   75s]     Multipath I/O support (MD_MULTIPATH) [M/n/?] m
   76s]     Faulty test module for MD (MD_FAULTY) [M/n/?] m
   76s]     Cluster Support for MD (MD_CLUSTER) [M/n/?] m
   76s]   Block device as cache (BCACHE) [M/n/y/?] m
   76s]     Bcache debugging (BCACHE_DEBUG) [N/y/?] n
   76s]     Debug closures (BCACHE_CLOSURES_DEBUG) [N/y/?] n
   76s]   Device mapper support (BLK_DEV_DM) [M/n/y/?] m
   76s]     request-based DM: use blk-mq I/O path by default (DM_MQ_DEFAULT) [N/y/?] n
   76s]     Device mapper debugging support (DM_DEBUG) [N/y/?] n
   76s]     Keep stack trace of persistent data block lock holders (DM_DEBUG_BLOCK_STACK_TRACING) [N/y/?] (NEW) aborted!
   76s] Console input/output is redirected. Run 'make oldconfig' to update configuration.
   76s] ../scripts/kconfig/Makefile:37: recipe for target 'silentoldconfig' failed
   76s] make[2]: *** [silentoldconfig] Error 1
   76s] /home/abuild/rpmbuild/BUILD/kernel-default-4.4.85/linux-4.4/Makefile:563: recipe for target 'silentoldconfig' failed
   76s] make[1]: *** [silentoldconfig] Error 2
   76s] Makefile:150: recipe for target 'sub-make' failed
   76s] make: *** [sub-make] Error 2
   76s] error: Bad exit status from /var/tmp/rpm-tmp.NtRMIr (%prep)
   76s] RPM build errors:
   76s]     Bad exit status from /var/tmp/rpm-tmp.NtRMIr (%prep)
   76s] lamb75 failed "build kernel-default.spec" at Tue Sep  5 07:14:21 UTC 2017.
   76s] ### VM INTERACTION START ###
   79s]    70.201737] reboot: Power down
   79s] ### VM INTERACTION END ###
   79s] lamb75 failed "build kernel-default.spec" at Tue Sep  5 07:14:25 UTC 2017.

Does anyone have any idea where I screwed up? I already tried running the config through “make xconfig” locally against the source files for the repo so it lists the correct kernel version at the start.

Just changed the build target so it’s matches as well. We’ll find out in a few minutes if that worked or not.


It failed. FFS!