OBS and "Failed to create aac streaming encoder (simple output)"

After reorganising codecs (YT media clips did not play in FF) found an error when starting OBS, “Failed to create aac streaming encoder (simple output)”. Solution was to install

librist4 - Development files for librist

should this library to be in dependency list too?

https://susepaste.org/39151638

weird, “Error” part is missing from susepaste section. Anyway, uninstalling librist library is reason of “aac streaming encoder” message and OBS just closes.


info: [obs-browser]: Version 2.18.7
info: [obs-browser]: CEF Version 95.0.4638.69 (runtime), 95.0.0-MediaHandler.2463+g3b3ac84+chromium-95.0.4638.69 (compiled)
error: os_dlopen(/usr//lib64/obs-plugins/obs-ffmpeg.so->/usr//lib64/obs-plugins/obs-ffmpeg.so): librist.so.4: cannot open shared object file: No such file or directory

warning: Module '/usr//lib64/obs-plugins/obs-ffmpeg.so' not loaded
info: [obs-websocket] [obs_module_load] you can haz websockets (Version: 5.0.1 | RPC Version: 1)
info: [obs-websocket] [obs_module_load] Qt version (compile-time): 5.15.7 | Qt version (run-time): 5.15.7
info: [obs-websocket] [obs_module_load] Linked ASIO Version: 101201
info: [obs-websocket] [obs_module_load] Module loaded.

Hi
That is a third party package, you need to follow up with the folks at Packman, see https://lists.links2linux.de/pipermail/packman/2022-November/017280.html

After trying to use OBS Studio and being unsuccessful, I ended up using flathub to get it. After seeing this thread, I uninstalled the flathub version, and am not using the one in yast. Glad I saw this thread!