Dear all
I am having problems configure nxserver and nxclient.

nxserver is configured to listen at port 5920
SSHDPort = “5920”

sshd is configured to listen at port 5920
Port 5920

I can connect to that pc by using ssh -v myipaddres -p 5902
which means that I get a prompt I enter password and I work directly with my files

I can also get connection to nxserver by using nxclient
I add the right ip address and the right port number
I use as user name as I use with ssh
It seems that I get connected with my nxserver as I get the message Verifying user. I get a prompt to insert the ssh key (only the first time) and then everything fails. I get the message

'Authentication failed for user … ’

I check nxserver manual and I also tried to use the default keys… but still the problem persists.

I also checked using nmap that my services listen to the right port.
I also restarted all the services many times just to be sure

What should I do?
I am really stuck here


I know nothing about nxserver or client but I have one remark :slight_smile:
Only one process can listen at one IP address at a given port.

  • Why do You successfully connect to ssh on port 5902 if it listens on 5920 ?
  • Are You sure sshd and nxserver both listen on the same port ?
  • Could You post “netstat -apn” output here ?
  • Did You check your firewall configuration ?

FYI nmap is used to test which ports are open on a machine. netstat is much better for checking on which ports your server listens.

Best regards,

  • It was a typo.
  • Yes, think so
  • netstat -apn | grep 5920
    tcp 0 0* LISTEN 1963/sshd
    tcp 0 0 TIME_WAIT -
    tcp 0 0 :::5920 :::* LISTEN 1963/sshd
  • Firewall is disabled!

As You can see sshd is listening on all ipv4 interfaces and all ipv6 interfaces on port 5920 so nxserver can’t listen on any interface on the same port. Why don’t You switch it to listen on a different port or switch sshd to listen on something else ?

Best regards,

From the “/usr/NX/etc/server.cfg” file used by nxserver:

Specify the TCP port where the NX server SSHD daemon is running.

SSHDPort = “5920”

The nx server manual says that they have to run on the same port. Nxservers runs over ssh. I get connection but the problem is that I get some error while I autheniticate my user.

Ah ok so I guess it’s forwarded trough ssh (porbably something like X11 forwarding) but I’m sure it can’t listen on the same port. Anyway I’ve got no idea what the problem is. Hopefully someone that knows something about NX server will see this thread. Good luck.

Best regards,

Your port settings in /usr/NX/etc/server.cfg and /etc/ssh/sshd_config are correct. The problem is more likely wrong ownership in /usr/NX/home/nx/.ssh, non matching dsa keys on both sides or missing or wrong known_hosts file. I’m not sure about the later since I’m using freenx in the first place. You might want to try that one. You can actually use both on 2 different ports and have freenx forwarding incoming nomachine clients to the nomachine nx server. The nomachine server allows only 2 connections per server while freenx doesn’t have that limit.