nvidia update (340.65 -> 340.76) fails

Opensuse 13.1 x86_64
Asus Nvidia 210 silent

today there is an nvidia update to 340.76

after the update i restart pc
no gui

i try to restart with “recovery” mode then no gui
i start another OS
i set all to start with nouveau
i start opensuse
i open a kde session
i open a root konsole
i search the nvidia installed packets
i see that all 5 340.76 packets are installed but also 2 340.65 packets : the 2 kmp desktop ones !
i uninstall all packets
i installed the five 340.76 packets
i run mkinitrd
i check nouveau is blacklisted and no_kms_initrd = “yes” and nomodeset in grub boot statement
i restart pc
no gui

here is the xorg.0.log

here is what i find in “messages” file

2015-02-05T10:15:05.103998+01:00 linux-b4lz kernel:    18.488951] nvidia_uvm: Unregistered the UVM driver
2015-02-05T10:15:05.104012+01:00 linux-b4lz kernel:    18.616954] NET: Registered protocol family 17
2015-02-05T10:15:05.239878+01:00 linux-b4lz systemd[1]: Started Privoxy Web Proxy With Advanced Filtering Capabilities.
2015-02-05T10:15:05.253368+01:00 linux-b4lz kdm[2753]: plymouth is NOT running
2015-02-05T10:15:05.291010+01:00 linux-b4lz kernel:    19.110631] NVRM: Your system is not currently configured to drive a VGA console
2015-02-05T10:15:05.291029+01:00 linux-b4lz kernel:    19.110637] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
2015-02-05T10:15:05.291031+01:00 linux-b4lz kernel:    19.110639] NVRM: requires the use of a text-mode VGA console. Use of other console
2015-02-05T10:15:05.291033+01:00 linux-b4lz kernel:    19.110641] NVRM: drivers including, but not limited to, vesafb, may result in
2015-02-05T10:15:05.291035+01:00 linux-b4lz kernel:    19.110643] NVRM: corruption and stability problems, and is not supported.
2015-02-05T10:15:05.316017+01:00 linux-b4lz kernel:    19.135797] nvidia_uvm: Loaded the UVM driver, major device number 250
2015-02-05T10:15:05.353140+01:00 linux-b4lz systemd[1]: Started Postfix Mail Transport Agent.

I have the same card and had no problem with the update. The problem seems to be this.

  1.     24.420] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
  1.     24.420] (EE) NVIDIA:     system's kernel log for additional error messages and
  1.     24.420] (EE) NVIDIA:     consult the NVIDIA README for details.
  1.     24.499] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
  1.     24.499] (EE) NVIDIA:     system's kernel log for additional error messages and
  1.     24.499] (EE) NVIDIA:     consult the NVIDIA README for details.

Are kernel-source and kernel-syms in sync with your kernel version?

here are the installed packets :

linux-b4lz:~ # rpm -qa | egrep “nvidia|kernel”
linux-b4lz:~ #

there is no error installing with “zypper in”
with previous version of nvidia no need of kernel source and kernel syms

don’t forget that i use opensuse 13.1

Remove the nvidia kernel module packages and install them fresh:

sudo rpm -e --nodeps nvidia-gfxG03-kmp-desktop nvidia-uvm-gfxG03-kmp-desktop
sudo zypper in nvidia-gfxG03-kmp-desktop nvidia-uvm-gfxG03-kmp-desktop

If you get an error message, please post it.

And it is perfectly normal that you still have the old version “installed” after an update. That’s because of the kernel multiversion feature (you also have more than one kernel installed).
Removing the older version might actually remove the files of the newer version, so don’t do that, unless you install the newer version afterwards.

this time i get error messages when installing nvidia uvm packets
see here

There are no errors, just warnings and notices.
Everything seems to have worked fine.

I suppose you changed /etc/sysconfig/kernel again to get nouveau to work? Set NO_KMS_IN_INITRD=“yes” in this file, and run “sudo mkinitrd” (to be sure that there’s no nvidia or nouveau driver in the initrd), and reboot.

If it still doesn’t work, please post Xorg.0.log again.
If you don’t get a GUI, reboot to recovery mode (“Advanced Options” in the boot menu) and post Xorg.0.log.old. You should not have a need to get nouveau to work (it won’t work fully anyway as long as nvidia is installed).

i installed again the nvidia kmp desktop packets then now no more pb .


Excellent! Thanks for this. I had this EXACT same problem with the 340.76 update running on 13.1. Here’s the steps that solved it for me (summarized from above):

sudo rpm -e --nodeps nvidia-gfxG03-kmp-desktop nvidia-uvm-gfxG03-kmp-desktop
sudo mkinitrd
sudo zypper in nvidia-gfxG03-kmp-desktop nvidia-uvm-gfxG03-kmp-desktop
sudo mkinitrd

Everything’s great now! Thanks again!