Nvidia ION Driver install

I am sort of new to the linux scene. I have a little ubuntu experience, and have been playing around with opensuse 11.4. I was wondering if anyone could help me get the driver for my nvidia ion installed. I downloaded the latest nvidia driver from their website and tried using this guide.LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Page 3 I was able to get to the point where I login as root, it finds the nvidia driver, i select " I accept" and then I get errors about CC and gcc. It do not have the exact error in front of me, but I think it said something about making sure CC was in the same directory as the driver and make sure GCC was installed.

anyone else have this issue or get around it? Is there a better way to install the driver? I really want hardware acceleration, as youtube practically crashes the computer hah.


Ok, i got that issue sorted by loading three packages from yast, but now i get this error…

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Fri Sep 30 15:13:22 2011
installer version: 280.13


option status:
  license pre-accepted               : false
  update                             : false
  force update                       : false
  expert                             : false
  uninstall                          : false
  driver info                        : false
  precompiled interfaces             : true
  no ncurses color                   : false
  query latest version               : false
  no questions                       : false
  silent                             : false
  no recursion                       : false
  no backup                          : false
  kernel module only                 : false
  sanity                             : false
  add this kernel                    : false
  no runlevel check                  : false
  no network                         : false
  no ABI note                        : false
  no RPMs                            : false
  no kernel module                   : false
  force SELinux                      : default
  no X server check                  : false
  no cc version check                : false
  run distro scripts                 : true
  no nouveau check                   : false
  run nvidia-xconfig                 : false
  sigwinch work around               : true
  force tls                          : (not specified)
  force compat32 tls                 : (not specified)
  X install prefix                   : (not specified)
  X library install path             : (not specified)
  X module install path              : (not specified)
  OpenGL install prefix              : (not specified)
  OpenGL install libdir              : (not specified)
  compat32 install chroot            : (not specified)
  compat32 install prefix            : (not specified)
  compat32 install libdir            : (not specified)
  utility install prefix             : (not specified)
  utility install libdir             : (not specified)
  installer prefix                   : (not specified)
  doc install prefix                 : (not specified)
  kernel name                        : (not specified)
  kernel include path                : (not specified)
  kernel source path                 : (not specified)
  kernel output path                 : (not specified)
  kernel install path                : (not specified)
  precompiled kernel interfaces path : (not specified)
  precompiled kernel interfaces url  : (not specified)
  proc mount point                   : /proc
  ui                                 : (not specified)
  tmpdir                             : /tmp
  ftp mirror                         : ftp://download.nvidia.com
  RPM file list                      : (not specified)
  selinux chcon type                 : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> Installing NVIDIA driver version 280.13.
-> Running distribution scripts
   executing: '/usr/lib/nvidia/pre-install'...
-> done.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
ERROR: The kernel header file '/usr/src/linux/include/linux/version.h' does not
       exist.  The most likely reason for this is that the kernel source files
       in '/usr/src/linux' have not been configured.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.

Hi there,

Please try this:

cd /usr/src/linux
make prepare

Then re-run the nVidia installer. Make prepare creates symlinks (largely related to architecture dependent assembly files) which are required for building kernel modules, etc. Unfortunately this is not documented in the README in the kernel source directory, though you can see what it does in the Makefile and in the output when you run it. Another handy make target to know is make scripts


And by the way, welcome to the forum. Hope you enjoy using Suse.

Good on you for jumping right in there an learning how to do things, and for asking intelligent questions and providing all the info. Good show.


thanks for the help man. i tried your steps, but i still got the same error. crazy huh?

thanks man. so far this forum has been great. There is tons of info on here, but I have to admit, it is a little intimidating. I am so used to installing things, next, next, next, finish hahah.I have played around with ubuntu and stuff which seems a little easier, but I had issues getting the drivers to give me hardware acceleration on it, so I decided to go to suse. I used suse probably like 6 years ago to just play around, but gave up very after about a month. This time, I will not be denied.

Hey there,

Okay, let’s check a few other things.

1 ) When you say you got the same error, do you mean it is still saying

ERROR: The kernel header file '/usr/src/linux/include/linux/version.h' does not
       exist.  The most likely reason for this is that the kernel source files
       in '/usr/src/linux' have not been configured.
  1. If you ran make prepare (as root) you should have seen output like this:

linux-fcqg:/usr/src/linux # make prepare
  CHK     include/linux/version.h
  CHK     include/generated/utsrelease.h
  HOSTCC  scripts/basic/fixdep
  HOSTCC  scripts/basic/docproc
  CC      kernel/bounds.s
  GEN     include/generated/bounds.h
  CC      arch/x86/kernel/asm-offsets.s
  GEN     include/generated/asm-offsets.h
  CALL    scripts/checksyscalls.sh

Did you see the above when you ran make prepare?

  1. Please post the results of running these two commands:

rpm -qa | grep kernel
rpm -qa | grep glibc

It may be that you simply don’t have the kernel source and kernel headers installed.

  1. Lastly, please upload the entire log file found at:


  1. The easy alternative?

Yes, compiling drivers and software in Linux is far different than in Windows. Of course, you are taking the long road here as well. What I mean is that you can install the binary (pre-compiled) Suse Nvidia driver, you usually do not have to compile it from source unless you want to or have a specific need.

In fact, the driver is available via one-click install from: SDB:NVIDIA drivers - openSUSE

You might find that is the fastest route to get things working.

(You can also configure the nVidia repository and install that was too, also described at the above link.)

Lastly, if you need, you can compile it yourself as you are attempting, and you can find more information on doing this at: SDB:NVIDIA the hard way - openSUSE

Lews Therin