Nvidia GeForce 7300 GT resolution problem. Need Help!

Hey all.
My english is rly bad, but i will try to explain the problem.
A’m new to OpenSuse.
Installed OpenSuse 2 days ago on my older PC that has GeForce 7300 GT videocard.
Here is the problem

  1. after opensuse instalation i could not see a thing, realy bad graphics, so i swiched to onboard videocart (motherboard) and everything was ok, so i searched for drivers, found them installed
  2. after instalation gt 7300 works ok, but resolution is 640x480, the only option actualy.
    So am asking how do i make it max…

Which drivers did you install (apparently the wrong ones) and how?

Please post the output of:

rpm -qa | egrep "(nvidia|kernel)"

And the file /var/log/Xorg.0.log might help as well… Please uploade it to http://susepaste.org otr similar and post a link.

Installed drivers thro Yast the ones he offeres

Here is the link for first ur request http://susepaste.org/5459287

here is the second one http://susepaste.org/43315258

if i get it right it loads NOUVEAU driver

So you have “nvidia-gfxG02-kmp-default” installed, which should support your card.

But what kernel are you using?

uname -a

If it’s kernel-desktop (which is the default), you need “nvidia-gfxG02-kmp-desktop”

No, it loads fbdev. The nvidia driver packages prevent the loading of “nouveau”, as otherwise the “nvidia” driver could not be loaded.

And as expected, you are using kernel-desktop, so “nvidia-gfxG02-kmp-default” doesn’t work:

    11.485] Current Operating System: Linux linux-z6ak 3.11.6-4-desktop #1 SMP PREEMPT Wed Oct 30 18:04:56 UTC 2013 (e6d4a27) i686

Uninstall “nvidia-gfxG02-kmp-default” and “kernel-default” in YaST and install “nvidia-gfxG02-kmp-desktop” instead.

Linux linux-z6ak 3.11.6-4-desktop #1 SMP PREEMPT Wed Oct 30 18:04:56 UTC 2013 (e6d4a27) i686 i686 i386 GNU/Linux

So i search for -dectop drivers right ?

No, -desktop. :wink:

See my previous post.

Uninstall “nvidia-gfxG02-kmp-default” and “kernel-default” in YaST and install “nvidia-gfxG02-kmp-desktop” instead.

Uninstalled nvidia-gfxG02-kmp-default… but cant find the “kernel-default”

It must be there and installed, as nvidia-gfxG02-kmp-default requires it.

Type “kernel” into YaST’s search field and you should see it.

there is nothing called “kernel-default” in Yast when i type in search bar kernel.
If i type in “kernel-default” i see only kernel-default-devel

There is:

If you cannot find it, just run this to uninstall it:

sudo zypper rm kernel-default

There is no kelner-default installed at all not even 1, still the problem remains

Yes, kernel-default did not cause your problem. I only advised to uninstall it because you don’t need it and it takes up hard disk space unnecessary.

So, do you have nvidia-gfxG02-kmp-desktop installed now?
Try to re-install it by right-clicking on the package and choosing “Update Unconditionally”, or running this:

sudo zypper in -f [FONT=Tahoma]nvidia-gfxG02-kmp-desktop

Uninstalling “nvidia-gfxG02-kmp-default” might have disrupted it as well.

If that doesn’t help, please post the output of the commands I asked for previously again.

Sorry, something went wrong with copy/paste.

You should run this instead:

sudo zypper in -f nvidia-gfxG02-kmp-desktop

Loading repository data…
Reading installed packages…
Forcing installation of ‘nvidia-gfxG02-kmp-desktop-304.119_k3.11.6_4-30.1.i586’ from repository ‘nVidia Graphics Drivers’.
Resolving package dependencies…

Probleem: nothing provides gcc needed by nvidia-gfxG02-kmp-desktop-304.119_k3.11.6_4-30.1.i586
Lahendus 1: do not install nvidia-gfxG02-kmp-desktop-304.119_k3.11.6_4-30.1.i586
Lahendus 2: break nvidia-gfxG02-kmp-desktop-304.119_k3.11.6_4-30.1.i586 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/l] (l):

This happened
or the full part http://susepaste.org/35382466

How did you install ‘nvidia-gfxG02-kmp-default’ then in the first place?

You need “gcc”, but apparently this isn’t available either (just like kernel-default).

Please post your repo list:

zypper lr -d

What happens when you try to install “gcc” manually?

sudo zypper in gcc

This happened
or the full part http://susepaste.org/35382466

Yes, you cannot install it because you don’t have gcc and make, which among other things are needed to compile the kernel module.

So you chose “break nvidia-gfxG02-kmp-default-304.119_k3.11.6_4-30.1.i586 by ignoring some of its dependencies” as well before?
You should never do that, unless you’re 110% sure.
And if you do something like that when somebody tries to help you with a problem, you should mention it!
In this case, it causes the kernel module TO NOT BE INSTALLED!
So it’s just the same as you wouldn’t even have nvidia-gfxG02-kmp-xxx installed at all!


I was trying to do it by myself b4, sorry…

You disabled the standard OSS repo:

#  | Alias                     | Nimi                               | Lubatud | Värskenda | Priority | Tüüp   | URI                                                                                    | Service---+---------------------------+------------------------------------+---------+-----------+----------+--------+----------------------------------------------------------------------------------------+--------
 7 | repo-oss                  | openSUSE-13.1-Oss                  | Ei      | Jah       |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                               |        

Enable that either in YaST->Software Repositories, or by running:

sudo zypper mr -e 7

Then reinstall the nvidia-gfxG02-kmp-desktop packages as before and the driver should work.

Btw, you can directly copy/paste text in your post as well, if it’s not too long.
You don’t have to use an external site for that.

But you should use

 tags in that case (the '#' button in the editor's tool bar).

> I was trying to do it by myself b4, sorry...

No need to be sorry. ;)
But you should tell such things, otherwise we might waste hours searching for the reason why the driver is not working.

Ty, now it looks much better with 1024x768… can i make it bigger ?

It should automatically use your monitor’s preferred/native resolution.

You can change it in KDE’s “Systemsettings”/“Configure Desktop”->“Display and Monitor” or with nvidia-settings, run this f.e.:

kdesu nvidia-settings

If the resolution you want is not available there, you have to create a custom mode line, see here:

If that’s the case, your monitor either reports a wrong resolution or none at all.
Disconnecting it completely (even the power plug) might fix it.
Some KVM switched might also cause a problem like this, so try to directly connect it to the graphics card if you use one.

/var/log/Xorg.0.log should tell what the monitor reports.