Nvidia G05 driver is broken with new Tumbleweed Kernel 6.2.0-1-default

After upgrading to kernel 6.2.0-1-default the driver of nvidia with the package Nvidia-Gay

@gerald.loss I see this: https://forums.developer.nvidia.com/t/470xx-drivers-and-linux-6-2-kernel/243573 and a patch applied https://build.opensuse.org/package/show/X11:Drivers:Video/nvidia-gfxG05.

I suspect you need to boot from the old kernel and wait for the change to propagate to the Nvidia repository…

I have the same with G06 and 6.2.1

@Opendreas Hi and welcome to the Forum :slight_smile:
You just need to be patient until the updated drivers arrive in the Nvidia repository… or install the hardway.

Thank you :slightly_smiling_face:
Will this patch also make it into G06?

@Opendreas No patch needed for the G06, likely just needs to build for the 6.2.1 kernel (also to work with the locked down kernel).

I’m using the latest beta release without secure boot installed the hard way.

Strange situation, but on the latest nvidia snapshot with kernel 6.2.0 it worked and if I load snapshot 20230301, then everything works.
But if I boot kernel 6.2.0 or 6.2.1 on snapshot 20230302, then nvidia doesn’t work.

Sorry for the short question above. A error prevent me to save the whole question. But I have seen you have understood me anyway. :slight_smile:

Finally with the help of this link I have solved it. Thanks to malcomlewis!

I’m not at my computer the next days, but I try to recall all the steps you need to do for the others.

Install the kernel package with the error on you system. (It’s the package with kmp in the name)

Copy the patch from the link above in the directory with the sources of the kernel module installed with the package. In the Midnight Commander you can look with F3 into the package to find the exact location of this directory. It is anywhere under /use/src/kernel_modules//

Now patch in this directory with following command:

patch -ruN -p1 < filename.patch

Now compile everything just with the command “make”

Copy all the files with the extention *.ko into the directory with the kernel modules. You find again this directory with F3 in the Midnight Commander. The name of this directory is something like /usr/src/lib/modules/‘uname -r’/update

After a reboot hopefully it works.

Thanks for all of you for the support.


Buy a Radeon graphics adapter :wink:

Hi. When I am doing modprobe, autocompletition to nvidia, nvidia-drm, etc. worked, but I’ve got modprobe: permission denied. I am doing this from root. I would not like to compile nvidia module, so maybe there is another solution. Also, I think my problem is different. When look inside Information Center of Plasma/hardware/security I see kernel lock was enabled today, when I am doing update.

Disabling secure boot temporarily solved the problem

Not by me. The secure boot was disabled by me.

Yes. the last kernel does not load unsigned driver. You must disable temporary “secure boot”. A fix is on the way.

G06 driver works fine, fortunately.

Neither the G05 or 6 driver get my multi monitor setup back working again. Razer Blade 2019 with 2060 gpu. I’ve tried every install, uninstall, reinstall and driver wit the new kernel and my external monitor doesn’t work. Secure boot disabled ect ect ect yada. yada. yada.

Fixed. For some reason, Opensuse was installing a mixed set of packages with both G05 and G06. I had to use Yast to see them all listed and sort it out. I had G06 Kernel Drivers with G05 open gl packages. Uninstalled everything and then used yast to select only the G05.

1 Like

I’m struggling with the proprietary video drivers too: I’ve installed the current G6 drivers (525.89.02) from the Nvidia repository with Secure Boot enabled. I’ve added the key, but the Nvidia driver still doesn’t work.

Is this still an issue with the 6.2.1 kernel?

@Spenalzo as a Tumbleweed user I would suggest perusing the Factory Mailing List to see the status, disable secure boot, wait for fix…

Ref: 6.2.1 will have lockdown patches - openSUSE Factory - openSUSE Mailing Lists>

Would using YAST to “protect” your currently installed packages that work, be a good idea until a proper fix comes along? There are other software updates that I enjoy access to.