nvidia frustrations

I have a fresh install of OpenSuSE 11.2(KDE) with the only non-default things being addition of the nVidia repository and installation of the driver for my card(x11-video-nvidiaG02, nvidia-gfxG02-kmp-KERNEL). No other software has been installed. Everything was working perfectly until i shutdown. Upon starting up today the nVidia x server settings no longer detects the nvidia driver, and my resolution has been switched(and can’t be changed back through the gui) from 1440x900 to (best guess)1068x620. desktop effects are completely disabled(were working just fine before). oddly enough it also doesn’t detect my video card at all and instead shows my onboard video in the SaX2 gui. Any ideas how i can get my desktop back up to the way it was before i shut it down?

I had the same prob. I ended doing a total reinstall.

that would work, but this is the second install i’ve done on this machine and both of them have had this exact problem. i’m guessing the third try would lead to the same ends.

it does work perfectly until the nvidia drivers are installed, so i guess i should just suck it up and not try for the desktop effects since that seems to make it more difficult to use.

I had no problems installing or running nvidia proprietary drivers

Have you tried the proprietary Nvidia driver? I’m using it with no problem at all in 11.2 with KDE effects.

driver is the proprietary one installed from nVidia’s repository, installed just earlier today.

Not sure if this will make a difference, but I usually ignore the ones in the repos and go directly to Nvidia’s site and download the lastest, then install “the hard way”. I’m using 190.42 on a lowly 9400 GT.

good idea. i just tried it and it is definitely not as hard as the method’s name implies, but sadly it didn’t change anything. if i end up having to reformat again, i’ll use that instead of the repos, though i’d still rather not have to reformat a third time this weekend.

Did you remember to run ‘sax2 -r -m 0=nvidia’ after you’d completed the driver installation and before you reboot?
Or once in your X session I think you can run ‘nvidia-xconfig’ from a terminal.

Disable your ownboard Video in BIOS. sax2 is no longer needed as Xorg does black magic with HAL to recognize the setup automatically, however having an onboard adapter can wreck havoc.

That fixed it. thanks!

Got the latest driver loaded. I initially tried the one click install, which I hadn’t seen before and that resulted in the screen res going haywire,( everything became larger and slightly fuzzy)as per my first attempt. I then attempted the Hardway and got throught to the MAKE part, but that didn’t work. I bypassed that and followed the instruction to DL the latest Nvidia driver and then ran Sax2 and Hey Presto all went perfect. The 190 driver is loaded and looks very sharp, however when I click on My Computer the driver shows unknown.

Downloaded and installed 11.2. From Main menu opened System Setting->Display. Set this for my two monitors accepted and everything works a treat. The problem is: when I log off, restart, or power off and then reboot I lose the Display settings both go back to 1024x768 cloned. Only xorg file I can find is xorg.conf.install full of “Virtual” setings. How can I save the setting I want from System Settings->Display if possible.

NVidia 9800 GT graphics card
res I would like to use and save
Monitor 0 22" Samsung Syncmaster 2243BW 1680x1050
Monitor 1 17" Ilyama E431S 1024x768 this is right of (Would prefer 1280x1024 but it seems fixed)


I’m having the same problem, except with these differences. My 2 monitors are a CRT & an LCD. By default, my CRT monitor is the system default in Linux and my LCD is not enabled. I had to go into nvidia-settings & enable my LCD and then set it to the default. I hit apply and everything works great until I logoff, or stop my xwindows session or reboot. The next time I boot into Linux, I’m back at my single crt w/ the LCD disabled.

I’ve tried running sax2 from a command line to see if there’s anything that can be done from here, but it won’t display after it says it’s going to start it’s own x session.

I had a similar problem.
Sax2 was calling the driver a frame buffer.
Logged in as root.
Went into init 3.
Ran nvidia-xconfig.
Ran xinit.
Used twm in X.
Ran nvidia-settings in xterm.
Used their software to configure.
Works well with 2 screens, will try compositing later.