Nvidia Driver

Hi I am writing this using lynx so bear with me. My power went out yesturday for an extended period of time and now my graphics are messed up
I started my computer up and I only can get 640x480, so I was trying to reinstall the drivers but the nvidia drivers on the repositroy do not make sense as far as what goes with what, or descriptions of them.
so I downloaded the driver off nvidias website instaled it. It went to my desktop same problem. help please
Nvidia ION

Opensuse 11.4 64 bit

What do you mean?

Maybe the driver wasn’t the problem and so reinstalling it wasn’t the solution.

Their seems to be multiple drivers and I do not understand the ones I need.

I tried to reinstall it in case there was a kernel update that did not make the connection with the driver. i dunno I am just trying things. I was just trying to bring the drivers back to the original setup.

ok after running X again in the terminal it reads
(EE) NV: The PCI device XXXXX at XXXXXX has a kernel module claming it.
(EE) NV: This driver cannot operate until it has been unloaded.
(EE) No devices detected.

Fatal server error:
no screens found

Did you try booting in Failsafe?

well failsafe brings me to the desktop at one resolution above 640x480 the only start up issue I see when I hit escape is that the MCElog fails to start.

So how did you install the nvidia driver?
You said you downloaded it.

But, perhaps first, you should tell us what nvidia card you have…

03:00.0 VGA compatible controller: nVidia Corporation ION VGA (rev b1)


under yast it has these installed
nvidia-gfx-kmp-desktop version 96.43.19_k2.6.37.1_1.2-25.1
x11-video-nvidia version 96.43.19-26.1

I just added x11failsafe to my boot command got to a desktop reinstalled the driver by going to init 3, su, sh NVIDIA-Linux-x86_64-270.41.06.run and going through there prompts. and now I do have to driver working again and a desktop, but I am back to just having 640x480 available.

If you are installed manually from level 3 that is fine
But you don’t have the nvidia repo in your list also do you?

Is this an on-board nvidia graphics then?

it is on board. and yes I do have the repo in my repositories that’s how I originally had it installed until I had the 640x480 problem the first time. than I downloaded and installed nvidias driver in init 3, and that had seemed to fix the problem, except now it has happened again.

Lets try this. For the time being forget the one you downloaded.
Go to yast and delete both these
nvidia-gfx-kmp-desktop version 96.43.19_k2.6.37.1_1.2-25.1
x11-video-nvidia version 96.43.19-26.1
make sure no other nvidia driver is installed, just in case.

Now reboot and choose the failsafe if the default boot doesn’t take you to the desktop.
And follow this:
nVidia Driver via Repo in 11.3 & 11.4 - Guide

Just out of interest, how did the nouveau driver work for you?

As you discovered x11failsafe has limitations. It boots openSUSE with the FBDEV graphic driver which is a very limited graphic driver in function and performance, although it does have a very high degree of compatibility.

If it were me with your problem I would remove any rpm with ‘nvidia’ in the rpm name and start again trying to install the driver. Pay careful attention to any settings wrt KMS.

EDIT - I see caf4926 has provided good advice … Follow that !

You need G02 for the ION series and none of the the Legacy drivers.
First deinstall the driver you previously installed, then type the following as root:

zypper ar  [noparse]ftp://download.nvidia.com/opensuse/11.4/[/noparse] nvidia
zypper refresh
zypper in x11-video-nvidiaG02

It should solve the problem in most cases.

Hi I looked here as it relates to my problem. Thanks for the ftp nvidia link. I have just installed the nvidia drivers for a 200 series with it.
I uninstalled the noveau driver with yast. I was aiming to force the vesa driver but finished up with nv. The vesa driver may have allowed me to make my system more usable on a temp basis. Mandriva offer this opportunity during install. Great but it has a far more serious problem later on.

I then prowled about on the ftp site and added this to the repo’s


Then fired up yast in update mode and accepted all that it offered. Nvidia drivers, kernel headers etc.

Results I am now running nvidia 2d and NVIDIA 260.19.44 3d drivers but it took a reboot.

On another query in this thread glxgears is topping 466 frames per sec at my current 1024 x 768 res. The os driver gave about 100 at the same res. I can’t reach my full res until I sort out the remaining problems. My set up is oldish intel 6700 core 2 duo 2.6gig, 4gig ram.

Could be that there is no need to remove the os driver as X loaded a number but eventually chose the right one.

As this area is of interest to others perhaps I should start another thread and run down the remaining issues which I suspect are fairly simple. This way if people stick to the point others can follow it.

Or I could ask questions here.


:stuck_out_tongue: For perverse reasons I am also running 686 code to see if as the bugzilla suggest the problems may have been fixed. I assume this is 32bit bit have never bothered to get my head round this area.

so here is what happened I installed nvidia-settings it told me that I needed to run nvidia-xconfig, I ran nvidia-xconfig things worked perfectly. I then deleted the drivers off of yast, dropped down to init 3 and reran the current nvidia driver that I had downloaded, 270.41.06. I initialized init 5 got a black screen, pushed the power button ten seconds, fired up suse and now I am back to normal with a very up to date driver. I usually stick with the yast drivers but I figured I already had this installed and I do not know how to uninstall it, and the yast drivers are so much easier to uninstall. so there you go.

Solved here to mostly.
Thanks for the indirect tip. I needed to run the nvidia-config too. Now need to do a little more work on the xorg.conf file. Many people may have a monitor that takes care of that but mine doesn’t. Some may want to read about xorg dpi settings in any case as it looks to offer more control of text size. Screen size doesn’t. YAST left me with xorg using defaults which are far from optimum for my card.

For info glxgears at 1680x1050 now runs at 208 fps.


At least it’s progress. Well done!

On my last post. I forgot to add that the nvidia xconfig utility can be used from su in the console - my mistake mentioning the nvdia-config file.

Also the driver obtained from the rpm source is the same as the one I downloaded after using nvidia’s search facility.


IT HAPPENED AGAIN. I have done no updates. Firefox would not start widget was gray. restarted my computer 640x480!!! What is going on with this??

There have been some updates recently…
Was Firefox an issue earlier?
Seems like you should already know where to start looking regarding the 640x480