nvidia driver with next tumbleweed iso

Just a quick ‘heads-up’ the latest nvidia driver 367.35 does not work with the next tumbleweed iso (30072016) which has the 4.7 kernel

There is a Patch for Kernel 4.7, works here with kernel:stable and openSUSE 13.2.

Thanks very much for the info.

Where can I find this patch?

Where can I find this patch?

Does anyone know if a patch is required with the Nvidia 340.96 driver, as was the case with the previous kernel? And if so, whether one is available?

I must be doing something wrong. I copied the patch into KWrite and saved it, then used the --extract-only option for the 367.35 driver. I cd’d into the created NVIDIA directory and did ‘patch -p1 <path the patch>’ but the cursor just went to the next line and did nothing until I did crtl-c.

Four hours later and still no reply. Can someone who successfully patched this driver tell me how they did it?

It appears you didn’t redirect.

./NVIDIA-Linux-x86_64-367.35.run -x
cd NVIDIA-Linux-x86_64-367.35/
patch -p1 < ../4.7_kernel.patch

./nvidia-installer

Expand the run File as User with:

./NVIDIA-Linux-x86_64-367.35.run -x

Goto to the Directory:

cd NVIDIA-Linux-x86_64-367.35

Download the patch:

wget http://openmafia.org/~osf/Downloads/nvidia367_kernel4.7.patch

Patch the Nvidia driver:

patch -p1 -i nvidia367_kernel4.7.patch

Set init 3 to install the Driver:
Now as root:

systemctl set-default multi-user.target

Reboot your Computer
Login as root, goto the expanded Nvidia directory maybe when it is in /home/username/Downlods/NVIDIA-Linux-x86_64-367.35

 cd /home/username/Downlods/NVIDIA-Linux-x86_64-367.35

Do not forget to expand username to your existing Username.
Install the Driver:

nvidia-installer -a -q

After Installation do not forget to set init 5 (Graphical Session):

systemctl set-default graphical.target

Reboot your Computer.

Thanks for the detailed instructions. I was able to patch the driver with the file from openmafia but the driver still wouldn’t build and ended with an error. From the nvidia-installer log, most of the errors were either “unterminated comment” or “unterminated #ifndef” or #ifndef _UVM_LINUX_H.

Also, I’m using the no-compat32 driver. Does that make a difference?

You use this Driver?
http://www.nvidia.com/download/driverResults.aspx/105343/en-us

And you install it with

nvidia-installer

inside the expanded Directory?
And not the NVIDIA-Linux-x86_64-367.35.run?

Yes. I even downloaded the NON no-compat32 driver and got the same result.

Edit: There was only three lines of output from the patch command. Is that what you got?

What is that?

NON no-compat32 driver

Link?

If that is a legacy driver I doubt if it will work. Mention that hardware please

On NVIDIA’s ftp website there is a choice between 64/32-bit compatible or 64-bit only. Non-compat32 is 64-bit only.

ftp://download.nvidia.com/XFree86/Linux-x86_64/367.35

Download the one I mentioned, with that Driver, my Nvidia is working with Kernel 4.7.

That IS the driver you’re talking about, downloaded from the link you provided.

Than look in the nvidia-installer.log

With

most of the errors were either “unterminated comment” or “unterminated #ifndef” or #ifndef _UVM_LINUX_H.

nobody can say anything.

And yes, three files are patched.

And you have deleted the old NVIDIA-Linux-x86_64-367.35 directory, before you have done an

NVIDIA-Linux-x86_64-367.35.run -x

Maybe you have changed something before?

@pilotgi:

I had the same problem. I fixed it (after applying the patch) by editing uvm_linux.h as follows: The method “radix_tree_empty” that starts in line 492 is commented out, but somehow there was an issue with the closing comment symbol in line 563. I don’t know what was wrong, but the syntax highlighting of vi showed an error. I removed the surrounding comment symbols ("/" in line 491 and "/" in line 563) and put them back in. That solved it.

If that doesn’t work for you, you should be able to simply remove the entire method (lines 491-563).