nvidia driver, nouveau and rmmod -f

I have a nvidia-graphics laptop
and on updating to 11.3, I wanted into install the nvidia driver by hand.

however the driver complained and gave a number of reasons for why this might occur. Using lsmod, it turned out that the nouveau module probably is the one causing this.

Unfortunately I was caught with patience levels quite low and I reading a few gormless posts, I reckoned that if nothing was using his module I should rmmod --force it out.

So I did and I now categorically state to all who read: do not do that.
I repeat: do not “rmmod -f nouveau”. The consequences are severely unpleasant.

You’ve all disobeyed and gone and done it, I guess.
OK, we’ll to get out of the conundrum, you need to reboot on a different linux, choose your poison: a live cd will do.
get root status, mount the partition of your opensuse and

  1. get nouveau into the blacklist in /etc/modprobe.d (thi didn’t have much of an effect for me, but it seems logical)
  2. add “nomodeset” to your opensuse kernel boot parameters.
    OK, get out of your live cd and reboot your opesuse.
    It should at least load this time.
    You’ll find that nouveaur is still running in lsmod, but this time, a simple rmmod nouveau will kick it out. No fatal “-f” is required.
    A good way to make this perament is to throw it out of your computer altogtther using zypper rm. You’ll have to search for its precise name first though.
    also modify the kernel boto parameter you just place to read “nouveau.nomodeset=1”
    Your life will slowly return with a few more trivial mods (among which installing the nvidia driver again).

It should not be needed to remove nouveau. What exactly are the errors you got compiling the NVIDIA driver. Did you install the Kernel-source?

Just add nvidia repository
and install the nividia driver accordingly. AS far as i remember it is not the latest Nvidia driver but it works fine for me.
the other way to do

kernel source(at least the system asked for it)
This is how i did it.
Step1: Download the nvidia driver from the nvidia website.
Step2: Reboot the system and when the grub menu comes up, write “nomodeset 3″ without the
quotes in option field.
Step3: login and become root.
Step4: Blacklist the nouveau module. Insert “blacklist nouveau” without the quotes at the end of
Step5: Install the nvidia driver with “sh NVIDIA-Linux-…….run -q”.
Step6: Generate a default xorg.conf with “nvidia-xconfig”.
Step7: Open “/etc/sysconfig/kernel” end set “NO_KMS_IN_INITRD” to “yes”.
Step8: Run “SuSEconfig”.
Step9: Restart the system.

this works I have done it . A nerd (compliment!!!) call Marius posted it.

the blacklisting and the kernel setting you can do whilst still using KDE or Gome it is easier.

cheers Otto

cheers Otto

There is also a guide here for guidance in configuring one’s graphics: SDB:Configuring graphics cards - openSUSE

sorry guys!
the driver I am referring to is the CUDA 3.1 devdriver. I should have specified that. It’s not the ordinary display driver. It’s also for executing GPGPU code.

It certainly should NOT be necessary. Unfortunately, when upgrades happen, the upgrades can wind up UNblack listing that brain damaged, only-partially-functional nouveau driver. I sincerely wish folks would not cram beta grade software down the throats of unsuspecting victims. It is quite aggravating. Oh, Thursday’s upgrade re-activated the nouveau driver rendering my system non-functional for a couple of days while I debugged it.