Nvidia driver coverage and Quadro RTX 5000 Mobile

Are the G04 / G05 / G06 variations of the nvidia drivers meant to cover all nvidia cards?
According to nvidia.com, my card the Quadro RTX 5000 Mobile is not listed under the supported products for the version currently used by any of these 3 drivers. According to their site, I should be using version 460.91.03.

Would this be considered a bug that a card is not covered by these 3 or is it just expected that some nvidia users will have to “roll their own”?


Other than quite old cards, that is. I’m aware there may be some cut off, but the card I’m using is fairly new.

The G06 (510.60.02)… I have a T400 Mobile in my desktop;

inxi -Gxxz

Graphics:  Device-1: AMD Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X] driver: amdgpu v: kernel bus-ID: 02:00.0
           chip-ID: 1002:699f
           Device-2: NVIDIA TU117GLM [Quadro T400 Mobile] driver: nvidia v: 510.60.02 bus-ID: 03:00.0 chip-ID: 10de:1fb2
           Display: x11 server: X.Org compositor: gnome-shell driver: loaded: amdgpu,nvidia
           unloaded: fbdev,modesetting,vesa alternate: ati,nouveau,nv resolution: 1: 1920x1080 2: 1920x1080 3: 1920x1080
           s-dpi: 96
           OpenGL: renderer: AMD Radeon RX 550 / 550 Series (polaris12 LLVM 13.0.1 DRM 3.44 5.16.15-1-default)
           v: 4.6 Mesa 22.0.0 direct render: Yes

I install the hard way here though.

Thanks Malcolm.

Looking up 510.60.02 on nvidias page (https://www.nvidia.com/download/driverResults.aspx/187169/en-us) under supported products it only lists the Quadro RTX 6000 under “Quadro RTX Series (Notebooks)”. It does list the Quadro RTX 5000 (and 4000, 6000, etc) under “Quadro RTX Series.” This is confusing, but I believe the notebook and non-notebook versions of these cards is different and that this matters. If you do the driver lookup by card (https://www.nvidia.com/Download/index.aspx?lang=en-us) puttiing in Quadro RTX Series (Notebooks) / Quadro RTX 6000 it takes you to 510.60.02, but if you select Quadro RTX Series (Notebooks) / Quadro RTX 5000 it gives you 460.90.03 (https://www.nvidia.com/Download/driverResults.aspx/177149/en-us).

So I don’t think the current G06 driver is right for this card (nor the G05 or G04 drivers), at least according to Nvidia.


My card is the same series… TU… it will work for sure. Install that driver then what you need to do is ignore prime-select (based on your other thread, it is hard having two running threads…) and show the output from;

xrandr --listproviders

So, the reason being AFAIK, the newer cards and hardware should just be able to use offload (See https://download.nvidia.com/XFree86/Linux-x86_64/510.60.02/README/primerenderoffload.html), this is what I use here, although a desktop. I no xorg configs etc, it just works… no logout/login etc much easier to use for the applications where you want to use the nvidia gpu.

Ok I installed the G06 drivers and rebooted:

xrandr --listproviders

Providers: number : 1 
Provider 0: id: 0x48; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); crtcs: 3; outputs: 7; associated providers: 0; name: mod
    output eDP-1 
    output DP-1 
    output HDMI-1 
    output DP-2 
    output HDMI-2 
    output DP-3 
    output HDMI-3

Grepping this boot’s journalctl for nvidia, I find

kernel: nvidia: disagrees about version of symbol module_layout

So, your at the latest Tumbleweed release? Can you post the output from;

cat /etc/default/grub |grep GRUB_CMDLINE_LINUX_DEFAULT

Correct, 20220324.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash apparmor=0"

And what about;

inxi -Gxxz

**Graphics:  Device-1:** Intel **vendor:** Hewlett-Packard **driver:** i915 **v:** kernel **bus-ID:** 00:02.0 **chip-ID:** 8086:9bf6 
           **Device-2:** NVIDIA TU104GLM [Quadro RTX 5000 Mobile / Max-Q] **vendor:** Hewlett-Packard **driver:** N/A **bus-ID:** 01:00.0 
           **chip-ID:** 10de:1eb5 
           **Device-3:** Luxvisions Innotech Limited HP HD Camera **type:** USB **driver:** uvcvideo **bus-ID:** 1-7:2 **chip-ID:** 30c9:0010 
           **Display:** x11 **server:** X.Org **compositor:** kwin_x11 **driver:** **loaded:** modesetting **resolution:** 1920x1080~60Hz 
           **s-dpi:** 96 
           **OpenGL:** **renderer:** Mesa Intel UHD Graphics P630 (CML GT2) **v:** 4.6 Mesa 22.0.0 **direct render:** Yes

Do you have any xorg configurations present associated with ether the nvidia card or suse-prime?

At the moment, I’ve got

sudo ls /etc/X11/xorg.conf.d
00-keyboard.conf  90-intel.conf

(I’ve experimented with prime-select since installing the G06 drivers. Last prime-select I ran was “prime-select offload”. I can run “prime-select unset” again if you want. “prime-select nvidia” currently results in failing to boot to a graphical desktop. I assume the 90-intel.conf came from trying “prime-select intel” previous to the “prime-select offload” unless the latter actually installed it.)



sudo ls -R /etc/prime
current_type  offload_type  user

(let me know if that doesn’t answer your question fully)

So what are the contents of current_type and offload_type? I have zero experience with suse-prime and plasma :wink: My dual gpu laptop is amd… If you inspect ~/.local/share/xorg/Xorg.0.log see any errors?

Empty. (The -R makes the ls recursive)

I don’t think plasma is entering into it. When I say failure to boot to graphical desktop, I beleive it’s not even getting to plasma. I’ll have to recheck this since the G06 driver, but previously it seemed to be the sddm error.

However your suggestion to check the xorg log was a good idea. I do see some errors, even booting (successfully into plasma) in the offload / intel mode. Ill just post the whole log since it’s not terribly long and there are some odd warnings earlier too…

This is a pre-release version of the X server from The X.Org Foundation. 
It is not supported in any way. 
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/. 
Select the "xorg" product for bugs you find in this release. 
Before reporting bugs in pre-release versions please check the 
latest version in the X.Org Foundation git repository. 
See http://wiki.x.org/wiki/GitPage for git access instructions. 
X.Org X Server 
X Protocol Version 11, Revision 0 
   513.072] Current Operating System: Linux eric-hpzbookfury15g 5.15.7-1-default #1 SMP Wed Dec 8 08:54:39 UTC 2021 (b92986a) x86_64 
   513.072] Kernel command line: BOOT_IMAGE=/@/boot/vmlinuz-5.15.7-1-default root=/dev/nvme0n1p5 rootflags=subvol=@ quiet splash apparmor=0 
   513.077] Current version of pixman: 0.40.0 
   513.080]    Before reporting problems, check http://wiki.x.org 
        to make sure that you have the latest version. 
   513.080] Markers: (--) probed, (**) from config file, (==) default setting, 
        (++) from command line, (!!) notice, (II) informational, 
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown. 
   513.087] (==) Log file: "/home/ericjs/.local/share/xorg/Xorg.0.log", Time: Fri Dec 17 15:10:58 2021 
   513.089] (==) Using config directory: "/etc/X11/xorg.conf.d" 
   513.090] (==) Using system config directory "/usr/share/X11/xorg.conf.d" 
   513.091] (==) ServerLayout "layout" 
   513.091] (**) |-->Screen "intel" (0) 
   513.091] (**) |   |-->Monitor "<default monitor>" 
   513.091] (**) |   |-->Device "intel" 
   513.091] (==) No monitor specified for screen "intel". 
        Using a default monitor configuration. 
   513.091] (==) Automatically adding devices 
   513.091] (==) Automatically enabling devices 
   513.091] (==) Automatically adding GPU devices 
   513.091] (==) Automatically binding GPU devices 
   513.091] (==) Max clients allowed: 256, resource mask: 0x1fffff 
   513.099] (WW) The directory "/usr/share/fonts/Type1/" does not exist. 
   513.099]    Entry deleted from font path. 
   513.099] (WW) The directory "/usr/share/fonts/100dpi" does not exist. 
   513.099]    Entry deleted from font path. 
   513.099] (WW) The directory "/usr/share/fonts/75dpi" does not exist. 
   513.099]    Entry deleted from font path. 
   513.099] (WW) The directory "/usr/share/fonts/ghostscript/" does not exist. 
   513.099]    Entry deleted from font path. 
   513.099] (WW) The directory "/usr/share/fonts/cyrillic" does not exist. 
   513.099]    Entry deleted from font path. 
   513.099] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist. 
   513.099]    Entry deleted from font path. 
   513.100] (==) FontPath set to: 
   513.100] (==) ModulePath set to "/usr/lib64/xorg/modules" 
   513.100] (WW) Ignoring unrecognized extension "XFree86-DGA" 
   513.100] (II) The server relies on udev to provide the list of input devices. 
        If no devices become available, reconfigure udev or disable AutoAddDevices. 
   513.100] (II) Loader magic: 0x55fff031aae0 
   513.100] (II) Module ABI versions: 
   513.100]    X.Org ANSI C Emulation: 0.4 
   513.100]    X.Org Video Driver: 25.2 
   513.100]    X.Org XInput driver : 24.4 
   513.100]    X.Org Server Extension : 10.0 
   513.101] (++) using VT number 1 

   513.103] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31 
   513.104] (II) xfree86: Adding drm device (/dev/dri/card0) 
   513.104] (II) Platform probe for /sys/devices/pci0000:00/0000:00:02.0/drm/card0 
   513.105] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 11 paused 0 
   513.110] (--) PCI:*(0@0:2:0) 8086:9bf6:103c:8783 rev 5, Mem @ 0xdf000000/16777216, 0xa0000000/268435456, I/O @ 0x00004000/64, BIOS @ 0x????????
   513.110] (--) PCI: (1@0:0:0) 10de:1eb5:103c:8783 rev 161, Mem @ 0xe0000000/16777216, 0x80000000/268435456, 0x90000000/33554432, I/O @ 0x0000300
0/128, BIOS @ 0x????????/524288 
   513.110] (II) LoadModule: "glx" 
   513.111] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so 
   513.119] (II) Module glx: vendor="X.Org Foundation" 
   513.119]    compiled for, module version = 1.0.0 
   513.119]    ABI class: X.Org Server Extension, version 10.0 
   513.119] (II) LoadModule: "modesetting" 
   513.119] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so 
   513.120] (II) Module modesetting: vendor="X.Org Foundation" 
   513.120]    compiled for, module version = 1.21.1 
   513.120]    Module class: X.Org Video Driver 
   513.120]    ABI class: X.Org Video Driver, version 25.2 
   513.120] (II) modesetting: Driver for Modesetting Kernel Drivers: kms 
   513.120] (EE)  
Fatal server error: 
   513.121] (EE) xf86OpenConsole: Cannot open virtual console 1 (Permission denied) 
   513.121] (EE)  
   513.121] (EE)  
Please consult the The X.Org Foundation support  
         at http://wiki.x.org 
 for help.  
   513.121] (EE) Please also check the log file at "/home/ericjs/.local/share/xorg/Xorg.0.log" for additional information. 
   513.121] (EE)  
   513.121] (WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor 
   513.121] (WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor 
   513.172] (EE) Server terminated with error (1). Closing log file.

Actually hold on…that local xorg log is old…probably from the last time I tried to startx as my normal user. These errors are not in the /var/log version. Let look at that log more closely.

So what files are down in /usr/share/X11/ and /usr/share/X11/xorg.conf.d any nvidia configuration, is nouveau blacklisted?

There are no errors in my /var/log/Xorg.0.log only warnings on those various directories under /usr/share/fonts not existing and that ‘Ignoring unrecognized extension “XFree86-DGA”’

I assume you really want me to check it in the “won’t boot into graphical mode after prime-select nvidia” situation.

Yes, just check the log and see whats happening.

ls -l /usr/share/X11/
total 68
drwxr-xr-x 1 root root   216 Mar 23 15:29 app-defaults/
drwxr-xr-x 1 root root    24 Feb 20 04:35 ja/
drwxr-xr-x 1 root root    24 Feb 20 04:35 ja_JP.eucJP/
drwxr-xr-x 1 root root    24 Feb 20 04:35 ja_JP.ujis/
drwxr-xr-x 1 root root    24 Feb 20 04:35 ja_JP.UTF-8/
drwxr-xr-x 1 root root  1254 Feb 19 21:34 locale/
drwxr-xr-x 1 root root    16 Aug 22  2006 nls/
-rw-r--r-- 1 root root 17975 Feb 19 16:10 rgb.txt
-rw-r--r-- 1 root root  1723 Feb 19 21:34 Xcms.txt
-rw-r--r-- 1 root root 42077 Feb 19 21:34 XErrorDB
drwxr-xr-x 1 root root    94 Feb 21 11:59 xkb/
drwxr-xr-x 1 root root   326 Feb 20 02:45 xorg.conf.d/
drwxr-xr-x 1 root root    30 Mar 15 22:04 xorg_pci_ids/
ls -l /usr/share/X11/xorg.conf.d/
total 44
-rw-r--r-- 1 root root   92 Mar  1 11:14 10-amdgpu.conf
-rw-r--r-- 1 root root 1099 Jan  7 14:28 10-evdev.conf
-rw-r--r-- 1 root root 1350 Mar 15 22:04 10-quirks.conf
-rw-r--r-- 1 root root   92 Feb 11 17:45 10-radeon.conf
-rw-r--r-- 1 root root  484 Jan  7 14:28 11-evdev.conf
-rw-r--r-- 1 root root 1459 Jan 26 15:35 40-libinput.conf
-rw-r--r-- 1 root root  199 Jan  7 14:28 50-elotouch.conf
-rw-r--r-- 1 root root  264 Mar 15 22:04 50-extensions.conf
-rw-r--r-- 1 root root 1913 Feb 20 02:45 70-synaptics.conf
-rw-r--r-- 1 root root  115 Feb 20 02:45 70-vmmouse.conf
-rw-r--r-- 1 root root 3465 Feb 20 02:44 70-wacom.conf

As to blacklisting nouveau, I’m quite sure I did this back when I first installed the nvidia drivers. However I don’t find it blacklisted under /etc/modprobe.d. Still, I can’t find any indication nouveau is loading. I will add the blacklisting for it and retry the prime-select nvidia.