nvidia and beta 5, how to get it?

I’ve searched and it seems people are able to run with their nvidia cards (have an 7600GT myself) using the nvidia drivers. I got it installed (downloaded the latest from nvidia), but it doesn’t pick it up. It says it can’t find the driver and I get a nice stretched out 1400x1050 in 16 bit color screen instead of 1680x1050 24 bit. No composite either, of course. I do have it working on 11.0, so what’s up?

You probably need to log into root and run sax2 -r -m 0=nvidia. I don’t know if this command has to be run at init 3 or just plain old root.

I manually install my nvidia drivers and the installer almost always fails to configure the them properly, resulting in the aforementioned command being run.

That didn’t work at all. I can set everything okay, display looks good, but starting X gives the same bad result.

I checked /var/log/Xorg.0.log and it says there is no valid nvidia driver. However, there is also /var/log/Xorg.19.log (which gets filled when using your sax2 command and that one is happy. It loads the nvidia driver.

There’s one message, when restarting /etc/init.d/earlyxdm and that is that it will use the backup /etc/X11/xorg.conf.install instead. I replaced that one with my version and then X is fine!!! How weird is that? And it shouldn’t work that way, of course.

Also, when not starting earlyxdm but just doing startx, X is also okay. However, I obiously want kdm (initialized by earlyxdm) properly, using my /etc/X11/xorg.conf.

So, I have it working, but in a broken way. Does anyone have any more ideas?

Did the NVIDIA installer say everything went ok? How did you install it? (I installed it in runlevel 3)

For me the Nvidia installer created some backup boot entries in grub, so I can choose whether I want the drivers enabled or not. Are you sure you are booting into the one which has the drivers enabled?

The new installers enable the driver themselves so no sax2 modifications should be needed.

I have a 7600GT too and it & composite are 100% on my x86-64 system.

The 1st thing I do is go to /etc/X11/xorg.conf and copy xorg.conf to /home/jim/backup (then if I ever get in trouble with video, just copy it back).

I went to: NVIDIA Driver Downloads - Advanced Search
And fetched the Version: 177.80 @ Linux x64 (AMD64/EM64T)
The guide is @ Nvidia Installer HOWTO for SUSE LINUX users

If you are 32-bit, be sure to select that version& change the code below; again, mine is x86-64.

From the desktop, in a terminal, login as root & type “init 3”
(which puts you at runlevel 3 command line)
login as root
cd /path to NVIDIA-Linux-driverxxx
Type “sh NVIDIA-Linux-x86_64-177.80-pkg2.run -q” to install the driver.

When that is done & you are back at the command line, type
“sax2 -r -m 0=nvidia”
when the screen comes up: “change”
select your config & “TEST” (always test)
change the size, move, etc.
if not repeat until you have it the way you want
type “reboot”

When the desktop is up again, go to /etc/X11/xorg.conf and you will probably see down at the bottom:

Section "Extensions"
  Option       "Composite" "off"

with an editor, change that to

Section "Extensions"
  Option       "Composite" "on"

Lastly, in "Personal Settings (configure desktop) > desktop effects
make sure you have 4 desktops selected
Turn on Desktop Effects
walk through the list of options & turn on what you like (like “cube”, etc,)

Ta Da:D

The above worked for me to install the 177.82 drivers. I did not enable Compiz because I don’t like how it affects the system.

There is a new NVIDIA driver (BETA).
The version is 180.06.

It’s probably one of the best NVIDIA drivers ever released. Not only Firefox/KDE4 performance problems are solved without need to tweak settings, but it includes experimental video acceleration (called VDPAU) for mplayer, plus is CUDA-enabled. OpenGL 3.0 support is planned (there is another driver that already supports that, if you need it now).

Try it.


I tried all of them (with 11.0’s repositories, stable and beta version of drivers on the official website) but it say me that’s not compatible with my kernel (2.6.27 up to date with openSUSE 11.1 beta 5 GNOME, 64 bit)

What can I do?

Sorry for my English, I speak French…

You need to install a package named “kernel-headers” or “linux-kernel-headers” o something like that. Also you need gcc. Then run the NVIDIA installer. It will ask you to compile the driver for your kernel.

Actually, one should install the “Patterns” of C/C++ & Kernel Development; then check “Details” to make sure make, gcc, kernel-source and kernel-syms are selected.
It is important that kernel-source and kernel-syms match your running kernel, check with “uname -a”
If they don’t, after the install do a Yast Online Update & yast will make them match for you.

Then run the Nvidia Installer.

Have fun:)

Interesting, thanks for that tip Cymerio. It made absolutely no difference to 11.1, but when I tried it on 11.0/KDE4 the difference was startling. On that platform my apps used to start up like they were crawling through wet cement in order to get onto the desktop, but with the 180.06 driver they start up almost as quickly as on KDE3.

Nice one - thanks!

thank you for your answers! I try it now :slight_smile:

Ok… a freaky thing:

I today reinstalled my beta5, but now I cannot get my nvidia driver to work… before this I installed it lots of times, but now XOrg doesn’t want to work with the new configuration files… at every boot it loads the /etc/X11/xorg.conf.install file and not the updated conf file?

Any reason for this?

PS: I’m trying to install the beta driver from nvidia.

I’ve looked around in the boot scripts and finally found a strage thing: my linux boots with an x11 failsafe option (x11failsafe), which causes the XOrg to default to the caonfig file that came with the install.

I also checked my grub boot options and indeed, x11failsafe is specified.

If I remember correctly, the stable Nvidia driver at the end of install stated that it will create backup entries for grub (and doubled the entries: one set using the driver and on set not). I think the problem then might be in the nvidia installer, that it “created” the backup entries in grub (by adding the x11failsafe option), but never created the new entries… So in the end the driver is installed and disabled during boot time.

Modifying the boot options should resolve teh issue, but haven’t tested it yet (will do so and post an update).

Ok, indeed that was the problem. Now everything works superb :slight_smile:

i have an 8800gt
and the nvidia installer made it itself, as always…

it’s strange… have many friends with nvidia, and everyone just use the installer

i run it without -q

Yeah, me too… I’ve been using suse since 9.2 and the nvidia installer always worked… but it somehow screwed up now. Anyway, I posted my “diagnosis” and solution so if anyone else experiences this issue (as the thread starter also did), they will have an idea what to do.

That should be stickied somewhere, patterns actually come in handy here. I completely and utterly hate compiling cause it’s always one thing missing after the next and I seem to reinstall too often so I gotta do it over and over. (btw, seems like beta 5 comes with linux-kernel-header preinstalled?)

hello, after install beta 5.2 i have #1 SMP kernel but linux-headers are so Nvidia driver is impossible to install. :frowning: Some help anybody?

Post #10:

",one should install the “Patterns” of C/C++ & Kernel Development; then check “Details” to make sure make, gcc, kernel-source and kernel-syms are selected.
It is important that kernel-source and kernel-syms match your running kernel, check with “uname -a”
If they don’t, after the install do a Yast Online Update & yast will make them match for you.

Then run the Nvidia Installer."