NVIDIA 367.27-24.1

I see that NVIDIA drivers 367.27-24.1 are now available.

The previous driver updates had bugs that resulted in a black screen at boot.

Has anyone installed this new version and can confirm that it is working correctly?

(Perhaps this post belongs in “Hardware”? Move if appropriate.)

The previous update had bugs in the openSUSE packaging, those should be fixed.

The driver itself was fine AFAIK.

Has anyone installed this new version and can confirm that it is working correctly?

I haven’t (no nvidia card here…), but somebody else confirmed it is working correctly in the bug report:

I have those drivers installed now and am still getting a black screen on boot up.

Do you have virtualbox-guest-kmp-default installed?
Apparently this breaks the correct creation of symlinks for the kernel modules in Leap currently.

Remove it and reinstall nvidia-gfxG04-kmp-default, and it should work.

I don’t have that package installed.

If I open yast up in the command line and under software management I search nvidia it brings a big list up, those I have installed are

Libdrm_nouveau2 version 2.4.65-1.1
Libdrm_nouveau2-32bit version 2.4.65-1.1
Nvidia-computeg04 version 367.27-24.1
Nvididia-gfxg04-kmp-default version 3.67.27_k4.1.12_1-24.1
Nvidia-glg04 version 367.27-24.1
X11-video-nvidiag04 version 367.27-24.1
Xf86-video-nouveau version 1.0.11-7.2
Xf86-video-nv version 2.1.20-11.1

Ok, but this is the only (general) “issue” I’m aware of at the moment.

We should try to find out why it doesn’t work for you then.

Can you please post /var/log/Xorg.0.log?
Does it work if you boot an older kernel (“Advanced Options” in the boot menu)?

Try to reinstall nvidia-gfxG04-kmp-default and post the output:

sudo zypper in -f nvidia-gfxG04-kmp-default

Maybe something goes wrong when compiling the kernel module…

How can I post the output of that log when I cannot get it online? Do I have to manually type it?!

I’ve tried booting the options in advanced options but still get a black screen unfortunately.


Maybe take a picture with a digital camera.

You could also try to add “x11failsafe” to the boot options, this should force the use of a generic driver and might enable you to start a graphical system.
To do so, press ‘e’ at the boot menu, and append this option to the line starting with “linux” or “linuxefi”, then press ‘F10’ to boot.

If that helps, please post /var/log/Xorg.0.log.old afterwards.

If you get to a login screen but your desktop doesn’t start, you could try choosing IceWM instead.

Or another way, uninstall all nvidia driver packages in text mode:

sudo rpm -e nvidia-gfxG04-kmp-default nvidia-computeG04 nvidia-glG04 x11-video-nvidiaG04

Then reboot (you should get into a graphical system then, using nouveau), and post var/log/Xorg.0.log.old.

I’ll start another thread. But I’ll also mention it here, since some of the interested people might be reading this thread.

Checking updates, there was an update for the Nvidia G02 driver. I installed it. That badly broke my system. Details elsewhere (when I get to posting it).

Do you have virtualbox-guest-kmp-default installed?
That problem affects all nvidia driver versions (or actually the installation of any kmp package).

I tried the x11failsafe and that didn’t work. I uninstalled all nvidia packages and upon booting I still get no desktop, just a black screen. When I get to console and also boot into yast the font is now absolutely tiny!

Hmmm, where to go from here? Cheers

Yes. But I think I’ll just stick with nouveau for the present (see the other thread for details of what I did).

Well, then your problem seems to be unrelated to the nvidia driver. (or maybe nouveau has a problem as well)
But just in case: if you have an /etc/X11/xorg.conf, you need to remove/rename it, as it will tell Xorg to load the nvidia driver (which fails if it isn’t installed).

Adding “nomodeset” to the boot options should help to get to graphics mode.
Please post /var/log/Xorg.0.log.old then.

Also, try to reinstall the nvidia driver then (the kmp in particular) and post the output.

sudo zypper in nvidia-gfxG04-kmp-default

When I get to console and also boot into yast the font is now absolutely tiny!

The font should be the same (pixel) size as ever.
But nouveau will use your monitor’s native resolution, while with the nvidia driver the console is using 640x480 by default.

I went to remove /etc/X11/xorg.conf and it said no such file or directory. Using yast I’ve reinstalled nvidia drivers so I’m back to square one.

If I press “e” at the bootloader screen it comes up with a lot of various text… And typing nomodeset and pressing F10 says something along the lines of command not found.


You should move the cursor to the line starting with “linux” (or “linuxefi”), and append “nomodeset” at the end.
Then press F10.

But that was intended to prevent nouveau from loading and using a fallback driver instead to get to a graphical system.
With the nvidia driver installed again, it doesn’t really make sense (although it might help if there’s a problem with the blacklist).

So again uninstall the 4 nvidia packages, reboot and add “nomodeset” to the boot options, then if you (hopefully) get into graphical system post /var/log/Xorg.0.log.old.
And please also run “sudo zypper in nvidia-gfxG04-kmp-default” and post the output.

I’ve downloaded the nvidia run file and installed “the hard way”. It installs and works fine on leap with kernel 4.6.
In Tumbleweed I have kernel 4.7 rc3 and I had to tweak the nvidia run file to install it. You can find the tweaks by googling “nvidia patch kernel 4.7”. It works just fine.

I’ve updated the nvidia drivers to 367.27, rebooted with crossed fingers and it’s working fine as it looks like. I did have problems after upgrading the first time last weekend but I didn’t had the problem with the black screen, just plasma crashing but this was related to vbox drivers that prevent installing the nvidia drivers.


I went into yast and deleted the nvidia packages, and started using nomodeset and… Still, I’m left with a black screen.

Many thanks. Getting a bit annoyed with this now. I’ve had more problems with this than Windows 10 which I’m dual booting!

Well, I suppose we can safely assume that the nvidia driver is not the problem then, and it’s probably not related to the graphics driver at all.

Unfortunately with the (lack of) information available so far (i.e. that you get a black screen…), it’s rather impossible to give any further suggestions (except a reinstall).

For a start, what exactly do you mean with a black screen?
Is it completely black?
Or is there a mouse pointer at least?
Does pressing Ctrl+Alt+Backspace twice bring you back to the login screen?

As you created a different thread yourself, please let’s continue there though:

Discussing the same problem in two different threads just creates chaos.