nVidia 180.27 driver issues with thinkpad T61

I run Opensuse 11.1 on a Thinkpad T61 with an nVidia Quadro NVS 140M graphics card. I recently migrated from Ubuntu to OpenSUSE in the hope that hibernate and suspend work.

I installed the 180.27 drivers off the site and well, suspend worked pretty flawlessly but there are some interesting issues for hibernate and the general usage of openSUSE.

  1. Hibernate takes just too long. It goes to sleep very quick but on resume, I get this blank screen with a cursor on the top left for about a minute, during which the hard disk doesnt seem to be spinning. After an annoying beep, the hard disk springs back to life, and I get to the password stage. The whole idea of using hibernate is that it is supposed to be quicker than a full blown power on, so the purpose is lost if hibernate takes this long. This is an interesting error message I encountered in my /var/log/pm-suspend.log file:
 Error org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files 
  1. On bootup, or when the screen goes off in general, there is this black and white mosaic which covers the entire screen before I get back to the SUSE desktop.

Any one has any ideas?