Numlock off on KDE 4.7

Greetings! need some helps here. I am using KDE 4.7 openSUSE Tumnleweed based on 12.1. How do I am make the numlock permanently ‘on’ during start up? Already made changes in YaST > system keyboard layout > and numlock on from there set to ‘yes’, in /etc/sysconfig the KBD_NUMLOCK been set to ‘yes’ as well, but none of it working during the boot up and I am need to activate the numlock manually. btw, my BIOS does not have any options in changing the specific keys lock. Things however worked well in my previous 11.4.

Thank you.

look at systemsettings -> input devices -> keyboard -> hardware -> num lock on KDE startup

I am in the same exact boat as you! This is not the case for openSUSE 11.4, only 12.1. I applied the same settings as you did, and my BIOS does not have a numlock option, either. The only thing that “works” is numlock will be enabled after I login to a KDE session. But no matter what I’ve tried, the KDM login screen always disables numlock!

If I reboot with numlock enabled, it will be disabled once I get to the KDM login screen.
If I logout from a KDE session, numlock will be disabled once I get to the KDE login screen.

Is the same true for you as well?

This only works to enable numlock after logging into a KDE session. This doesn’t help if numlock is disabled on the KDM login screen.

This also happens to me. My system does have a NumLock setting in the BIOS and my settings in KDE are set to “Leave unchanged” but as soon as I log in it’s turned off.

Yes, I have been noticing this change.

Previously, I had set numlock to leave the setting as it is. And my BIOS setting sets it on at bootup.

I’m not sure whether the change is KDE 4.7.2 or openSUSE 12.1, but often numlock is not on when I login.

I did as others have suggested. I changed the setting to force numlock to be on at KDE session start. That has solved the problem for me.

unfortunately, even forcing that on it does not working eithe

Is there a fix for this available? Since this problem has impact on all opensuse users, I would assume that this issue has high priority. But I haven’t found a software update that fixes the issue yet (dissapointed).

I also do not understand that this wasn’t seen and fixed by the developpers in alpha and beta testing since you can not look over this. When num lock is off, your password will be wrong if it includes a number when logging into KDE…

The following worked,

>System Settings
>>Input Devices
----Select any other device, make sure all normal key are recognised in Test area:
----Select Apply

Repeat the above and select the correct keyboard
Reboot again.

Is the number lock now as required?

keellambert, nice suggestion but unfortunately it doesn’t help. Numlock is switched off as soon as opensuse starts to boot from grub and is not activated again by KDM. When I turn it on, login into KDE, logout again into KDM, the numlock is back off…


Sorry my suggestion did not work for you.

I had exactly the same problems after a kernel update and changing / replacing the selected keyboard solved it.

My conclusion being, something in the user profile was not being updated or being masked.

I assume you have tried toggling the ‘leave alone’ and ‘enable’ parameters. But that had no effect for me.

If you create a new user profile, and logon with that account, do you still get the same result?

I am thinking that this is a minor from openSUSE 12.1 itself, now I am using 11.4 with latest KDE and no such problem with that.

ok not a solution

but stay with what works best for you

I don’t know if the with this thread:
edit /etc/init.d/boot.local and add

touch /var/run/numlock-on

seem work for me