"ntfs" missing on "Repair Installation"

Noobie to openSUSE, having installed and used Ubuntu. I installed openSUSE 11.2 using an “internet install” (due to a question as to reading a burned DVD). OpenSUSE 11.2 was installed on a (successfully) partitioned Windows/XP laptop, with Windows occupying two (2) partitions. The primary Windows partition is “NTFS”, and the second partition (the installation material) is “FAT32”. Other than losing the ability to boot Windows via GRUB boot loader, and repairing the same, no problems are experienced in the Windows environment.

After install, I ran the 11.2 install CD again, using the “Repair Installion” option. Selecting “Automatic Repair”, a message kicked out out in the package verification section concerning “ntfs” (missing?), and was flagged as “problematic”. I assume that this support is not necessary for openSUSE, unless I need to access the Windows partition (which would be nice!).

Where can I find the “ntfs” package(s) noted as missing ? I have searched through “Software Management” and “Add-Ons”. I did locate “ntfs-config” which provides write support for NTFS partitions. I really wish to only read the NTFS partitions, having no desire for a Linux/Windows problem with NTFS sharing.

Open a terminal and become su

post result of:

fdisk -l
cat /boot/grub/menu.lst
cat /etc/fstab

To start: Welcome to the forums.

For read/write access to NTFS partitions, you need ntfs-3g, and IIRC it’s in the kernel.

Do I understand correctly, that you installed 11.2 successfully, except for not being able to boot XP? And repaired from XP?

If XP is not touched, boot into the openSUSE installer, at the choice for “New Install”, pick the extra option and “Boot installed system”. This will look for an openSUSE install, attempt to boot it ( and IME succeeds 999 out of 1000 ). Login, start Yast and create a new bootloader configuration. Check all, ask for help here if you’re not sure. At next reboot you should be able to boot openSUSE as well as XP from GRUB.

Good luck, let us know how you get on.

Donut:/home/sean # cat /etc/fstab
/dev/disk/by-id/ata-HTS726060M9AT00_MRH423M4H4MRTB-part5 swap swap defaults 0 0
/dev/disk/by-id/ata-HTS726060M9AT00_MRH423M4H4MRTB-part6 / ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-HTS726060M9AT00_MRH423M4H4MRTB-part7 /home ext4 acl,user_xattr 1 2
/dev/disk/by-id/ata-HTS726060M9AT00_MRH423M4H4MRTB-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-HTS726060M9AT00_MRH423M4H4MRTB-part2 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
Donut:/home/sean #

Thank you!

I really only wish to have read access to the NTFS volume. Such may save dumping things to jump-drives or E-Mails, and avoid swap boots.

As to the loss of Windows boot, I searched this forum and found


This procedure did the trick, and all was almost well. Windows could boot (no problems there), but after recovering the boot menu, openSUSE only runs booting the “Failsafe” startup. When I boot the “normal” openSUSE option, it will sometimes boot. Once to the desktop though, after a few commands everything goes black (not green), and only a hard boot will recover. (I am working on different options to avoid this, and will post up separately).

edit fstab
replace this
/dev/disk/by-id/ata-HTS726060M9AT00_MRH423M4H4MRTB-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0


/dev/disk/by-id/ata-HTS726060M9AT00_MRH423M4H4MRTB-part1 /windows/C ntfs-3g defaults 0 0

FSTAB - Editing Manually - openSUSE Forums


Do you have windows boot option now?

I had previously restored the ability to boot Windows. I have yet to perform the FSTAB edit uou had suggested. I will attempt the proposed edit, and post back.

The proposed change includes “defaults 0 0” which, to my understanding, provides read/write access. While I may eventually attempt read/write, I am currently seeking only read access.

(Sorry for the delay … was watching Aston Villa v ManU (live here!)):slight_smile:

Follow-up … Windows access via GRUB/boot menus functioning, and access to the NTFS Windows partition working, although I have yet to determine how to restrict to read-only.

The 11.2 openSUSE is only working in “failsafe” mode, due to the ongoing problems (found here and in the “Hardware” forum) with an ATI video driver. A secondary problem has been wireless access, and, as a result, openSUSE is running tethered (wired interface).

The ATI driver problem(s) led me to attempt a full install of openSUSE 11.1. This was somewhat problematic, as the LiveCD (GNOME and KDE) both experienced the ATI problems, and the network install completed with a number of errors, including an “ICEauthority” failure, and a following “GConf” status 256 error.

At this point, I have re-installed openSUSE 11.2 (with KDE this time), with a few minor glitches and one MAJOR problem. When the install completed, and the login panel presented, the user name/password I had specified produced a “Login failed”. The only login available was “root”.

I know need to determine how to either activate the installation user name (“sean”) or add it back to the install. Any help would be most welcome. Should this prove unresolvable, I will either re-do the network install (~ 1.5 - 2.5 hours, depending on the net speed, or attempt a full DVD install.

A re-install the way you just did should work. And is probably the quickest to solve the password issue.

Have a look here for some graphics tips
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

I performed another “Repair Installation”, and was able to correct the installer’s loss of access to the Windows partition. As for the user/password issue(s), I may have had a bit of luck here. After applying some updates (actually, more than a few!:wink: ), I looked at the portfolio of “users” (there were none to be seen), so I added the user I had originally specified. Voila! I am logged in correctly!

Have a look here for some graphics tips
[". I do not intend a rant or flaming, rather to offer some observations and suggestions. This has been quite an interesting experience, If you wish, I will proffer my remarks to you, or another moderator.

Cheers!failsafeATI****ATIblack screen of deathwireless accessun-tetheredBroadcomPackmaninternet installRepair InstallationAutomatic Repair](http://forums.opensuse.org/new-user-how-faq-read-only/unreviewed-how-faq/430150-opensuse-graphic-card-practical-theory-guide-users.html#post2099015)

If you feel there are areas where improvements could be make, you can voice them here:

But you are certainly welcome to offer your observations here too.