Nss-systemd not found

Hello all,
I have an application that is requiring nss-systemd.
Unfortunately the installer is not able to find it in systemd package that I have it installed.

Any suggestions here?

Always big thanks in advance for who will spend time trying to help

@mark07 See https://www.freedesktop.org/software/systemd/man/latest/nss-systemd.html it’s actually systemd-userdbd

1 Like

Hello @malcolmlewis , big thanks as always for the answer.
I went through the link.
I have installed systemd package in my machine but it is not finding systemd-userdbd.
Could you point me to the package to be installed for having it?

Then, after that, should I follow the instructions reported to activate nss-systemd modfying mentioned files of the link?

Let me know when you have time and super thanks

@mark07 it’s part of systemd, maybe a typo?

systemctl status systemd-userdbd.service 
○ systemd-userdbd.service - User Database Manager
     Loaded: loaded (/usr/lib/systemd/system/systemd-userdbd.service; indirect; preset: disabled)
     Active: inactive (dead)
TriggeredBy: ○ systemd-userdbd.socket
       Docs: man:systemd-userdbd.service(8)

zypper se --provides /usr/lib/systemd/system/systemd-userdbd.service

S | Name    | Summary                      | Type
i | systemd | A System and Session Manager | package

1 Like

Thanks @malcolmlewis .
Yes I have the same as you.
Last question, since when I try to install the app it is saying nss-systemd not found.
Should I follow the link and activate the nss-systemd service to let the installer seeing it?

Big thanks again

@mark07 yes, enable --now and see if that helps.

Hello @malcolmlewis ,
I tried with enable and also starting the service but still getting this

Checking for missing dependency packages ...
nss-systemd is missing in the machine
sudo password 
Refreshing service 'NVIDIA'.
Refreshing service 'openSUSE'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: the installed systemd-254.9-1.2.x86_64 obsoletes 'nss-systemd < 254.9-1.2' provided by the to be installed nss-systemd-245.7-3.110.x86_64
 Solution 1: Following actions will be done:
  downgrade of systemd-254.9-1.2.x86_64 to systemd-245.7-3.110.x86_64
  install systemd-245.7-3.110.x86_64 from vendor obs://build.opensuse.org/devel:openSUSE:QA
    replacing systemd-254.9-1.2.x86_64 from vendor openSUSE
  downgrade of udev-254.9-1.2.x86_64 to udev-245.7-3.110.x86_64
  install udev-245.7-3.110.x86_64 from vendor obs://build.opensuse.org/devel:openSUSE:QA
    replacing udev-254.9-1.2.x86_64 from vendor openSUSE
  downgrade of systemd-network-254.9-1.2.x86_64 to systemd-network-245.7-3.110.x86_64
  install systemd-network-245.7-3.110.x86_64 from vendor obs://build.opensuse.org/devel:openSUSE:QA
    replacing systemd-network-254.9-1.2.x86_64 from vendor openSUSE
  downgrade of systemd-coredump-254.9-1.2.x86_64 to systemd-coredump-245.7-3.110.x86_64
  install systemd-coredump-245.7-3.110.x86_64 from vendor obs://build.opensuse.org/devel:openSUSE:QA
    replacing systemd-coredump-254.9-1.2.x86_64 from vendor openSUSE
 Solution 2: do not install nss-systemd-245.7-3.110.x86_64

Choose from above solutions by number or cancel [1/2/c/d/?] (c): c
Failed to install dependencies.Please execute following command manually.
 zypper install -y nss-systemd

Failed installation due to missing dependency : , nss-systemd

I tried to do solution 1 but downgrading and replacing systemd is breaking the system (I cannot login anymore with GUI).

Do you have any idea?

PS big thanks in any case for the patience and help already.


@mark07 why downgrading systemd? I suggest you talk with the application developers as to why your having an issue…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.