Nouveau DRI/3D driver without NVIDIA?

After 3 weeks holiday I found that my Leap15.4 computer had 40 updates. When trying to install I received the following Licence agreement message:
"WARNING: Nouveau DRI/3D driver selected.

This driver is considered experimental and is known to have issues with
applications that use certain 3D acceleration features of modern
NVIDIA hardware.

Symptoms include application crashes or lockups & crashes of your system’s

graphical environment. Older Hardware and less demanding applications may work
just fine and do benefit from the Hardware acceleration features this driver
offers over software emulation.

Now the strange thing is I don’t have Nvidia hardware and I never needed a Driver from Nvidia so I stopped the update.
Here is what I have got:

lspci -vv
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (
rev 09) (prog-if 00 [VGA controller]) 
        Subsystem: Intel Corporation Haswell-ULT Integrated Graphics Controller 
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+ 
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx- 
        Latency: 0 
        Interrupt: pin A routed to IRQ 44 
        Region 0: Memory at f7800000 (64-bit, non-prefetchable) [size=4] 
        Region 2: Memory at e0000000 (64-bit, prefetchable) [size=256] 
        Region 4: I/O ports at f000 [size=64] 
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128] 
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit- 
                Address: fee04004  Data: 0024 
        Capabilities: [d0] Power Management version 2 
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-) 
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME- 
        Capabilities: [a4] PCI Advanced Features 
                AFCap: TP+ FLR+ 
                AFCtrl: FLR- 
                AFStatus: TP- 
        Kernel driver in use: i915 
        Kernel modules: i915

So up to now the i915 driver worked fine and with the warning of “application crashes or lockups & crashes of your system’s” I see no reason why I should install this driver. Now of course you can untick the part you don’t want to install with the updates but going through the 40 items on the list I see no “Nouveau DRI/3D”. so I used command line zypper up. There I get the message 130 packages to upgrade and 12 new to install. In those to upgrade are the following 2 packages: [FONT=arial]Mesa-dri- nouveau and libvdpau_nouveau. So I preusume I can take the “Recommended Updates for Mesa” of is there a better way without blacklisting? I just don’t see any need and potentially many problems installing the Nvidia driver. Any thoughts?[/FONT][/size][/size][/size][/size]

Standard install. Because it is installed does not mean you are using it. You can black list it if you never will have NVIDIA hardware.

Thank you for your reply, gogalthorp, what should then be black listed - [FONT=arial]Mesa-dri-nouveau and libvdpau_nouveau or Mesa?[/FONT]

Dependencies would seem to be bogus for libdrm* packages:

# inxi -S
  Host: ab85m Kernel: 5.14.21-150400.24.18-default arch: x86_64 bits: 64
    Console: pty pts/0 Distro: openSUSE Leap 15.4
# rpm -e libdrm_nouveau2
error: Failed dependencies: is needed by (installed) Mesa-dri-21.2.4-150400.68.3.1.x86_64 is needed by (installed) Mesa-gallium-21.2.4-150400.68.3.1.x86_64
# inxi -Cx
  Info: dual core model: Intel Pentium G3220 bits: 64 type: MCP **arch: Haswell**
    rev: 3 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 1718 high: 2227 min/max: 800/3000 cores: 1: 1210
    2: 2227 bogomips: 11972
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
# pinxi -Gaz
  **Device**-1: **Intel** Xeon E3-1200 v3/**4th Gen Core Processor Integrated Graphics**
    vendor: ASUSTeK driver: i915 v: kernel arch: Gen-5.75 process: Intel 45nm
    built: 2010 ports: active: DP-1,HDMI-A-3 empty: HDMI-A-1,HDMI-A-2,VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0402 class-ID: 0300
  Display: x11 server: X.Org v: 1.20.3 driver: X: loaded: modesetting
    unloaded: fbdev,vesa alternate: intel gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4160x1440 s-dpi: 120 s-size: 880x304mm (34.65x11.97")
    s-diag: 931mm (36.65")
  Monitor-1: DP-1 pos: primary,left model: Acer K272HUL serial: <filter>
    built: 2018 res: 2560x1440 hz: 60 dpi: 109 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  Monitor-2: HDMI-A-3 mapped: HDMI-3 pos: right model: Dell P2012H
    serial: <filter> built: 2012 res: 1600x900 hz: 60 dpi: 92 gamma: 1.2
    size: 443x249mm (17.44x9.8") diag: 508mm (20") ratio: 16:9 modes:
    max: 1600x900 min: 720x400
  OpenGL: renderer: **Mesa Intel HD Graphics (HSW GT1)** v: 4.6 Mesa 21.2.4
    compat-v: 3.1 direct render: Yes
# rpm -e --nodeps libdrm_nouveau2
# rpm -qi libdrm_nouveau2
package libdrm_nouveau2 is not installed
# rpm -qa | grep veau

Xorg ran, apparently normally, after restart, after running all the above commands. AFAICT, there should be no need for nouveau on any system lacking an NVidia GPU. However, the restart changed inxi -Gaz output, to end thus:

  OpenGL: renderer: **N/A v: N/A direct render: N/A**
# xdriinfo
Screen 0: not direct rendering capable.

I had to reinstall it to get Mesa showing as in use again:

# zypper install libdrm_nouveau2
# inxi -Gaz | tail -n2
  OpenGL: renderer: Mesa Intel HD Graphics (HSW GT1) v: 4.6 Mesa 21.2.4
    compat-v: 3.1 direct render: Yes
# xdriinfo
Screen 0: crocus

Nothing needs to be blacklisted WRT nouveau for use with Intel IGPs. Mesa-dri-nouveau and libvdpau_nouveau are unneeded and can be removed.

Thank you, mrmazda. I haven’t installed them yet but it might be easier to blacklist them. Otherwise they might come back with the next update.

Packages you wish not to be installed you either lock with zypper or taboo with yast. Blacklisting is generally about preventing modules from loading. I need neither because before anything tried to install Mesa-dri-nouveau I had this:

# grep onlyR /etc/zypp/zypp.conf
 solver.onlyRequires = true

None of this has anything to do with i915 loading or not. As long as Haswell is your only graphics hardware, i915 is going to load, if you don’t block it from loading via blacklist, nomodeset or i915.modeset=0.

bor@localhost:~> ldd /usr/lib64/dri/ 
    ** => /usr/lib64/ (0x00007f4bc24da000)**

If you think it is wrong, you need to discuss it with Mesa developers.

# xdriinfo
Screen 0: not direct rendering capable.

It should print error message about missing library. Did you intentionally omit it?

A lot of what you write mrmazda and arvidjaar is over my head. however I agree with the statement “there should be no need for nouveau on any system lacking an NVidia GPU” and there is no need to request for users who have no NVidia hardware to agree to Nvidias licence agreement (which is pre-condition for the install - otherwise the update does not go ahead. I am all for open source and without urgent need I don’t want to install closed source software. Further mrmazda - when I wrote blacklisting I meant tabooing/locking the file that it does not get installed. I have taboo’d files before and this will be the first step to try for me.


It should print error message about missing library. Did you intentionally omit it?[/QUOTE]If by “it” you mean some error message produced by xdriinfo, my code tags contain all that showed up in Konsole. I left out nothing visible. Maybe an error message would appear in TW under equivalent configuration?

Sorry, for not reading all of the above.

May I point to this thread:

It is about (a certain type of) Intel graphics.

What you see with your update (I used YaST > Software > Online Update) is what I saw this morning. I choose to not use that MESA thing (I think it was choice #2 in the question) specialy because it warned that it could be problematic with KDE. It then told me something about de-installing something, of which I forgot the details (and of course can not re-create it).

After the update I removed the line from my.profile (which was there to by-pass the problem)


which BTW was, on request of the developers handling the bugzilla, changed in


and loged out/in. Problem with KDE programs gone!

I then changed back default-displaymanager from lightdm to sddm (which was also done to by-pass the problem) and re-booted. Problem gone!.

So I am happy and hope you can now see what this is doing.

Thank you, hcvv, I will try tomorrow morning (it is too late now). I have one more question: You wrote “After the update I removed the line from my.profile” where is this my.profile?

When you did not have the problem described in the other thread, you most probably did not use the by-pass by adding the line to your .profile. Thus why should you try to remove it? And if you have added the line in your .profile, then you would know where it is. :wink:

BTW, it is ~/.profile (for every user of course).

If you do not have a NVIDIA graphics card you should have no need for those packages to be installed.

My system has Intel graphics only

# inxi -G
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
    driver: i915 v: kernel
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 driver: X:
    loaded: modesetting gpu: i915 resolution: 3840x2160~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 4600 (HSW GT2) v: 4.6 Mesa

and the only nouveau related packages i have installed are

# zypper se nouveau
Loading repository data...
Reading installed packages...

S | Name                   | Summary                                                      | Type
i | libdrm_nouveau2        | Userspace interface for Kernel DRM services for NVIDIA chips | package
i | libdrm_nouveau2-32bit  | Userspace interface for Kernel DRM services for NVIDIA chips | package
  | libvdpau_nouveau       | XVMC state tracker for Nouveau                               | package
  | libvdpau_nouveau-32bit | XVMC state tracker for Nouveau                               | package
  | libXvMC_nouveau        | XVMC state tracker for Nouveau                               | package
  | libXvMC_nouveau-32bit  | XVMC state tracker for Nouveau                               | package
  | Mesa-dri-nouveau       | Mesa DRI plug-in for 3D acceleration via Nouveau             | package
  | Mesa-dri-nouveau-32bit | Mesa DRI plug-in for 3D acceleration via Nouveau             | package
  | xf86-video-nouveau     | Accelerated Open Source driver for nVidia cards              | package

However I use openSUSE Tumbleweed (with Plasma5 as desktop) so your situation may be different. But it might be worth trying to remove the packages Mesa-dri-nouveau and libvdpau_nouveau.



It is not “NVidia license agreement” and package does not come from NVIDIA anyway.

We also cannot tell why you have Mesa-dri-nouveau installed. This package is not required or recommended by any other package, not does it supplement any other package/hardware. I do not have it installed here. So it does not look like something installed automatically.

Point is that you do not HAVE to remove packages. nouveau is part of the basic openSUSE install but it should not interfere with usage of any non-NVIDIA graphics. It has always warned the it is experimental. But that is not a problem since it is essentially stable. My advice leave it alone it is not hurting anything and if you start removing things because maybe you don’t currently use you will eventually break something. You will not save all that much space.


I reported things in the bug report and mentioned that it now was solved for me. But now a new entry in the bug report says:

YaST popup for package possibly breaking KDE –> probably Mesa-dri-nouveau; this popup should no longer occur; currently handled in a separate bugreport.

Could be with the latest Mesa update you no longer need the workaround, but unfortunately it broke Mesa for almost everybody else, so I needed to revert this change. So with next Mesa update you probably need the workaround with MESA_LOADER_DRIVER_OVERRIDE again.

Which, as far as I see it, says

  1. De pop-up about MESA-Dri Nouveaus is an error in itself that will be (is) fixed.
  2. The cure to the segfault problem is a wrong one and will be removed, thus the error will return! And thus the work around with

in the .profile of a user should then be used again (as well as not using SDDM).

What is the reason for having the packages Mesa-dri-nouveau and libvdpau_nouveau installed if there is no NVIDIA card in the system?



Are you asking the poor users here? They will probably have no idea, they just installed their system. And when those packages are on the system after installation, they never even looked, let alone wondered if they are used or not and why they are there when not used.

Personally I had no idea what MESA is, nor what dri is. I only since a few days know that they exist and I even used the word MESA by adding


to my .profile. But I still do not know what it is, let alone that I understand the connection with “crocus”, which, at least in the Dutch language, is a flower that announces spring here.

No I’m not!

I would like to address the system administrators (of the systems which are probably used by “poor users”). Because I expect that the administrators know why certain packages are installed in the systems they are responsible for and why certain settings in a users profile are needed.



It is the decission of the openSUSE developers to include different package sets dependend on the system role you chose whilst installation. openSUSE is not the only distribution which installs a subset of packages whilst installation even if they are not needed (unneded patterns or kernel firmwares as example).
As example PCLinuxOS installs a complete set of drivers (also the proprietary NVIDIA driver set) even if you only have a Intel CPU/GPU. PCLinuxOS installs even more stuff where you can only shake with your head (because it is not needed or wanted). Not many distributions give their users a chance to make an individual package selection whilst installation.
Mageia as example has the possibility to select/deselect sub-groups of packages like multimedia, office, editors, internet, server, and more… And you can even chose individual packages to install or deselect them if you don’t want them installed.