Nouveau blacklist?

Hi! :slight_smile:

Can someone tell me please, how to prevent nouveau from starting?
The wiki page (SDB:NVIDIA the hard way - openSUSE) has a reference to menu.lst, but nothing for the current GRUB version.

The wiki page states this as the first sentence:

To prevent the proprietary NVIDIA driver from conflicting with the default nouveau driver, prevent the nouveau module from getting loaded at boot by blacklisting it:

echo “blacklist nouveau” >> /etc/modprobe.d/50-blacklist.conf

Haven’t you seen that? rotfl!

That should be enough.

If you do want to add the modeset thing to the kernel options, just use YaST->System->Boot Loader->Boot Loader Options.

No it isn’t.
I have already done this.

Let me try it and I’ll be back.

Did you reboot?

Ehm…How??? :question:
I went there, but I don’t know what to add.
Any more specific instructions???

I’ve done all previous steps (including rebooting), but nvidia driver still complaints that nouveau is active.

Enter YaST->System->Boot Loader, click on Boot Loader Options and append “modeset.nouveau=0” to “Optional Kernel Command Line Parameter”.

Also have a look at the release notes, this is in there since 12.1:

But if you wasn’t able to figure this out, maybe you should install the driver “the easy way”?
The official repo is available for 13.1 as well since today… :wink:

Uinstall xorg-x11-driver-video-nouveau if you want to entirely remove nouveau. But that should not be necessary if the NVIDIA driver is properly installed.

And it won’t help at all, because the nouveau kernel modules is not uninstalled then and still loaded at boot preventing the nvidia driver to work.
The nouveau kernel module is included in the kernel package.

THANKS guys for your help!!!
OK. I installed the repo version.

BTW, that did the trick! :wink: