Notebook freezing with later kernels including Spectre/Meltdown protection.

I encountered unexpected freezing of my ASUS UX303UB after software update. First it happened after some longer time of operation, recently quite soon after restart. It happened very often and only hard restart was possible.

I reinstalled the system many times, it helped shortly. I also created a new user, as adviced on forum in other threads. I checked also if my SSD disk is not broken.
As I get always information [Firmware Bug]: ACPI region does not cover the entire command/response buffer) I tried ACPI option OFF, what initially helped, later no more.

In version 4.4.120 I got additionally information on Spectre vulnerability, that was not shown on 4.4.114. I started to check it in older versions of kernel with command grep . /sys/devices/system/cpu/vulnerabilities/* until I got in version 4.4.104 result “No such file or catalogue”

Surprisingly my notebook started to work normally and ideally stable with this version of Kernel. I work now over 5 days, many hours a day. No bad issues.

Is it possible that Spectre/Meltdown protection in Kernel may freeze my notebook?

But you should start with perhaps inspecting the last 50 or so lines in your system log before your machine froxe.

You can inspect previous bootlogs, so for instance if you can remember that you’ve booted 3x with your problem-free kernel, you can inspect the bootlog from 5 boots ago and reverse the output so that the last entries are displayed first

journalctl -rb -5


It is unfortunately too late as I do not know how far to search for it. But I tried to provoke such behaviour starting system with the recent kernel 4.4.120. \


  1. it does not show vulnerability for Spectre V2
  2. the system works perfect since the post of Tsu2

maybe there was an update in the meantime