not working knemo 0.7.7-2.4

I installed knemo 0.7.7-2.4 but no add icon and reboot system still no see icon
And go to Runing user/share/applications/kde4/knemo
But no not working.
Remove and re-install still not work and not added icon
In your opinion.what’s the problem?

What icon exactly is missing?
The one in the system tray, or the one in the applications menu?

And you cannot “run” user/share/applications/kde4/knemo (such a file doesn’t even exist, it should be /usr/share/applications/kde4/knemo.desktop, but that only describes the menu entry anyway… :wink: ).
Try running knemo instead.

If you are unlucky, knemo won’t detect your network connection though. It doesn’t show any icon in that case, so you cannot even reach the settings.
Try running “kcmshell4 knemo” (or install kdebase4-workspace-addons to get “Configure KDE4 Applications”, which should contain the settings for knemo as well) and add your network interface.

Thanks bro
Run “kcmshell4 knemo”
Now added icon and good works

Now works knemo
I think my system have problem
I install “kdebase4-workspace-addons” but not add icon configure kde4 and not found

Because KDE4’s systemsettings have not been renamed to “Configure KDE4 Applications” in Leap by mistake. I forgot about that, sorry.
I prepared an update already, but haven’t submitted it yet (because we also still miss the translations to other languages)…

As its menu entry has the same name as systemsettings5, the menu will hide one of the duplicates.
To “fix” that, right-click on the application menu icon and choose “Edit Applications…”, then change the name of one of the two.
Or run it manually, either in a konsole or the Alt+F2 dialog (KRunner), it’s called “systemsettings” instead of “systemsettings5”.

But then, you don’t really need it. You can reach knemo’s settings also by right-clicking on its icon in the system tray.