Not even new to SUSE yet ... Pre-install issues

Many years ago I was on Red Hat for a while, it was my first linux, and I still remember rpm’s, but my recent years have been on Ubuntu. The problem with Ubuntu is when a project you want to develop for uses all the latest versions of the libraries. Which is why in my new AMD rig (Ryzen + Radeon) I decided to dual boot Ubuntu 24.04 and tumbleweed.
On with my questions:
What’s going on with the installation image files? First it was my fault; I was trying to use an Ubuntu tool to make a SUSE bootable stick. But then I tried to install etcher, which refused to in 24.04; luckily I still have my old laptop running 22.04, and etcher installed nicely there. But so I downloaded the image again, burnt the stick with amd64 tumbleweed, but when I try to boot off it with my new rig, it ignores the stick completely.
Opening the thing looks okay, with folders,


and files,


How do I go about diagnosing the problem?

And a question for thereafter:
I have 9 partitions on my disk, including swap …
sda1: 1 gig VFAT for boot (shared)
The next 3 partitions are Ubuntu’s:

    sda2: 1 gig ext4 for /temp
    sda3: 1 TB ext4 for /
    sda4: 2.5 TB ext4 for /home

(all the above for Ubuntu 24.04)
sda5: 80 gig swap (shared)
(all the stuff below for SUSE)

    sda6: 1 gig ext4 for /temp,/var
    sda7: 1 TB ext4 for /
    sda8: 2.5 TB ext4 for /home

… or at least that’s my plan.
The question is, how do I explain this to the installer?
Installing 24.04 was relatively easy because there was nothing there yet; but now I’m paranoid of the SUSE installer confusing sda2 through sda4 for sda6 through sda7, and mixing into Ubuntu’s partitions. Is this going to be easy and straightforward during the installation?, or do I need special magic?

If the USB stick is ignored whilst boot, it is in most cases a BIOS/UEFI boot order setting. You need to check your BIOS/UEFI settings for the boot media order. USB (removable media) must be before HDD/SSD.

No, I should have mentioned, I checked the bios several times; the order is USB first. In fact, I never touched it since I installed Ubuntu from a stick.

Start with describing your system (legacy BIOS or UEFI) and how you created this USB stick. The

does not explain much.

1|) my system:
Mobo is AM5, MSI Mag X670e Tomahawk WiFi
The first thing I did was update the bios, and that was
two or three weeks ago.
Got 32 gigs of DDR5 on it
Processor is AMD Ryzen 5 7600 I think it was, with a HUGE heatsink with two fans, even though I’m not overclocking or anything like that.
Video card is Sapphire with Radeon 7600, and 8 gigs of DDR6.
Hard drive is a Barracuda 8 Teras, standard 5600 rpm.
Power supply is way over-specified, a 750 Watt Corsair.
ATX case has 4 big fans.
Bios settings are everything at factory settings, basically, except I removed the safe-boot option, which I don’t remember if it was on by default or whether I turned it on; but basically I did not mess with the bios much, except to update it. Wish I could say something about UEFI but I’m not familiar with it; only saw it since putting together this box; I don’t even know what it is.

  1. How I created the USB stick:
    I installed balena-etcher on my Ubuntu 22.04 laptop
    I downloaded the tumbler iso file:
    I fired up etcher, pointed it to the file, plugged in the usb stick, cancelled the offered file explorer open, pointed the stick (sdb) to etcher, then hit Flash!
    It worked for about 15 minutes, and told me it was finished.
    So then I came to my new rig with the stick, rebooted, and plugged it in during the bottom of the boot. But nothing happened; it came back to Ubuntu. I checked my bios, and it has usb removable first in the boot list.

Update: I just tried to boot off my other USB stick, the Ubuntu 24.04 installer, which used to work, and it didn’t see it either; so it MUST be something with my bios.

Another update: I managed finally to get the machine to boot off the Ubuntu installer stick, but never once got it to boot off the Tumbleweed installer stick.

(By the way, both sticks are 32 gig Kingston Traveler; I bought them at the same time, precisely to make two two installers for my dual boot machine.)

The weird thing is it took me several attempts to get that one boot to work, and I don’t know what’s the problem; it was working fine before.
So, after I verified that my Ubuntu stick was not working either, I went into the bios and found the SATA drive first and USB second priority, which I’d swear I never set so. So I changed them to put USB first, but it still didn’t work. Went into the bios again, and they had not been swapped out or anything; tried again; did not work. Then I rebooted and went into the bios again and hit F6 to load factory settings, and from there I changed the boot priority to USB first, and disabling of safe boot. Everything else I left at factory setting. When I hit Save and Reboot, the bios said I had not changed any settings, and asked me if I was sure I wanted to save and reboot, and I said yes. This was the only time the stick worked and it booted the Ubuntu installer. Maybe there was a wrong bit there that needed to be set or cleared by a forced save?
I don’t know; but, after that, I tried multiple times to boot the SUSE installer and nothing happens; it goes to Ubuntu off the SATA.

Regarding UEFI settings:
There is normally one setting:
>UEFI Hard Disk Drive BBS Priorities Boot Option #1
has choices,

    ubuntu (SATA P3 ...)

And if I have a stick in a USB port, there is a second entry:
>UEFI USB CDROM/DVD Drive BBS Priorites Boot Option #1
has choices,

    UEFI Kingston Data Traveler

That’s all Klingon to me; neither is disabled; is that correct? Both say “Option #1”, whatever that means…