Not associated

Looks like I finally caught the problem with 50% chance to have Internet up after the reboot. Even if Internet is down I can still scan for networks. If I try to connect to the proper router it says

Connection request to: muxecrouter failed. You are currently not associated with this accesspoint. Try again!

From my ability to see nearby access points I assume it is not a ndiswrapper driver problem, but problem of “stupid linux” type.

Are there any fixes?

Hey! Is there anyone competent enough to help me? This problem is almost blocker for me and I can imagine people who see this bug as blocker. Well, I know that I did not pay for linux or whatever. :wink: I want to at least understand what’s the problem before adding it to bug tracker. (Understanding bug what package’s bag it is would be great).

comments like this will not endear you to the community, would be better rephrased. As for help,have you read the stickies at the start of the wireless section ? any problems apart from the above ?You did set things up via YaST - network devices - network settings ? a bit more info on what you have tried would help also


I did read the FAQ post, the word “associated” appears there once but it looks like it is irrelevant to my problem.

Yes, it is configured wireless in Yast. Every time I reboot the PC there is like 50% chance that on next boot internet will be up. If it is not I can still scan for networks (scan actually happens, I see APs in my neighborhood the list refreshes if something changes) but when I try to connect I get “not associated” error (message quoted above).

This bug is extremely annoying as it feels like Stupid Linux(r) is rolling a dice at boot to decide whether to **** me off.

still don’t say which method you are using, network manager or ifup,hardware you are using,ndiswrapper or native driver ? then we may have a better chance of giving you an appropriate response


Using ndiswrapper for ath5k. I tried madwifi but it broke whatever little that actually worked.

Tried both ifup and network manager. Same 50% chance of no internet on reboot. The error message is from KInternet, ifup just fails silently (and says it is actually connected somehow to somewhere if I try ifconfig)

ok, have you tried the drivers from here Index of /repositories/home:/schmolle1980/openSUSE_11.0/i586 ndiswrapper can cause this sort of problem. the way round it, i found, was to re-start the wireless router & try again. Can you post the output of



Why are you calling it ‘Stupid Linux’ ?
With the wordings and the tone you are using you are lucky someone is willing to help.

Cause when I see bundled Internet Explorer not working on freshly installed WindowsXP I call it “Stupid Windows”. :wink:

Any guide to how I configure alternative driver if I already have ndis from repos installed? I mean guide in human readable format that says exactly how to configure it and, if needed, instructions to safely disable the old one.

Since ndiswrapper is already in place, look thru here for something you missed:
Ndiswrapper - openSUSE

e.g. did you do the ‘ndiswrapper -m’ command that it shows?
e.g. did you blacklist the alternate-driver?

iwconfig results:
With buggy internet:

linux-l5b4:/home/muxec # iwconfig
lo no wireless extensions.

wlan0 IEEE 802.11g ESSID:“muxecrouter” Nickname:“linux-l5b4”
Mode:Managed Frequency:2.432 GHz Access Point: Not-Associated
Bit Rate:108 Mb/s
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

With working internet:

linux-l5b4:/home/muxec # iwconfig
lo no wireless extensions.

wlan0 IEEE 802.11g ESSID:“muxecrouter” Nickname:“linux-l5b4”
Mode:Managed Frequency:2.432 GHz Access Point: Not-Associated
Bit Rate:108 Mb/s
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

So, do you have ‘ath5k’ blacklisted?

Another thing that would be very helpful would be to post
which device you actually have. [And, since you haven’t
done that, it makes me think that maybe you also haven’t
read the ‘sticky’ posts at the front of this ‘wireless’ forum.]

Those ‘stickies’ request that you run a cmd like
‘lspci’ (if your device is pci-bus based) and post the result.
Actually, for your situation, the best cmd would be:
hwinfo --wlan
Once we know what device you actually have, we can
better lead you to the best solution.

Lastly, reading other posts in this forum, especially ones
of people who have the exact same device that you do,
will bring the quickest results.*

I mean ndiswrapper for stuff that attempts to use ath5k by default. ath5k is blacklisted as described in the guide.

Here it is (when network is up)

linux-l5b4:/home/muxec # hwinfo --wlan
01: PCI 500.0: 0282 WLAN controller
[Created at pci.310]
UDI: /org/freedesktop/Hal/devices/pci_168c_13
Unique ID: y9sn.Hpw2bX1iAM4
Parent ID: 6NW+.two+GgbUMg7
SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:05:00.0
SysFS BusID: 0000:05:00.0
Hardware Class: network
Model: “Atheros TRENDnet TEW-443PI Wireless PCI Adapter”
Vendor: pci 0x168c “Atheros Communications, Inc.”
Device: pci 0x0013 “AR5212/AR5213 Multiprotocol MAC/baseband processor”
SubVendor: pci 0x168c “Atheros Communications, Inc.”
SubDevice: pci 0x2051 “TRENDnet TEW-443PI Wireless PCI Adapter”
Revision: 0x01
Driver: “ndiswrapper”
Driver Modules: “ndiswrapper”, “ndiswrapper”
Device File: wlan0
Features: WLAN
Memory Range: 0xfb000000-0xfb00ffff (rw,non-prefetchable)
IRQ: 20 (no events)
HW Address: 00:1d:0f:b6:6d:7f
Link detected: yes
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
WLAN bitrates: 1 2 5.5 11 6 12 24 36
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: “pci:v0000168Cd00000013sv0000168Csd00002051bc02sc00i00”
Driver Info #0:
Driver Status: ath5k is not active
Driver Activation Cmd: “modprobe ath5k”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #9 (PCI bridge)

Please tell me what diagnostic tools I can run. I want to help you to help me. :wink:

One place I go for a first-indication is the website:
Linux wireless LAN support
where the link above shows your device as ‘green’ for the madwifi-driver.
(i.e. the ‘ath_pci’ driver, whose ‘ath_hal’ component is proprietary)
So, that driver should work for you.

ndiswrapper (i.e. the Windows driver) is proprietary too, so
it looks like you’ll have to ‘taint’ your kernel, no matter
whether you choose madwifi or ndiswrapper. Since you
already have familiarity with ndiswrapper, and since their
website documents 4 separate successes, I’d keep trying ndiswrapper:
Look specifically at entries 5,44,46,73 in the page above, all of which show your same
pci-id: 168c:0013

For starters, make sure that you have executed:
ndiswrapper -m
which creates a file: ‘/etc/modprobe.d/ndiswrapper’
aliasing wlan0 to the ndiswrapper module. (If you ever decide to
switch back to trying to use the madwifi-driver, make sure that you
DELETE this file, as one of the steps in removing ndiswrapper support.)

Yast2->network devices->network settings is where you are supposted to
to ‘configure’ your device, and I assume you’ve been thru this. One
caveat: lots of people are reporting issues here…one approach is
to DELETE the entry pertaining to your device, reboot, and go back
in (it should get re-created and show up as non-configured), then click on
‘edit’ and configure it again. Some (including me) had better luck with
‘ifup’ than with ‘network-manager’ under the global-options section, when
using ndiswrapper.

Your output shows that the windows-driver you currently have setup is trying
to run at the (non-standard) bit-rate of 108Mb/s (as the two entries #44 and #46 mention).
I think that only works if your router supports ‘Super G’ rates, so that MIGHT be the problem!
[To test that theory, you could try either of the two Windows-drivers pointed to
by entries #5 and #73 and see if they default to the standard 54Mb/s rate.]
[There is also another way…mucking around in the generated config-file that controls
these lower-level details, but I’d have to do some forum-searching to find
the details for how to do that. Search for ‘bit rate’ in the wireless forum if you
want to learn how to hack on that.]

Hope this helps more than it confuses. [This pretty well reaches the
extend of my knowledge. Good luck.]


The entries you mention are all 108Mbit, not sure that there are 64 bit drivers everyone. At least now I have one hypothesis on the cause of the problem, non-standard speed. However my router is 108Mbit too.

Where should I ask for the meaning of “not associated”? Ndis forums? Kinternet forums? Everywhere?

When your wireless device connects with the access point, it must
complete two steps - establish that the AP is the correct one, and
then perform the authentication process. Only when both steps are
complete is it “associated”.

Looks like madwifi solved it. It was probably a driver problem, but the front end failed to report the problem in understandable way. Thank you for your help.