Not able to use Dedicated GPU

So I have a dedicated GPU on my laptop which is not being used when I run wine. Also amdgpu-install is not working too when I tried updating the drivers after I found about the gpu not being used. I looked up online and saw people suggesting to use the
‘xandr --listproviders’ command, the output is
‘Providers: number : 0’ which did not seem to be the output others were getting
However, when using lspci -nnk, it gives details of all hardware devices including my dedicated gpu
Also, further i tried using the
glxinfo | grep -i direct command and the output was
GL_AMD_gpu_shader_int64, GL_AMD_multi_draw_indirect,
GL_ARB_depth_clamp, GL_ARB_derivative_control, GL_ARB_direct_state_access,
GL_ARB_draw_elements_base_vertex, GL_ARB_draw_indirect,
GL_ARB_indirect_parameters, GL_ARB_instanced_arrays,
GL_ARB_map_buffer_range, GL_ARB_multi_bind, GL_ARB_multi_draw_indirect,
GL_AMD_multi_draw_indirect, GL_AMD_performance_monitor,
GL_ARB_direct_state_access, GL_ARB_draw_buffers,
GL_ARB_draw_indirect, GL_ARB_draw_instanced, GL_ARB_enhanced_layouts,
GL_ARB_indirect_parameters, GL_ARB_instanced_arrays,
GL_ARB_map_buffer_range, GL_ARB_multi_bind, GL_ARB_multi_draw_indirect,
GL_EXT_direct_state_access, GL_EXT_draw_buffers2, GL_EXT_draw_instanced,
Also my laptop works perfectly find otherwise, the system is dual boot with windows and dgpu works perfectly fine on it.
Specs : HP Omen 16 Advantage Edition
Ryzen 7 5800H, AMD RX 6600M, 16gb RAM, 1tb SSD

Could not edit so updating below
Game uses GPU with lutris but still works weird
Image below

EDIT : was not using DGPU, same gpu but with more VRAM, idk how, earlier it was 500mb now its 8gb

It would have been useful to post the actual output of the xrandr command you referenced, rather than describing the output in words. Note that I have used the preformatted text button ‘</>’, and that is how you should post commands and output in their complete form…

xrandr --listproviders
inxi -Ga

For hybrid graphics systems, PRIME is used

Did you try specifying the graphics card using something like…

DRI_PRIME=1 wine <game.exe>

FWIW, a similar reddit thread…