noob confused trying to install VMware tools on 11.0

Trying to install VMware tools by opening rpm from disk image in Package Manager.

“Package Tools/VMwareTools-7.6.3-94249.i386.rpm was not found on the medium”
“Package /media/VMware was not found on the medium”
It then quits.

complete opensuse virgin. halp.

copy the VMwareTools-7.6.3-94249.i386.rpm file to a directory in your /home (or on your desktop) and retry installing from there.

When installed, open a terminal, ’ su - ’ enter root pw to get your root rights , and run

If all is well the tools are installed.

Note: I’ve seen mentioned that vmdrivers have been added to openSUSE 11.
It’s possible you don’t need to install the tool package anymore… but I haven’t installed version 11 in vmware yet.


Thanks very much- I moved it into my home folder and that took us a bit further.

It was that I needed to run.

I had problems during the process- wouldn’t build vmmemctl, vmhgfs or vmblock modules because

Your kernel was built with “gcc” version “4.3.1”, while you are trying to use
“/usr/bin/gcc” version “4.3”

Checking the version on yast shows me it’s version 4.3-39.1…

you can install the driver by running again after making
sure that gcc, binutils, make and the kernel sources for your running kernel
are installed on your machine.

but but but but I had made sure these were all on the system- but I don’t know how to check the kernel version (is it kernel-default in yast? if so the versions matched…) and as far as I can see there aren’t alternate versions to install on the DVD, nor in the default repositories…


If you go to the VMware support forums, Forums - Powered by vBulletin
under support, you’ll find my thread about not being able to install the VMware tools in Suse. It ended up in me installing the source code for the kernel in my installation after which the VMware tools installed like they should. The only problem was that when I tried to reboot afterwards, GNOME would not open up, but just stayed in a loop of starting and crashing. It appears there is a problem with the smartd daemon causing the greeting application not to launch properly. No one answered my thread afterwards so I don’t know what the resolution should be. This was using Suse 10.3 in a clean install in Fusion for Mac. Everything was 32 bit. I’m sorry I can’t give you more help here. I’m now in Suse 11.0 on my G4 PPC where I just have sound and video problems along with gnuCash with no help system. :slight_smile:

Thanks motsteve- maybe it’s too early to be trying to get opensuse 11 up and running on VMware- ubuntu hardy seems to be running a lot smoother.

Someone please help. I am very new to OpenSUSE and new to Linux too.

I could not install the VMWare tools at all.

I follow the intructions here: Setting up SUSE Linux as a VMware Guest - openSUSE

I have done this: 4. Right click on VMwareTools-6.0.2-59824.tar.gz archive and extract it into into /tmp/VMwareTools

I am trying to do this: 1. Open a terminal as root and configure VMware Tools by running:

cd /tmp/VMwareTools/vmware-tools-distrib

My actual command in the terminal:

linux-8bxu:/tmp/VMwareTools # ls
FILES INSTALL bin doc etc installer lib
linux-8bxu:/tmp/VMwareTools #
bash: command not found

What does it mean command not found?

Please help.

Hi chong67…

You are doing it right, just one slight detail:

My actual command in the terminal:

linux-8bxu:/tmp/VMwareTools # ls
FILES INSTALL bin doc etc installer lib
linux-8bxu:/tmp/VMwareTools #
bash: command not found

You are getting the command not found because Linux is searching in the search paths for the command.
If you want to execute a command located in the working directory you need to stick ’ ./ ’ in front of it

So your build command should be ’ ./ ’

This is one of those things you have to know about the command prompt in Linux… So, you’ve just learned something new :wink:

Two remarks for you:

  1. As openSUSE is a Linux distribution that uses RPM format for it’s packages it is much easier to use the vmware-tools rpm install. You should also have an rpm file. Use this, it makes life easier. - install the rpm and then run from the command line as root.

  2. I think the build is going to fail as I see you are using VMWare Workstation (?) version 6.0.2.
    For openSUSE 11.0 you will need the 6.0.4 version. This is because it has a very new kernel version. The same goes for Ubuntu 8.04.

Two options: either install the latest VMWare version… or use the vmware-any-any-117 patch found here :

More info can be found here in this thread: (it talks about installing vmware on openSUSE 11.0 as host or as guest):
Suse 11.o Beta And Vmware 6.0.3 - openSUSE Forums

Hope that helps,

P.s. hang in there… It can be very confusing when starting with Linux, -been there!- but if you have any questions, just ask them & we might be able to help. Once you get the hang of things, the more you learn the more you love! …most of the time :wink:

edit: I just checked the vmware-any-any-117 link & see it’s gone dead. Better to get the latest vmware version.

I do have the 6.0.4 version of VMware workstation.

I try to do the easiest thing now and I am doing your #1 remark.

I copy the .rpm to the desktop and run it.

Then I get error about 6.0.4-93057.i386.rpm could not be installed. In the details it say Subprocess failed. Error: RPM failed etc etc

You need more info let me know?


Open a terminal console and try the following to install from there to see the exact error (assuming the rpm file is on your desktop):

su - (& enter root pw)
cd /home/<username>/Desktop
rpm -ivh <vmware workstation rpm>.rpm

You did note the packages you need to install before trying the vmware install (kernel source etc… just to be sure)?


I did install these package:

I did the commands you told me and here they are:

linux-8bxu:/tmp/VMwareTools # su -
linux-8bxu:~ # cd /home/philip/Desktop
linux-8bxu:/home/philip/Desktop # ls
MozillaFirefox.desktop SuSE.desktop VMwareTools-6.0.4-93057.i386.rpm trash.desktop
Office.desktop Support.desktop myComputer.desktop
linux-8bxu:/home/philip/Desktop # rpm -ivh VMwareTools-6.0.4-93057.i386.rpm
Preparing… ########################################### [100%]
file /etc/vmware-tools/poweroff-vm-default from install of VMwareTools-7241-93057 conflicts with file from package open-vm-tools-2008.04.14-21.1
file /etc/vmware-tools/poweron-vm-default from install of VMwareTools-7241-93057 conflicts with file from package open-vm-tools-2008.04.14-21.1
file /etc/vmware-tools/resume-vm-default from install of VMwareTools-7241-93057 conflicts with file from package open-vm-tools-2008.04.14-21.1
file /etc/vmware-tools/suspend-vm-default from install of VMwareTools-7241-93057 conflicts with file from package open-vm-tools-2008.04.14-21.1
linux-8bxu:/home/philip/Desktop #

Whats my next move?

I did almost exactly what you have done and encounter the same issue where you have now.

I did a search on the modules which are clock the rpm installation. Those modules are vmblock.ko, vmmemctl.ko … I think they are under /etc/module

So I deleted them and try again … the install come back with another error … It is just too much.

The easier way to see the error is not using the rpm. Unzip the package and run the install script “”. Then you will see what is the cause.

I am still stuck there because not know how to get around the gcc version complian.

The open-vm-tools-… package is the there by default starting openSUSE 11.0 (lower versions don’t get this).
The open tools basically do the same thing as the official tools you are trying to install… enhance performance. I haven’t really run openSUSE 11.0 as guest in VMWare yet, so don’t know if it’s worth keeping the open-vm-tools.

To get your vmtools rpm installed:
You will first have to de-install open-vm-tools by either doing that from the console (as root, ’ zypper remove open-vm-tools ’ ) or opening YaST > software Management, searching for open-vm-tools and removing it.

After removing it retry the install, all should be well?!

@tcmchow: be careful with that (just building from source) as those actions can also make your system slow/unstable. Using RPM where you can is a better move as your system, in the long run, stays manageable (think installing, upgrading, removing).
As the RPM package manager states there would be a conflict (packages overlapping or interfering with each other) that needs to be resolved.

I found it and was able to uninstall it.

Then I run the .rpm and it was over in 5 sec. Is that it?

Now I cannot find my .pl file

I am so lost.

If the rpm installed without error is should be fine.
what options do you get when you open a terminal console, switch to root (su -) and enter ;
vmware- <2x TAB> ?

it should list all commads for vmware including the

Also what happens if you just run (switched to root) ’ '?

Hi, i’m new in linux.
it’s alright when im on login screen and i couldnt use vmware tools? I can use it after im succesfull login into linux.


Hi Cerno & welcome :slight_smile:

I’m not sure what you are asking here? How do you want to use vmware tools?

Just to give some more info: the vmware tools are a set of special drivers and settings for your virtual guest to make it respond quicker/better and to give extra functionality (like copy/paste between the host and the virtual guest) and automatically releasing the mouse when leaving the guest screen.

heh sorry it was too late :smiley:

Well so i have problem with releasing the mouse between host and virtual guest. When i have a welcome scr(i dont know real name of that)i cannot move mouse between host and guest until i push ctrl+alt. After login it’s everything working correct.

It’s normal that your keyb/mouse gets locked when first starting the XP guest and clicking the console (putting focus to the XP guest).
But once XP has started, vmware tools should be running in the guest as background service.

In XP check the services list to see if the vmwaretools service is set to automatically start at boot. If not set it so.
You could also try reinstalling (maybe uninstalling first) the vmware tools in the XP guest.

Hope that helps,

everything works correct and thank u for explanation :slight_smile:

Can someone please help me?

I am trying very hard to install VMWare tools on the OpenSUSE 11.0 without much success.

I am using VMWare Workstation 6.0.4 built-93057.

I still dont know what I am doing wrong.

Any help you can give me is much appreciated.