no x after update

hey people,
i’m in trouble after doing an online update in suse 11.1
after this update i can no longer boot in runlevel 5, the screen
fades away and stays away.
i am now booted in runlevel 3 and, using yast or whatever, want
to remove the software i installed today.
who can help me with that?
thanks in advance


Undoing the update is no option but it is probably not necessary. The update has given you a new kernel and this means that you have to recompile your graphics driver. Which one depends on your hardware. There have been a lot of posts on this issue in the forum.

I had the same problem the day before yesterday. I my case was the problem the nvidia driver and the fix was relatively easy - to reinstall the driver. In my case :
init 3
sh -q
(agree with the licence)
sax2 -r -m 0=nvidia
init 5

And everything works again.
May be it helps you, by,

this already gives me more of an insight…but i’m just out of time,
don’t know whick nvidia, don’t know how to recompile.
can’t i just go back to the previous kernel?

Look again in the updates for the nVIDIA repository, and you’ll find version 190 driver updates for the kernel. It takes a few days for nVIDIA to make these available after openSUSE makes a kernel update, so one should always wait for them OR do the trick that Karel suggests, which is well worth understanding.

Update, reboot, your desktop should once again be available.

Well, I am at another machine and on that machine, the nVIDIA updates haven’t yet arrived, but they for sure were there on the first machine I tried over the weekend. This may be why some people are having problems.

<sigh> The repo is down for me, but this one has the goodies for x86_64 so I wasn’t dreaming …

Index of /mirrors/opensuse/nvidia/

thanks for all the input, but x86_64, isn’t that for 64-bit machines?
i tried 185.18.39 from nvidia linux display driver archive,
that gave me an errror

the kernel header file
‘/lib/modules/’ does not exist. The most likely reason for this is that the kernel source path ‘/lib/modules/’ is incorrect.
please you have installed the kernel source files for your kernel and that they are properly configured…etc…etc…

i cannot find anything with 190 on the nvidia site.

the sh…command - i hope it is a command - came up with nothing…

i love linux guys, i realy do. but i’m not too happy today.

thanks in advance for any further help

hey all,
i now found new packages on

both nvidia.ymp and nvidia-fx5XXX.ymp give
a bunch of no such file or directory messages.

any advise anyone??
remember i’m in runlevel 3, so if additional info is needed, tell me how to get it.

Well, most modern machines are x86_64, a previous poster used x86_64 in an example, and you don’t appear to have told us what you’re running. :wink:

(Actually, that you’re running a PAE kernel suggests you have a 32 bit, but my point is that you need to help us to help you.)

Don’t install nVIDIA drivers without careful thought. We don’t know what model your nVIDIA card is either, so can’t advise on the right driver.

To complement the x86_64 link I gave you, here’s the i586 link - plenty of 190 rpms.

Finally, to use the “sh NVIDIA…run” method, you should have the Linux kernel sources installed from YaST. That’s what the message “The most likely reason for this is that the kernel source path ‘/lib/modules/’ is incorrect.” was telling you. My current advice: Install the kernel sources using YaST and try the “sh NVIDIA … run” method again.

hey all,
it’s solved!

i downloaded and installed:
rpm -ivh x11-video-nvidia-96.43.11-21.1.i586.rpm
that gave me EM: nvidia-gfx-kmp is needed

so i downloaded and installed
rpm -ivh nvidia-gfx-kmp-pae-96.43.11_2.6.27.37_0.1-20.6.i586.rpm
that gave me EM: x11-video-nvidia is needed.

somewhere i came across “fglrx”

typed that into yast and downloaded everything it came up with
x11-video-fglrx …

you were right, i didn’t give enough info.
the machine is acer aspire 5710G
the card is ati mobility radeon HD 2300.

thanks for the replies
i learned a lot
still – anybody care to explain what fglrx is?

I’m pleased it’s been a success.

You seem to have an ATI card, so didn’t need any of the nVIDIA drivers at all. rotfl!

I don’t have ATI experience, but I think fglrx is one of the packages ATI cards need for Linux.