No write access to samba shares after recent updates/change to firewalld ; smb4k crashes - help!

Hello experts,

my notebook runs on Tumbleweed with most recent updates installed.

Since installation of these updates, I cannot write acces my NAS-shares (samba) anymore.

I find the shares in smb4k, and I can mount them with smb4k. I also find them in krusader and dolphin, but I cannot write in these folders, and also from a terminal I have no longer write access.

I use smb4k for convenience reasons (the NAS is not always running, and smb4k makes mounting the shares very easy).

It worked yesterday and today until installation of the updates.

I stopped and disabled SuSEfirewall, and I tried to understand what firewalld is, enabled it, tryed to configure it, stopped it, disabled it, … - nothing would help.

smb4k has not been updated as far as I can see, but is suddenly quite unstable.

Any help would be very much appreciated!



If you can read but not write sounds like a permission problem. check permissions

Yes, I know. Sorry, but I am completely puzzled … Where can I check permissions? And what can I do else?

In smb4k I entered authentification (user and password).

I have the same issue when I try to configure the share as NFS client under Yast, but this seems something where one needs at least a master degree in Linux :-((( It never worked for me. (It did work, by the way, using Ubuntu … some years ago). That’s why I then started to use smb4k under opensuse.


If mounted ad readable then just right click a folder and check properties

Well … it is quite clearly ro. But HOW can I change this? Here is the ls output:

bogislav@linux-u7cl:~> ls -al smb4k/
insgesamt 8
drwxr-xr-x  3 bogislav users   22 27. Jan 18:09 **.**
drwxr-xr-x 73 bogislav users 4096 27. Jan 18:04 **..**
drwxr-xr-x  3 bogislav users   22 27. Jan 18:09 **IX4-300D**
bogislav@linux-u7cl:~> ls -al smb4k/IX4-300D/
insgesamt 0
drwxr-xr-x 3 bogislav users 22 27. Jan 18:09 **.**
drwxr-xr-x 3 bogislav users 22 27. Jan 18:09 **..**
drwxr-xr-x 2 root     root   0  2. Dez 2016  **Pictures**

The folder “Pictures” is ro …

chmod 755 Pictures/ does obviously not work here …

Well pictures is owned by root so that will not work SMB4 seems to be mounting as root??? Does it work if you go there via the network?? You really don’t need smb4 to access. Or try mounting via mount command (must be root) and set the permissions manually see man mount for details