No window borders

DL’ed 4.1.2 , XGL updates and now I do not have any window borders or Compiz functions .

Have the same problem, to regain borders you’ll have to disable compiz.

Go into YaST and look for an update to Emerald, check the description box as well so that you can make sure to get everything associated with it updated too.

When I see updates ready for Compiz, I ususally go ahead and look for one for emerald too. This is good practice lest you want to run into the windowless borders forever…update, then see if that fixes if you get a system running good there, reboot and make sure everything works…or reboot after updating and then reintroduce emerald borders.

Hope that helps
have fun

I have the same problem, but I don’t use emerald as windows decorator :frowning:

what do you use?

I use the GTK window decorator. When I try to enable compiz I have no windows borders and also all the effects, like the cube, doesn’t work. All was working fine before the last update.

hmmm check to see if there is an update to GTK that you need and see if that fixes…

This not the first time this has happened , in 10.3 had it happened as well .
Have been using SuSE for some 5 years so not the first time to update with YaST .
Compiz-fusion and Emerald have plagued SuSE for some time now , seeing SuSE is the XGL originator doesn’t make sense .
It did occur when I updated marked Compiz-fusion components (XGL-11), so quite sure that is the cause , tried to disable but says no command and get a bash returned (enable or disable) .

hmmm check to see if there is an update to GTK that you need and see if that fixes…

There are no updates available for GTK. Today there were other updates for some compiz components, but the problem still persists.

Same here , was a few XGL updates , but did not fix border problem .
Have to use Kwin if Compiz is selected as “window manager” no border .

Got borders back today with new updates , but now desktop will not rotate with 1 thru 4 selection , mouse and ctrl>alt>arrow r-l keys work but not selecting desktop 1 thru 4 nothing .
After update KDE had 1 (one) desktop selection , I tried setting it to 4 and Plasma crashed and had to reboot .
At least got borders back (in Compiz) .