No UMS support in radeon module; no X

I just performed a clean installation of openSUSE 13.1 on an HP Pavilion 10 TouchSmart 10-e010nr with AMD Radeon HD 8180 graphics. I needed to run the installer with the “no KMS” video option. The installation appeared to work well. Upon reboot, however, attempting to boot into X halts before X begins, with the last message to scroll by being:

OK ] Started LSB: X Display Manager

The openSUSE 13.1 release notes suggest that I try to boot with nomodeset:

https://www.suse.com/releasenotes/x86_64/openSUSE/13.1/#sec.114.kms

However, that parameter is already present on the kernel boot command, presumably as a result of my running the installer with no KMS. Just for laughs I tried booting with that parameter removed; no change.

dmesg | grep radeon says:

[drm] VGACON disable radeon kernel modesetting.
[drm:radeon_init] ERROR No UMS support in radeon module!

Per man radeon, the HD 8000 series is supported.

Searching the web, I found recommendations to try booting with the kernel parameter radeon.modeset=0. Specifically, I tried all of the following, but none brought X to life:

radeon.modeset=0: no change
nomodeset radeon.modeset=0: no change
nomodeset: no change
radeon.modeset=1: froze earlier in the boot process; I could not access the console
nomodeset radeon.modeset=1: kernel panic
(null: none of the above): no change

Finding no further tips either in the release notes or in searching here and the web, I’m out of ideas. What might I try to get X working on this hardware?

When it fails to boot, do you end up with a black screen ? Can you boot to run level 3 ? If you can boot to run level 3 and if you are familiar with command line commands, its possible to mount a USB stick, copy log files (such as /etc/log/Xorg.0.log.old and /var/log/messages) to the USB stick, unmount stick, and then take that file to a PC that does boot, and copy the files to separate http://susepaste.org and post here the URL/web-address where those log message outputs have been copied, for our experts to examine.

Per chance is this machine one of those with both Intel and ATI GPUs??

Can you boot to command line? but a 3 at the end of the linux line in the grub edit window

Well, the radeon module requires Kernel Mode Setting, so it cannot work with the options “nomodeset” or “radeon.modeset=0”.
But, Xorg should fall back to the vesa or fbdev driver then.

Have you maybe created an xorg.conf or modified a file in /etc/X11/xorg.conf.d/ to force X to load the radeon driver?
Revert that change then.

And please post an Xorg log as oldcpu suggested, this should show why Xorg is not using a different driver.

Per man radeon, the HD 8000 series is supported.

Yes.
But I would propose to install the proprietary fglrx driver that fully supports your graphics card anyway on a HD 8000.
https://en.opensuse.org/SDB:AMD_fglrx

radeon does support it according to the man page, but the version included in 13.1 is quite old already (over a year), so it still has problems with “newer” cards.

radeon.modeset=0: no change

That’s the same as nomodeset, but restricted to radeon only. So of course there’s no change.

nomodeset radeon.modeset=0: no change

“radeon.nomodeset=0” is superfluous when you specify “nomodeset”, as nomodeset disables KMS completely anyway.

nomodeset: no change

Well, that’s what you had before, so it’s obvious that there’s no change.

radeon.modeset=1: froze earlier in the boot process; I could not access the console

That’s the complete opposite of nomodeset, i.e. it turns on Kernel Mode Setting. But that’s the default anyway, so not necessary (and radeon doesn’t work without it too, as you noticed yourself already).

nomodeset radeon.modeset=1: kernel panic

Those parameters are conflicting.
You cannot turn off Kernel Mode Setting completely, and then tell radeon to use it.

(null: none of the above): no change

None of the above would be the same as “radeon.modeset=1”.

Finding no further tips either in the release notes or in searching here and the web, I’m out of ideas. What might I try to get X working on this hardware?

See above.
X should start with “nomodeset” at least, if you remove any custom Xorg config.
Then install the fglrx driver.

Thanks all for your help. To answer your queries: In tty7, booting halts apparently when it attempts to start X. tty1 through 6 are available and work, so I have a working command line. I don’t believe this box has an Intel GPU in addition to ATI: the manufacturer’s hardware page and lshw both only mention ATI. I have not created or modified xorg.conf or anything in /etc/X11/xorg.conf.d/ or anything; this is a fresh install.

I attempted to install fglrx per wolfi323’s recommendation; the build failed but the error messages scrolled off the console.

Here are the requested files (created after trying to install fglrx, which in retrospect may have been a mistake):

Xorg.0.log.old http://susepaste.org/73899123
The first 2000 lines or so of /var/log/messages http://susepaste.org/92854912 (the full file is 2.5 MB and too large for SUSEpaste)
Output from lshw http://susepaste.org/77950773

Additional information: This is a second install of openSUSE 13.1 on this hardware. The first installation went fine and X worked out of the box without having to do anything special other than run the installer with the “no KMS” video option. The only thing I did differently on the second install was to encrypt the home partition, which I hadn’t done the first time and is the reason for the re-installation.

Thanks again for everyone’s help.

This shouldn’t matter anyway, as the fglrx driver does support hybrid configurations out of the box.

I have not created or modified xorg.conf or anything in /etc/X11/xorg.conf.d/ or anything; this is a fresh install.

Ok. Still strange that X doesn’t start then.

I attempted to install fglrx per wolfi323’s recommendation; the build failed but the error messages scrolled off the console.

Can you try it again and post the messages?
How did you try to install it exactly?

Maybe redirect the output to a file.

Xorg.0.log.old http://susepaste.org/73899123

This shows that indeed the fbdev driver is used, which would be normal for the “nomodeset” option.
And I don’t see any error in there.

Probably the hang is not related to the graphics driver at all?
Have you tried recovery mode already? (“Advanced Options” in the boot menu).

The first 2000 lines or so of /var/log/messages http://susepaste.org/92854912 (the full file is 2.5 MB and too large for SUSEpaste)

Well, I cannot see anything in there except that error message about missing UMS support in the radeon module that you already told about.
But as I said, this is normal if you use “nomodeset”. The radeon driver/kernel module does not work with nomodeset and tells so.
But the point of nomodeset is in fact to prevent the use of radeon and use a generic driver instead.

Additional information: This is a second install of openSUSE 13.1 on this hardware. The first installation went fine and X worked out of the box without having to do anything special other than run the installer with the “no KMS” video option. The only thing I did differently on the second install was to encrypt the home partition, which I hadn’t done the first time and is the reason for the re-installation.

If the system worked with nomodeset at the first install, it should do so now as well.
Installing fglrx should give you the full graphics potential then, as 13.1’s radeon driver still seems to have problems with your card if nomodeset is necessary (but fglrx should fully support it).

So, I guess the more likely reason for your problem is the encrypted home partition I’d say.
Unfortunately I have no experience with that.

According to your first post the boot halts with “Started LSB: X Display Manager”, I would start with “sudo systemctl status xdm”.
And maybe the output of “mount” and “sudo systemctl /home” might be interesting as well.

Thanks. I did in fact wind up going with AMD’s proprietary driver, available as fglrx, after getting no joy with free and open source alternatives.

Hi,

I am trying to install my own created distro build on Open SUSE but i get errors when booting my live cd.
The error i get is [drm:radeon_init] ERROR No UMS support in radeon module! and the laptop reboots after a couple of minutes.
What can i do to solve this?
It also doesn’t work on a other pc with a Nvidia card. it gives the same sort of error.

Thanks in advance