no Trash

I have a new installation of Tumbleweed.
There is not a Trash Bin on the desktop and I cannot move files to the trash.

Probably a simple fix, but need some help. Thanks.

When I try to move anything to the trash (w right mouse click)
Unable to find or create trash directory for /backups/MovaviPhotoEditorSetupF.exe
dad@dad-pc:~> ls -ld ~/.local/share/Trash/files/
ls: cannot access '/home/dad/.local/share/Trash/files/': No such file or directory
dad@dad-pc:~> ls -lh ~/.local/share/Trash/files/
ls: cannot access '/home/dad/.local/share/Trash/files/': No such file or directory

Could it be a permissions problem? Does the user own his own home directory?

You show there is no ~/.local/share/Trash/files/ directory, but do you have ~/.local/share/Trash?

Anyhow, I would just create these directories:

mkdir -p -m 755 ~/.local/share/Trash/files
mkdir -p -m 755 ~/.local/share/Trash/info

And give it a try.

Is the user GUI KDE, GNOME or, something else?

  • If KDE then, you can drop a “Trash” or “Wastebin” widget on to the Desktop – anywhere on the Desktop or, in the Desktop Folder on the Desktop …

As mentioned previously in this thread, possibly the missing “~/.local/share/Trash/” directory tree but, if KDE then, the KDE initialisation should have set them up …

Thank you all for the help.

The /home dir permissions are me/users
trash is working fine here

The /documents (not in my home dir) and everything else, permissions are root/root owner, group, other are all “view content and modify”
But cannot trash anything in this.
I would think this should work, but it is not.
Should I change the ownership of this drive to users?

I ran without errors. What do I look for now?
mkdir -p -m 755 ~/.local/share/Trash/files
mkdir -p -m 755 ~/.local/share/Trash/info

I am running LXQT

So at this point, I am thinking the error message I get when trying to send something to the trash may be permissions.
Does that sound right, before I change anything?
How to I get a trash bin on the desktop?


Then, I’m backing out of here …

All files and folders in your home must be owned by you not root.

Do you ever log into a GUI as root this can cause ownerships to change.

   		 			 			All files and folders in your home must be owned by you not root.

The /home directory is working fine and is owned by my user.

The problem is two other data directories. Those are the ones that this install has set with root as the owner. However it looks like they are set for anyone to view and modify so other than trash they are working fine. Should the owner of those directories be changed to the user group? Would that solve this?

I’m confused is this “other” directory ie you log into as some other user and that other user does not have trash??? How did you create this other directory and who where you when you did??? Any directory to be used exclusively be a given user should be owned by that user. If you want a shared data area all that need access should be in the same group and the data area should be in that group. It is very unclear what you are doing and why.

You should never ever log into a GUI as root you will break things :open_mouth:


It might be that LXQt does not setup trash when you first login. Since I normally use Plasma (KDE), I would not notice that. By the time that I experiment with LXQt, Trash has already been setup by Plasma.

Here, Trash seems to depend on a file “trash.desktop” in my Desktop folder, as well as “.local/share/Trash”. I would guess you might be missing that “trash.desktop” file. It is probably copied to there from somewhere else on the system, but I’m not sure where.

Template is /usr/share/kio_desktop/directory.trash

I have a specific partition that can be accessed by any of the OS installed. It is my primary data storage area. That is the “other” directory I was referring to. So at install it was simply a mount point to an existing partition. The system set it up as user/root and group/root. That is the directory that will not let me use trash. When I was running Leap 42.2 this wasn’t an issue. However I notice that shift-delete does work.

OK, thank you.

Ok I guess this is a MS FS then?? If so the permissions are faked at mount because MS stuff does not have the same permissions as a true Linux file system. Show us the /etc/fstab

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=1d0b4eae-f9b1-43e7-a0ad-2790930e3374  /                 ext4  noatime                      0  1
UUID=95560983-e4b1-42a7-87b3-b2e20c8feb77  swap              swap  noatime                      0  2
UUID=0652B937439E6BDA                      /backups          ntfs  defaults                     0  0
UUID=cce38ff5-440e-4c90-b5bc-7923a640fb70  /openSuse15_root  ext4  defaults                     0  2
UUID=9e4b2cbe-4227-49f6-bc01-c133785b592d  /home             ext4  data=ordered,acl,user_xattr  0  2
UUID=420EFA6B0EFA56FF                      /windows-D        ntfs  defaults                     0  0
UUID=F84ECD3B4ECCF402                      /windows-C        ntfs  defaults                     0  0

Please show

ls -ld /windows*

dad@dad-pc:~> ls -ld /windows*
drwxrwxrwx 1 root root 24576 Jan 21 18:59 /windows-C
drwxrwxrwx 1 root root  4096 Feb 10 12:49 /windows-D

Windows-C is the primary drive with applications
Windows-D is the data drive

I am 99% linux, except when tax time comes around. The application we use does not run well on Wine, so that is one of the rare times we boot to Windows. All data is on the Windows-D, for any OS I run.

Did some digging as the comment above rang a bell about windows partitions needing more specifics in fstab. Below solved the permissions and access.

UUID=420EFA6B0EFA56FF                      /windows-D        ntfs-3g    uid=dad,gid=users,umask=0022    0 0

UUID=F84ECD3B4ECCF402                      /windows-C        ntfs-3g    uid=dad,gid=users,umask=223    0 0

the first one is r/w/e
the second one is basically read only

Now the right mouse click, send to trash is working.

So, now to the second part of my initial request for help. How do I place a trash bin on the desktop?