no sound

hi, i have problem with my sound card. i am using HCL notebook, audio card is realtek alc660@sis high definition audio controller. i am using kde environment.

Thanks for that.

Try working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

To test if your sound is working, I recommend you try copy and pasting the following into a gnome-terminal or a kde konsole:speaker-test -Dplug:front -c2 -l5 -twavyou should hear a lady’s voice saying “front-left”, “front-right” five times. Note Linux is case sensitive.

If that does not work, try a shorter form version:speaker-test -c2 -l5 -twavIf you hear sound (ie if you hear the lady’s voice), then please post here, let us know this fact, and explain more as to what your sound problem might be.

If that does not work, and if you do not hear the lady’s voice, then we need more information to help solve your problem. To provide more information, with your PC connected to the internet copy and paste the following into a gnome-terminal or konsole:

wget -O && bash 

When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal or konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Once I have that information, I believe I may be able to provide helpful recommendation(s).


I’m having a similar problem: sound works intermittently. When it stops working, I have to execute yast2|hardware|sound|edit and click on “Reset all”; then sounds works for a while.

I have a Gateway HDMI laptop with OpenSuSE 11. Yast detects two sound cards:

82801H (ICH8 Family) HD Audio Controller
RV630/M76 audio device [Radeon HD 2600 Series]

I ran the sugested scripts and the output is the following:

Your ALSA information is located at

Please inform the person helping you.

> rpm -qa | grep alsa
> rpm -qa | grep pulse
> rpm -q libasound2
> uname -a
Linux chipi #1 SMP 2008-10-21 16:30:26 +0200 i686 i686 i386 GNU/Linux
> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel,snd-hda-intel

NXNs.vgutMGDgtYF:RV630/M76 audio device [Radeon HD 2600 Series]

alias snd-card-0 snd-hda-intel

u1Nb.2mUELP7kxbC:82801H (ICH8 Family) HD Audio Controller

alias snd-card-1 snd-hda-intel

I would really appreciate any help on this.

There is a BIG difference between sound working intermittently and sound not working at all. Typically, they are not similar.

Was that script run with your sound working? or not working?

As far as I can tell from that script, your configuration is fine, although at 18% your PCM levels are so low, it may not be possible to hear sound.
Simple mixer control ‘PCM’,0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Front Left: Playback 45 [18%] -42.00dB]
Front Right: Playback 45 [18%] -42.00dB]Restarting your sound system could have moved up your PCM levels. Next time you think you have lost your sound, check your mixer and check your PCM levels.

Now assuming that does not work, you need to provide a better indication as to “cause and effect”. What program, that uses audio, were you running last when your sound was working? What program, were you trying now, that has no audio?

To help you figure this out, you could run the following when your sound is working, by copying and pasting the following line into a gnome-terminal or konsole (and record the output), and also run the same when they don’t work. lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*and compare the outputs of the two.

Note your Gateway has a stac9205, and I also researched this on alsa, and obtained the following hits, indicting there has not been much in the way of updates since 1.0.16 of alsa (which you have):

Also, after your investigative efforts are finished, and you wish to get your sound system working, instead of going into yast, you could try typing in an xterm/konsole:su -c ‘rcalsasound restart’ Enter root password when prompted for a password. You may need to manually restart your mixer after that.

jafg, … before I forget … welcome to openSUSE Linux and welcome to our forum.

thank you sir
i tried speaker test but I found no sound.
I pasted the code in konsole and found output as follows
linux-5gki:~ # rpm -qa | grep alsa
linux-5gki:~ # rpm -qa | grep pulse
linux-5gki:~ # rpm -q libasound2
linux-5gki:~ # uname -a
Linux linux-5gki #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux
linux-5gki:~ # cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel

_+Pw.gBxY3S_STw9:Azalia Audio Controller

alias snd-card-0 snd-hda-intel

Thanks for that. Can you also run the script I asked? If you can not post a URL (because you have insufficient posts) then put code ] and / code ] brackets around it. Do that by highlighting the URL, and then press on the " # " icon about the box for entering your message:

whattodo, you should have sufficient posts. Just post the URL. Thanks.

Hi again,

I followed your advice given to whattodo:

“Try working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE”

and after reconfiguring the card, I have not experienced the problem again.

So, it could be that the initial configuration was wrong or that some application could have moved down the PCM levels.

I’ll keep observing to see the problem shows up again.

Thanks a lot for your advices

I am a new user of openSUSE Linux and my sound does not work at all. I have run recommended commands and there results are below.
Please help me.

Your ALSA information is located at

Please inform the person helping you.

hana@linux-vnm6:~> rpm -qa | grep alsa
hana@linux-vnm6:~> rpm -qa | grep pulse
hana@linux-vnm6:~> rpm -q libasound2
hana@linux-vnm6:~> uname -a
Linux linux-vnm6 #1 SMP 2008-10-21 16:30:26 +0200 i686 athlon i386 GNU/Linux
hana@linux-vnm6:~> cat /etc/modprobe.d/sound

options snd slots=snd-cmipci

WL76.leFtcOMtGx0:CMI8738/C3DX PCI Audio Device

alias snd-card-0 snd-cmipci

Your alsa version appears to be ok. Did you restart after installing alsa-firmware?

Thanks for the script output.

Nothing strikes me as being really bad there.

I note you have a CMI-8738. Searching on that, I get this: Search results - AlsaProject
I could find no new updates.

You could try tune your mixer a bit:Simple mixer control ‘Master’,0
Front Left: Playback 13 [42%]
Front Right: Playback 26 [84%]
Simple mixer control ‘3D Control - Switch’,0
Mono: Playback [off]Maybe balance your master at 80%. And try switch on your 3D control.

Are you using an ndiswrapper?

What happens if you restart alsa with: su -c ‘rcalsasound restart’ #and enter root password when prompted for a password. Then test your sound.

Dear Oldcpu,
I am very gratefull to you, because you advise helped me to solve my problem. I Kmix I have set switch IEC958 In Monitor to “light yellow”. What is the use of an ndiswrapper?
Good night.
With best wishes
Jirka (pospij2)