No Sound with fresh install of 15.0

This laptop recently got a fresh install of LEAP 15.0, but it now has no sound whatsoever. I’ve tried with speaker-test from CLI, test sound from YAST, several apps, etc.

All codecs are installed and updated to packman versions.

Pavucontrol is installed. All levels are appropriate, and the configuration is pointing to the Analog Stereo Duplex as expected.

:~ # lspci -nn |grep -i audio
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)
:~>:~> speaker-test -Dplug:front -c2 -l5  

speaker-test 1.1.5

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Playback open error: -16,Device or resource busy
:~> speaker-test -c2 -l5 -twav

speaker-test 1.1.5

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Time per period = 3.039437
 0 - Front Left
 1 - Front Right
Time per period = 3.031559
 0 - Front Left
 1 - Front Right
Time per period = 3.024431
 0 - Front Left
 1 - Front Right
Time per period = 3.039000
 0 - Front Left
^C 1 - Front Right
Transfer failed: Bad address
:~ # aplay -ll
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CX8200 Analog [CX8200 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

(I expected to see “CX8200 Analog” as the only one to be designated “card 0”, but that’s not the case. Am I mistaken?)

Contents of 50-sound.conf are:

options snd slots=snd-hda-intel

nS1_.T4VXuKCjnQ3:Intel Corporation

alias snd-card-0 snd-hda-intel

ALSA information is located here

there are known issues with intel sound chips try the suggestions at

Thank you for the suggestion, however I have already spent a couple of hours working on this issue, in large part following the suggestions on that page… all without any success. I must say that page is quite well written, however it is badly in need of review in light of some changes in Leap 15.0. For instance: one line mentions

…the file /usr/src/KERNEL_VERSION/Documentation/sound/alsa/ALSA-Configuration.txt search for the codec…

yet I can find no KERNEL-VERSION folder at that location, nor can I find ALSA-Configuration.txt.

But, I digress. The bottom line is that I would suspect that any hardware issues that would make any of those proposed fixes necessary would have been needed with 42.2 or 42.3 and this PC’s sound worked OTB with both earlier versions of openSUSE. Is there a factor that I’m not aware of?

BTW, I did try modifying the 50-sound.conf as follows, but with no positive result

options snd slots=snd-hda-intel index=0 model=auto vid=8086 pid=9d71

nS1_.T4VXuKCjnQ3:Intel Corporation

alias snd-card-0 snd-hda-intel

Perhaps I made an error in syntax or whatever?

The kernel-firmware is installed ?

I haven’t had time to go through your alsa diagnostic output, but check that nothing applicable is muted.

Just in case the following is helpful…

Checked and confirmed, thanks

Thanks for the suggestion, however the fix offered there did not help.

did sound ever work on that machine or is this the first Linux installation on it as I remember reading a thread about sound on some intel devices not working at all this was a driver issue I think the fix was using a newer kernel but I’m not quite sure

I note an Conexant CX8200. I think this pretty new. You could also try installing alsa-firmware, but I just took a look at the rpm content for Leap-15.0 (of alsa-firmware) and I can not see any firmware specific to the Conexant CX8200.

My assumption is you are NOT using HDMI for audio. Please advise me if my assumption is wrong.

I would like to determine if the issue is at the alsa driver level, or at the pulse audio level.

Please could you send each of the following 2 commands in a terminal, and advise if either one yields sound. If neither yields sound then I suspect the problem is at the alsa sound driver level.

aplay -D hw:0,0 -vv /usr/share/sounds/alsa/test.wav 

Now try the above again, but this time with pulse audio suspended

pasuspender -- aplay -D hw:0,0 -vv /usr/share/sounds/alsa/test.wav

Let me know if either yields sound.

Also, if you get any errors with any of the above, please post the errors.

I recall an old bug report that the CX8200 is supposed to be equivalent with CX20724. That information may be useful later if we have issues.

What happens if the openSUSE Leap 15 Codecs are installed?

  • Yes, yes, I know, not all (Video) formats are supported but, AFAIK, these days, there ain’t so many Audio formats which are ** not ** supported by the openSUSE Codecs …

Sound worked OTB with 42.2 & 42.3


Today I had to go on the road before I’d even had time to investigate any of the fixes so kindly offered by any of those who posted yesterday. Of course I had to shut off the laptop for the trip. I just now got in and booted it back up. It had been rebooted before several times since the last time I worked on this issue, so this boot should have been no different. However, to my great surprise, I now have sound!

On the one hand that’s very good news, as I’ve got what I wanted.

On the other hand that’s very frustrating, because I will likely never know what changed or be able to share what the resolution might have been.

FWIW, I’ve read of accounts where Windows has left audio hardware in a strange state (firmware still loaded or some flag set?) such that there is no audible sound following a reboot to Linux despite all seeming ok. Affected users often claim a full power down is needed to restore working audio. I wonder if something like that transpired here? Just a thought.

Very interesting thought.

The only data I can offer is that I did boot into Windows 10 very briefly right after the installation of Leap 15, just to confirm that duel boot was working. I hadn’t tried sound prior to that. I did reboot several times since then, but it was always just a “reboot”. Last night was the first time I’d actually left the machine powered down for any significant length of time. It seems a little far fetched to conclude that the longer down time would make that much difference, but I’ve seen stranger things happen, so who knows.

Your opinion?

Reviewing your diagnostic info (shared in your opening post), I note that the speaker output was muted…

Node 0x11 [Audio Output] wcaps 0xc1d: Stereo Amp-Out R/L
  Control: name="Speaker Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Control: name="Speaker Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Amp-Out caps: ofs=0x4a, nsteps=0x4a, stepsize=0x03, mute=1
  Amp-Out vals:  [0x37 0x37]
  Converter: stream=1, channel=0
    rates [0x540]: 48000 96000 192000
    bits [0xa]: 16 24
    formats [0x1]: PCM
  Power states:  D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0

Good catch, thanks.

Very interesting insomuch as I’ve made no changes since the diagnostic script was run, though I had checked Pavucontrol et al. and not seen anything muted. I’m real reluctant to attribute a change like that to the reboot, but I’m at a loss to explain it otherwise.

After two months of tracking this I can now confirm that a full power down, with at least 10 seconds of power off, is required to ‘reset’ whatever is causing this issue. I’m currently working on a project that requires me to use Win 10 from time to time. I have no sound in 15.0 every time I forget to power this computer down completely after using Win 10.

In summary:
Fresh boot into Leap 15.0 = sound is OK
Boot into Windows 10 then reboot = no sound at all, though no settings have changed since it worked in 15.0
Power off for 10 sec. +, then boot Leap 15.0 = fully functional sound

I’d suggest disabling fast boot in windows 10 as that does not do a full power-off but it’s a hybrid hibernation which I’m guessing is the cause of your issue if a reboot from LEAP to LEAP (with a 10 wait period) fixes the issue