No sound when recording with Krecord or in Skype

Hello there.

Since upgrading to openSuse 11.1 and KDE 4.2, I can’t record with Krecord nor I can’t hear any sound when calling the Skype test Call.

I did uninstall pulseaudio related packages, so now I’m all on ALSA again. My sound card specs:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
        Subsystem: Dell Device 01bd                                                                   
        Flags: bus master, fast devsel, latency 0, IRQ 21                                             
        Memory at efffc000 (64-bit, non-prefetchable) [size=16]                                      
        Capabilities: [50] Power Management version 2                                                 
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Count=1/1 Enable-               
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00                           
        Capabilities: [100] Virtual Channel <?>                                                       
        Capabilities: [130] Root Complex Link <?>                                                     
        Kernel driver in use: HDA Intel                                                               
        Kernel modules: snd-hda-intel                 

When I go to Skype -> Options -> Sound devices I have these settings to choose for Input, Output and Ringing. It’s set Default device for all 3 of them.

Where you can thick under those settings: “Allow Skype to automatically adjust my mixer levels”, I have unthicked.

However I don’t think this is the skype issue since I can’t record my voice with Krecord.

Any help tips would be much appreciated.
Thank you![/size]

Is your microphone working properly? Test your microphone whether it is working with other application or not.