No Sound via headphones

Hi all!
New user of OpenSuse & Linux in general.
I originally used to run Ubuntu on a VM, then tried Mint & Xubuntu… finally OpenSuse & totally loving it.
I’ve spent a lot of time getting things to work & like how opensuse feels… and don’t want to change.

I am dual booting OpenSuse 13.1 on a late 2012 iMac

I was able to get Sound to work by playing around with the general settings.
However, i’ve not been able to get sound through the headphone jack.
Have tried multiple earphones & speaker systems…

So, i tried my luck with this thread -

These are the contents of my /etc/50-sound.conf

options snd slots=snd-hda-intel,snd-hda-intel# u1Nb.RlhQY3YvZ59:Intel Corporation
alias snd-card-0 snd-hda-intel

NXNs.I5tmKNlvQN5:nVidia Corporation

alias snd-card-1 snd-hda-intel

And this is my sound codec

letmedanz@linux-1j4l:~$ sudo head -n 1 /proc/asound/card0/codec*root’s password:
Codec: Cirrus Logic CS4206

Adding few sound related screenshots](](](](

Install pavucontrol and configure your headset there.

Thank you.
Through pavucontrol, i can view & adjust all the sliders…
Made changes with the port at ‘headphones’ & combinations of all other options too.
No change.

To add, the /etc/50-sound.conf are as default

Did you play a soundfile when you configure with pavucontrol?
Pulseaudio is enabled in Yast-----Hardware-----Sound:
Its your first Picture, click on others----Pulseaudio-Konfiguration?

Appreciate your help on this Sauerland.

Yes, i was playing a track on youtube while adjusting the settings in pauvcontrol.

And yes, PulseAudio support is enabled](

Play a sound and check in pavucontrol if the sound is playing on the right output (Headphone)ärkeregler_153.jpg

You may also try changing the order of the drivers. Try NVIDIA as the first driver

On 09/19/2014 11:56 AM, letmedaz wrote:

I had similar issue. I inserted in 50-sound.conf the model of my audio
system, in pavcontrol I have output speakers instead of analog output,
and for now it’s working ok

openSuSe 13.1

There are a number of possibilities. Its also possible your headphones are muted in your mixer. If you run a diagnostic script and share its output (via an automated web upload/address) we can take a look (do a Quality Assurance check) at your settings. To run the script, with PC connected to the internet, type in a konsole/xterm the command:


and select the SHARE/UPLOAD option. Then when the script completes, look in the terminal/xterm and it will have posted a URL/address there where the script is located. Please copy that URL/address here.

Hi Sauerland,

Tried it…
i can see that the sound is playing, as the bar keeps jumping about.
But no go with ANY of the options in pavucontrol](](

hmmm… i wasn’t actually able to change them as ‘preferred’ device, but just ordering in the list…
not sure if that’s what you meant?
if not am not sure how to change the ordering of the devices…?

The thing is when i added the model number to ‘CS4206’, i get an error & cannot save to proceed.
Am assuming the model number is incorrect?

Thanks oldcpu
Here is the ALSA information -

appreciate all of your help…
thank you

I have tried that script, seems nice but when i select the update option my /usr/sbin/ is empty, the file exists and still executable.

ls /usr/sbin/ 

file /usr/sbin/ 
/usr/sbin/ empty

Maybe i am the bug :).

Highlight the second one then in other select make primary This should change the order of the list. or you can delete then add them back in in the order you want, but first be sure you write down the card details since you would need to manually select from a very long list.

Unfortunately there was a corrupted update to that script, which replaces the script with a file with no content. The only way to get the script back is to force a re-install of alsa.

Its clear from the script. … Your mixer has your headphones muted :

**Simple mixer control 'Headphone',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Front Left: Playback 0 **[0%]** -57.50dB] **[off]**
  Front Right: Playback 0 **[0%]** -57.50dB] **[off]**

You need to unmute your headphones in your mixer.

Try this command in a konsole/xterm (to turn on your headphones) in your mixer:

amixer -c0 sset 'Headphone' on 100%

On doing that, i get this-

letmedanz@linux-1j4l:~$ amixer -c0 sset 'Headphone' on 100%Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Front Left: Playback 127 [100%] [6.00dB] [on]
  Front Right: Playback 127 [100%] [6.00dB] [on]

but no sound yet via heaphones jack…
i tried varying combinations of all settings in pavucontrol, no go :frowning:

That appears to be an improvement.

Can you run the script again please … ? and post here the output link. Maybe something else was muted at the same time.


Ok, but i have found a way to get it directly though.

curl -Lsf '' > /usr/sbin/