No sound since upgrading to 11.3

Here is another topic on no sound from the sound card. It was working fine in 11.2 but not now. This was a clean install of 11.3 not an upgrade, whilst leaving my home directory alone. This is no sound from system, Amarok, web browser.>:(

Acer laptop, Intel soundcard.

I have followed this but it made no difference.

These are the outputs;
rpm -q alsa alsa-utils alsa-firmware

No sound from this;
speaker-test -Dplug:front -c2 -l5 -twav

No sound from this;
speaker-test -c2 -l5 -twav

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version

cat /proc/asound/modules
0 snd_hda_intel

cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf0240000 irq 28

KMix is showing Master and PCM chanels at 75%, I have deleted my sound card and added another with no difference.

Here is the alsaconf output

What I haven’t done is mucked around with the kernel. Pulse is not installed, I have tried Xine, GStreamer and VLC backends. KDE is at 4.4.5.

Any help please, this is really frustrating. 11.2 had sound card issues which I managed to solve eventually, whilst not really knowing what I did to fix it.

I have run out of ideas now.

Please, what is output of:

rpm -qa '*alsa*'
rpm -q libasound2
rpm -qa '*pulse*'

instead of ‘just’ deleting your sound card (in yast) try removing the file /etc/modprobe.d/50-sound.conf and then restarting and testing sound.

Also, did you try forcing an alsa sound restart with:

su -c 'rcalsasound restart'

I assume when running those speaker tests, you tested not only as a regular user, but also using root permissions in a terminal ? And you test with both regular speakers and headphones?

Thanks for the quick reply.

rpm -qa ‘alsa

rpm -q libasound2

rpm -qa ‘pulse

I have deleted the sound.conf file and gone through Yast to regenerate the file again. Unfortunately no change.

I assume when running those speaker tests, you tested not only as a regular user, but also using root permissions in a terminal ? And you test with both regular speakers and headphones?

I don’t have any headphones at hand at the moment, I’ll try tomorrow. All tests were done as a regular user, I’ll try as root tomorrow.

So I have installed openSUSE on several computers. One of those is an Intel chipset and HD Audio. Anyway, I noticed that I had no sound in anything and in KDE / Personnel Settings / Multimedia, the only entry was PulseAudio. So, I opened up a Terminal session, enter su - and the root password and then I disabled PulseAudio with the following terminal command.

su - (root password)
setup-pulseaudio --disable

After this command, when I went back to the Multimedia section, it was repopulated with the correct devices and my audio was working again. Since everything is working, I don’t appear to need PulseAudio. While I could uninstall PulseAudio, I decided to not do that just in case I was wrong, but not so far.

Thank You,

Did you run the Alsa tests under your user or root?

I installed 11.3 LXDE edition and had the same problem. Figured out that it was a permissions problem, because it would always produce sound under root.

I fixed it by adding my user to the “audio” group. You can do this in Yast, edit the user, add him to the audio group, and logout and log back in. It has worked for me ever since.

(Also, HAPPILY found out the LXDE edition does not use Pulseaudio)

I believe Pulse is disabled, but I’ll check again anyway. I’m sure I have added myself to the Audio group, but I’ll check again. I haven’t checked the audio through root, another job to check when I get back later.

I do not have access to my laptop at the moment as I am at work, so I’ll check later.

Well go figure this one out. Just did the test with the headphones. As I don’t have a need for headphones, I have it muted. I unmuted it for this test and the sound is back, mute the headphones and the sound disappears WTF!

Since when did the headphones get mapped to the main speakers? The sound is a little different also, seems to be a little muted, could this be the mapping?

For what it’s worth I am part of the audio group already and guess what, sound works through the headphones as well.

Guys, I really appreciate your help on this. Any advice on the headphone mapping, I’m pretty sure this was not there before.

Well done on determining this strange behaviour.

I recommend you write a bug report on openSUSE component “sound” on openSUSE-11.3.

Attach (don’t copy and paste, but attach) to the bug report the text file from running:

/usr/sbin/ --no-upload

and that will create the file /tmp/alsa-info.txt which can be added as an attachment. That has bunch of technical info that may show the alsa dev what is wrong with the alsa driver, IF you also describe the audio symptoms.

Note the SuSE-GmbH packager for sound is also an alsa developer, and if he fixes this, the fix gets sent upstream and ALL Linux distributions will benefit from your efforts with him.

There is guidance here for raising bug reports: Submitting Bug Reports - openSUSE … The alsa developer/openSUSE packager, may ask that you try a few different alsa versions, and hence if your schedule is too busy for such support (and I definitely know what that can be like) then its probably best NOT to write such a bug report.

Don’t reference this thread, as the SuSE-GmbH packager refuses to read forum threads. Note that its important the bug report has all the salient information so you will need to restate such information in the bug report.

Good luck !!

I love you! :smiley:

I was having difficulty getting the sound to work in a Xephyr-based multiseat setup. Adding the relevant users to the audio group has fixed this instantly.

Thank you!